summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-01-29 09:51:13 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-01-29 09:51:13 +0000
commit7f7b86b5fc8fa8a10826dfb12e742a69377a3732 (patch)
tree4ece2742a2032ccfa78944b506793d567958d7b4 /sci-mathematics/freemat
parentEAPI=2; respect CC (diff)
downloadgentoo-2-7f7b86b5fc8fa8a10826dfb12e742a69377a3732.tar.gz
gentoo-2-7f7b86b5fc8fa8a10826dfb12e742a69377a3732.tar.bz2
gentoo-2-7f7b86b5fc8fa8a10826dfb12e742a69377a3732.zip
Added qt-svg dependency, switch to eapi 2
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/freemat')
-rw-r--r--sci-mathematics/freemat/ChangeLog7
-rw-r--r--sci-mathematics/freemat/freemat-3.6.ebuild26
2 files changed, 15 insertions, 18 deletions
diff --git a/sci-mathematics/freemat/ChangeLog b/sci-mathematics/freemat/ChangeLog
index 294498deedee..935d8c285959 100644
--- a/sci-mathematics/freemat/ChangeLog
+++ b/sci-mathematics/freemat/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/freemat
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/ChangeLog,v 1.14 2008/08/06 20:27:08 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/ChangeLog,v 1.15 2009/01/29 09:51:12 bicatali Exp $
+
+ 29 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org> freemat-3.6.ebuild:
+ Added qt-svg dependency, switch to eapi 2
06 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sci-mathematics/freemat/freemat-3.6.ebuild b/sci-mathematics/freemat/freemat-3.6.ebuild
index d1c45665a175..b4109a78b838 100644
--- a/sci-mathematics/freemat/freemat-3.6.ebuild
+++ b/sci-mathematics/freemat/freemat-3.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/freemat-3.6.ebuild,v 1.5 2008/07/27 14:22:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/freemat-3.6.ebuild,v 1.6 2009/01/29 09:51:13 bicatali Exp $
-EAPI="1"
+EAPI="2"
inherit eutils autotools fdo-mime
MY_PN=FreeMat
@@ -17,35 +17,31 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="|| ( ( x11-libs/qt-gui:4 x11-libs/qt-opengl:4 )
- =x11-libs/qt-4.3*:4 )
+RDEPEND="|| ( ( x11-libs/qt-gui:4 x11-libs/qt-opengl:4 x11-libs/qt-svg:4 )
+ x11-libs/qt:4[opengl] )
dev-libs/libpcre
virtual/lapack
virtual/opengl
ncurses? ( >=sys-libs/ncurses-5.4 )
umfpack? ( sci-libs/umfpack )
arpack? ( sci-libs/arpack )
- fftw? ( >=sci-libs/fftw-3:3.0 )
+ fftw? ( sci-libs/fftw:3.0 )
portaudio? ( media-libs/portaudio )
ffcall? ( dev-libs/ffcall )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-QT4_BUILT_WITH_USE_CHECK="opengl"
-
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
# allow enable/disable for configure
epatch "${FILESDIR}"/${P}-optional-deps.patch
epatch "${FILESDIR}"/${P}-includes.patch
eautoreconf
}
-src_compile() {
+src_configure() {
econf \
--with-blas="$(pkg-config --libs blas)" \
--with-lapack="$(pkg-config --libs lapack)" \
@@ -54,9 +50,7 @@ src_compile() {
$(use_enable arpack) \
$(use_enable fftw) \
$(use_enable portaudio) \
- $(use_enable ffcall) \
- || die "econf failed"
- emake || die "emake failed"
+ $(use_enable ffcall)
}
src_install() {
@@ -66,7 +60,7 @@ src_install() {
make_desktop_entry FreeMat FreeMat
}
-pkg_postint() {
+pkg_postinst() {
fdo-mime_desktop_database_update
elog "Before using ${MY_PN}, do (as a normal user)"
elog "FreeMat -i /usr/share/${MY_P}"