summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-05 18:49:54 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-05 18:49:54 +0000
commitd8fac1a09af6c77d9066839a5028ff1d4467bc16 (patch)
tree2752e69f1844f16e2f136671ff661e238fe656b0 /sci-mathematics/form
parentsys-kernel/aufs-sources: Fix for latest aufs, #490461 (diff)
downloadgentoo-2-d8fac1a09af6c77d9066839a5028ff1d4467bc16.tar.gz
gentoo-2-d8fac1a09af6c77d9066839a5028ff1d4467bc16.tar.bz2
gentoo-2-d8fac1a09af6c77d9066839a5028ff1d4467bc16.zip
sci-mathematics/form: Version BUmp, #490390
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-mathematics/form')
-rw-r--r--sci-mathematics/form/ChangeLog9
-rw-r--r--sci-mathematics/form/form-4.1.ebuild82
-rw-r--r--sci-mathematics/form/metadata.xml12
3 files changed, 95 insertions, 8 deletions
diff --git a/sci-mathematics/form/ChangeLog b/sci-mathematics/form/ChangeLog
index 24a31872bdf2..6f3e7881f8af 100644
--- a/sci-mathematics/form/ChangeLog
+++ b/sci-mathematics/form/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/form
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/form/ChangeLog,v 1.4 2012/06/01 21:17:19 tomka Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/form/ChangeLog,v 1.5 2013/11/05 18:49:54 jlec Exp $
+
+*form-4.1 (05 Nov 2013)
+
+ 05 Nov 2013; Justin Lecher <jlec@gentoo.org> +form-4.1.ebuild, metadata.xml:
+ Version BUmp, #490390
01 Jun 2012; Thomas Kahle <tomka@gentoo.org> form-4.0_p20120529.ebuild:
keyworded ~amd64 after request on sci-ml
diff --git a/sci-mathematics/form/form-4.1.ebuild b/sci-mathematics/form/form-4.1.ebuild
new file mode 100644
index 000000000000..903260298fe4
--- /dev/null
+++ b/sci-mathematics/form/form-4.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/form/form-4.1.ebuild,v 1.1 2013/11/05 18:49:54 jlec Exp $
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="Symbolic Manipulation System"
+HOMEPAGE="http://www.nikhef.nl/~form/"
+SRC_URI="http://www.nikhef.nl/~form/maindir/binaries/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devref doc doxygen gmp mpi threads zlib"
+
+RDEPEND="
+ gmp? ( dev-libs/gmp )
+ mpi? ( virtual/mpi )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ devref? ( dev-texlive/texlive-latex )
+ doc? ( dev-texlive/texlive-latex )
+ doxygen? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i 's/LINKFLAGS = -s/LINKFLAGS =/' sources/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-scalar \
+ --enable-largefile \
+ --disable-debug \
+ --disable-static-link \
+ --with-api=posix \
+ $(use_with gmp ) \
+ $(use_enable mpi parform ) \
+ $(use_enable threads threaded ) \
+ $(use_with zlib ) \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}"
+}
+
+src_compile() {
+ default
+ if use devref; then
+ pushd doc/devref > /dev/null || die "doc/devref does not exist"
+ LANG=C emake pdf
+ popd > /dev/null
+ fi
+ if use doc; then
+ pushd doc/manual > /dev/null || die "doc/manual does not exist"
+ LANG=C emake pdf
+ popd > /dev/null
+ fi
+ if use doxygen; then
+ pushd doc/doxygen > /dev/null || die "doc/doxygen does not exist"
+ emake html
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+ if use devref; then
+ insinto /usr/share/doc/${PF}
+ doins doc/devref/devref.pdf
+ fi
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/manual/manual.pdf
+ fi
+ if use doxygen; then
+ dohtml -r doc/doxygen/html/*
+ fi
+}
diff --git a/sci-mathematics/form/metadata.xml b/sci-mathematics/form/metadata.xml
index c9a2a9712cae..05d73a9db6bb 100644
--- a/sci-mathematics/form/metadata.xml
+++ b/sci-mathematics/form/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<longdescription lang="en">
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
A system which can efficiently manipulate huge formulas limited only by available disk space.
</longdescription>
-<use>
- <flag name='devref'>Build and install developers reference</flag>
- <flag name='doxygen'>Build and install API documentation</flag>
-</use>
+ <use>
+ <flag name="devref">Build and install developers reference</flag>
+ <flag name="doxygen">Build and install API documentation</flag>
+ </use>
</pkgmetadata>