summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-08-03 12:06:54 +0000
committerMark Wright <gienah@gentoo.org>2013-08-03 12:06:54 +0000
commitc96a608af8a1380a01fd2a047d74f40746b5be08 (patch)
treeb02d6d8d449fa763c7516a16665c106a0fafb8dc /sci-mathematics/coq
parentMigrate to distutils-r1. (diff)
downloadgentoo-2-c96a608af8a1380a01fd2a047d74f40746b5be08.tar.gz
gentoo-2-c96a608af8a1380a01fd2a047d74f40746b5be08.tar.bz2
gentoo-2-c96a608af8a1380a01fd2a047d74f40746b5be08.zip
Bump coq to 8.4pl2 / coq-8.4_p2.
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics/coq')
-rw-r--r--sci-mathematics/coq/ChangeLog7
-rw-r--r--sci-mathematics/coq/coq-8.4_p2.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index 3eb70d962423..b24776ca7a7a 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/coq
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.78 2013/04/15 08:47:14 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.79 2013/08/03 12:06:54 gienah Exp $
+
+*coq-8.4_p2 (03 Aug 2013)
+
+ 03 Aug 2013; Mark Wright <gienah@gentoo.org> +coq-8.4_p2.ebuild:
+ Bump coq to 8.4pl2 / coq-8.4_p2.
15 Apr 2013; Agostino Sarubbo <ago@gentoo.org> coq-8.4_p1.ebuild:
Stable for x86, wrt bug #460136
diff --git a/sci-mathematics/coq/coq-8.4_p2.ebuild b/sci-mathematics/coq/coq-8.4_p2.ebuild
new file mode 100644
index 000000000000..5ef36b277341
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.4_p2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.4_p2.ebuild,v 1.1 2013/08/03 12:06:54 gienah Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Coq is a proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="http://${PN}.inria.fr/V${MY_PV}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk debug +ocamlopt doc camlp5"
+
+RDEPEND=">=dev-lang/ocaml-3.11.2[ocamlopt?]
+ camlp5? ( >=dev-ml/camlp5-6.02.3[ocamlopt?] )
+ gtk? ( >=dev-ml/lablgtk-2.10.1[ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? (
+ media-libs/netpbm[png,zlib]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-tex/xcolor
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-mathextra
+ dev-texlive/texlive-latexextra
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ ocaml_lib=`ocamlc -where`
+ local myconf="--prefix /usr
+ --bindir /usr/bin
+ --libdir /usr/$(get_libdir)/coq
+ --mandir /usr/share/man
+ --emacslib /usr/share/emacs/site-lisp
+ --coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ --docdir /usr/share/doc/${PF}
+ --configdir /etc/xdg/${PN}
+ --lablgtkdir ${ocaml_lib}/lablgtk2"
+
+ use debug && myconf="--debug $myconf"
+ use doc || myconf="$myconf --with-doc no"
+
+ if use gtk; then
+ use ocamlopt && myconf="$myconf --coqide opt"
+ use ocamlopt || myconf="$myconf --coqide byte"
+ else
+ myconf="$myconf --coqide no"
+ fi
+ use ocamlopt || myconf="$myconf -byte-only"
+ use ocamlopt && myconf="$myconf --opt"
+
+ use camlp5 || myconf="$myconf --usecamlp4"
+ use camlp5 && myconf="$myconf --camlp5dir ${ocaml_lib}/camlp5"
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure $myconf || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 || die "make failed"
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install || die
+ dodoc README CREDITS CHANGES
+
+ use gtk && make_desktop_entry "/usr/bin/coqide" "Coq IDE" "/usr/share/coq/coq.png"
+}