summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-02-15 06:46:47 +0000
committerMark Wright <gienah@gentoo.org>2015-02-15 06:46:47 +0000
commitad1984717216645c52fc605c8eb60b9a80e58d6d (patch)
tree60fdfd2ab68af2535019df6d36eeb2d61d3049e4 /sci-mathematics/coq
parentSwitch to matching versions as the SLOT in older versions is changing #528196. (diff)
downloadgentoo-2-ad1984717216645c52fc605c8eb60b9a80e58d6d.tar.gz
gentoo-2-ad1984717216645c52fc605c8eb60b9a80e58d6d.tar.bz2
gentoo-2-ad1984717216645c52fc605c8eb60b9a80e58d6d.zip
Fix generation of /usr/share/doc/coq-8.4_p5/html/refman/index_urls.txt, patch from upstream: http://lists.gforge.inria.fr/pipermail/coq-commits/2014-October/013582.html. Replace sed to avoid installing revision with patch. Patch Makefile.build to avoid deleting html/refman/index_urls.txt in the test phase and then failing to install with FEATURES=test and USE=doc
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics/coq')
-rw-r--r--sci-mathematics/coq/ChangeLog14
-rw-r--r--sci-mathematics/coq/coq-8.4_p5.ebuild18
-rw-r--r--sci-mathematics/coq/files/coq-8.4_p5-do-not-install-revision.patch19
-rw-r--r--sci-mathematics/coq/files/coq-8.4_p5-hevea.patch11
-rw-r--r--sci-mathematics/coq/files/coq-8.4_p5-no-clean-before-test.patch12
5 files changed, 66 insertions, 8 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index d11c606a8ee9..164c353ec003 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sci-mathematics/coq
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.84 2014/11/28 19:11:10 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.85 2015/02/15 06:46:47 gienah Exp $
+
+ 15 Feb 2015; Mark Wright <gienah@gentoo.org>
+ +files/coq-8.4_p5-do-not-install-revision.patch,
+ +files/coq-8.4_p5-hevea.patch, +files/coq-8.4_p5-no-clean-before-test.patch,
+ coq-8.4_p5.ebuild:
+ Fix generation of /usr/share/doc/coq-8.4_p5/html/refman/index_urls.txt, patch
+ from upstream: http://lists.gforge.inria.fr/pipermail/coq-
+ commits/2014-October/013582.html. Replace sed to avoid installing revision
+ with patch. Patch Makefile.build to avoid deleting html/refman/index_urls.txt
+ in the test phase and then failing to install with FEATURES=test and USE=doc
28 Nov 2014; Alexis Ballier <aballier@gentoo.org> coq-8.4_p5.ebuild:
update deps for ocaml 4.02
diff --git a/sci-mathematics/coq/coq-8.4_p5.ebuild b/sci-mathematics/coq/coq-8.4_p5.ebuild
index e3ace8057f3b..cdae7204a41b 100644
--- a/sci-mathematics/coq/coq-8.4_p5.ebuild
+++ b/sci-mathematics/coq/coq-8.4_p5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.4_p5.ebuild,v 1.2 2014/11/28 19:11:10 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.4_p5.ebuild,v 1.3 2015/02/15 06:46:47 gienah Exp $
EAPI="5"
@@ -37,9 +37,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
src_prepare() {
- sed -e 's@\($(INSTALLLIB)\) revision@\1@' \
- -i "${S}/Makefile.build" \
- || die "Could not edit Makefile.build to remove install revision"
+ epatch "${FILESDIR}/${PN}-8.4_p5-do-not-install-revision.patch"
+ # Fix generation of the index_urls.txt file with Gentoo dev-tex/hevea versions.
+ # http://lists.gforge.inria.fr/pipermail/coq-commits/2014-October/013582.html
+ epatch "${FILESDIR}/${P}-hevea.patch"
+ epatch "${FILESDIR}/${PN}-8.4_p5-no-clean-before-test.patch"
}
src_configure() {
@@ -89,8 +91,12 @@ src_compile() {
emake STRIP="true" -j1 world VERBOSE=1
}
+src_test() {
+ emake STRIP="true" check VERBOSE=1
+}
+
src_install() {
- emake STRIP="true" COQINSTALLPREFIX="${D}" install
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install VERBOSE=1
dodoc README CREDITS CHANGES
use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
diff --git a/sci-mathematics/coq/files/coq-8.4_p5-do-not-install-revision.patch b/sci-mathematics/coq/files/coq-8.4_p5-do-not-install-revision.patch
new file mode 100644
index 000000000000..e97f4a165f87
--- /dev/null
+++ b/sci-mathematics/coq/files/coq-8.4_p5-do-not-install-revision.patch
@@ -0,0 +1,19 @@
+--- coq-8.4pl5-orig/Makefile.build 2014-10-22 19:30:53.000000000 +1100
++++ coq-8.4pl5/Makefile.build 2015-02-15 12:06:48.044999959 +1100
+@@ -655,16 +655,12 @@
+ # it with libraries
+ -$(MKDIR) $(FULLCOQLIB)/plugins/micromega
+ $(INSTALLBIN) $(CSDPCERT) $(FULLCOQLIB)/plugins/micromega
+- rm -f $(FULLCOQLIB)/revision
+- -$(INSTALLLIB) revision $(FULLCOQLIB)
+
+ install-library-light:
+ $(MKDIR) $(FULLCOQLIB)
+ $(INSTALLSH) $(FULLCOQLIB) $(LIBFILESLIGHT) $(INITPLUGINS)
+ $(MKDIR) $(FULLCOQLIB)/states
+ $(INSTALLLIB) states/*.coq $(FULLCOQLIB)/states
+- rm -f $(FULLCOQLIB)/revision
+- -$(INSTALLLIB) revision $(FULLCOQLIB)
+ ifeq ($(BEST),opt)
+ $(INSTALLSH) $(FULLCOQLIB) $(INITPLUGINSOPT)
+ endif
diff --git a/sci-mathematics/coq/files/coq-8.4_p5-hevea.patch b/sci-mathematics/coq/files/coq-8.4_p5-hevea.patch
new file mode 100644
index 000000000000..c76f1dea8e11
--- /dev/null
+++ b/sci-mathematics/coq/files/coq-8.4_p5-hevea.patch
@@ -0,0 +1,11 @@
+--- coq-8.4pl5-orig/Makefile.doc 2014-10-22 19:30:53.000000000 +1100
++++ coq-8.4pl5/Makefile.doc 2015-02-15 15:28:34.797911303 +1100
+@@ -148,7 +148,7 @@
+ ######################################################################
+
+ $(INDEXURLS): $(INDEXES)
+- cat $< | grep li-indexenv | grep HREF | sed -e 's@.*<TT>\(.*\)</TT>.*, <A HREF="\(.*\)">.*@\1,\2@' > $@
++ cat $< | grep li-indexenv | grep href | sed -e 's@.*>\([^<]*\)</span>.*, <a href="\([^"]*\)">.*@\1,\2@' > $@
+
+
+ ######################################################################
diff --git a/sci-mathematics/coq/files/coq-8.4_p5-no-clean-before-test.patch b/sci-mathematics/coq/files/coq-8.4_p5-no-clean-before-test.patch
new file mode 100644
index 000000000000..ef4b6cf3e824
--- /dev/null
+++ b/sci-mathematics/coq/files/coq-8.4_p5-no-clean-before-test.patch
@@ -0,0 +1,12 @@
+--- coq-8.4pl5-orig/Makefile.build 2015-02-15 12:06:48.044999959 +1100
++++ coq-8.4pl5/Makefile.build 2015-02-15 16:41:06.521892146 +1100
+@@ -395,8 +395,7 @@
+
+ check:: validate test-suite
+
+-test-suite: world $(ALLSTDLIB).v
+- $(MAKE) $(MAKE_TSOPTS) clean
++test-suite: $(ALLSTDLIB).v
+ $(MAKE) $(MAKE_TSOPTS) all
+ $(HIDE)if grep -F 'Error!' test-suite/summary.log ; then false; fi
+