summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-08-12 21:29:11 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-08-12 21:29:11 +0000
commit05471bd7c53b6c40eb8073bb36757a383b4aecbe (patch)
treec6d2a3233632940e6c6c61f9467a59b57ed47298 /sci-mathematics/cgal
parentFix bug numb. (diff)
downloadgentoo-2-05471bd7c53b6c40eb8073bb36757a383b4aecbe.tar.gz
gentoo-2-05471bd7c53b6c40eb8073bb36757a383b4aecbe.tar.bz2
gentoo-2-05471bd7c53b6c40eb8073bb36757a383b4aecbe.zip
Added a gcc-4.4 patch in order to build cgal-python
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/cgal')
-rw-r--r--sci-mathematics/cgal/ChangeLog6
-rw-r--r--sci-mathematics/cgal/cgal-3.3.1.ebuild3
-rw-r--r--sci-mathematics/cgal/files/cgal-3.3.1-gcc44.patch30
3 files changed, 37 insertions, 2 deletions
diff --git a/sci-mathematics/cgal/ChangeLog b/sci-mathematics/cgal/ChangeLog
index 9868480ddb53..b19b4e84504a 100644
--- a/sci-mathematics/cgal/ChangeLog
+++ b/sci-mathematics/cgal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/cgal
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/ChangeLog,v 1.3 2009/08/12 20:27:00 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/ChangeLog,v 1.4 2009/08/12 21:29:10 bicatali Exp $
+
+ 12 Aug 2009; Sébastien Fabbro <bicatali@gentoo.org> cgal-3.3.1.ebuild,
+ +files/cgal-3.3.1-gcc44.patch:
+ Added a gcc-4.4 patch in order to build cgal-python
12 Aug 2009; Sébastien Fabbro <bicatali@gentoo.org> cgal-3.3.1.ebuild:
Fixed a sed line
diff --git a/sci-mathematics/cgal/cgal-3.3.1.ebuild b/sci-mathematics/cgal/cgal-3.3.1.ebuild
index 6ee20eaf9e79..432a12c6fcce 100644
--- a/sci-mathematics/cgal/cgal-3.3.1.ebuild
+++ b/sci-mathematics/cgal/cgal-3.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/cgal-3.3.1.ebuild,v 1.3 2009/08/12 20:27:00 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/cgal-3.3.1.ebuild,v 1.4 2009/08/12 21:29:10 bicatali Exp $
EAPI=2
@@ -34,6 +34,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-rpath.patch
# a patch from debian on missing qt headers
epatch "${FILESDIR}"/${P}-qt.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
# sed for blas and lapack gentoo style
sed -e 's:Intel MKL:Gentoo BLAS-LAPACK:' \
-e "s:^LIBS.=.*:LIBS=$(pkg-config --libs-only-l lapack | sed 's/-l//g'):" \
diff --git a/sci-mathematics/cgal/files/cgal-3.3.1-gcc44.patch b/sci-mathematics/cgal/files/cgal-3.3.1-gcc44.patch
new file mode 100644
index 000000000000..3707bd83d67c
--- /dev/null
+++ b/sci-mathematics/cgal/files/cgal-3.3.1-gcc44.patch
@@ -0,0 +1,30 @@
+--- include/CGAL/Lazy_exact_nt.h.orig 2009-08-12 22:17:43.000000000 +0100
++++ include/CGAL/Lazy_exact_nt.h 2009-08-12 22:19:06.000000000 +0100
+@@ -329,11 +329,11 @@
+ struct Lazy_exact_Min : public Lazy_exact_binary<ET>
+ {
+ Lazy_exact_Min (const Lazy_exact_nt<ET> &a, const Lazy_exact_nt<ET> &b)
+- : Lazy_exact_binary<ET>((min)(a.approx(), b.approx()), a, b) {}
++ : Lazy_exact_binary<ET>((CGAL::min)(a.approx(), b.approx()), a, b) {}
+
+ void update_exact()
+ {
+- this->et = new ET((min)(this->op1.exact(), this->op2.exact()));
++ this->et = new ET((CGAL::min)(this->op1.exact(), this->op2.exact()));
+ if (!this->approx().is_point()) this->approx() = CGAL_NTS to_interval(*(this->et));
+ this->prune_dag();
+ }
+@@ -344,11 +344,11 @@
+ struct Lazy_exact_Max : public Lazy_exact_binary<ET>
+ {
+ Lazy_exact_Max (const Lazy_exact_nt<ET> &a, const Lazy_exact_nt<ET> &b)
+- : Lazy_exact_binary<ET>((max)(a.approx(), b.approx()), a, b) {}
++ : Lazy_exact_binary<ET>((CGAL::max)(a.approx(), b.approx()), a, b) {}
+
+ void update_exact()
+ {
+- this->et = new ET((max)(this->op1.exact(), this->op2.exact()));
++ this->et = new ET((CGAL::max)(this->op1.exact(), this->op2.exact()));
+ if (!this->approx().is_point()) this->approx() = CGAL_NTS to_interval(*(this->et));
+ this->prune_dag();
+ }