summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2011-09-25 19:44:37 +0000
committerThomas Kahle <tomka@gentoo.org>2011-09-25 19:44:37 +0000
commit5c5939ef32e5b914b69d262378e450710c791258 (patch)
tree9206791f202b1ded0dac924775dad79a591b2a24 /sci-mathematics/Macaulay2
parentDrop useless fix-includes patch as this breaks with gcc-4.6+ (--disable-share... (diff)
downloadgentoo-2-5c5939ef32e5b914b69d262378e450710c791258.tar.gz
gentoo-2-5c5939ef32e5b914b69d262378e450710c791258.tar.bz2
gentoo-2-5c5939ef32e5b914b69d262378e450710c791258.zip
Fix pari-2.5 compatibility (Bug 381347) and two emacs-improvements
(Portage version: 2.1.10.19/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/Macaulay2')
-rw-r--r--sci-mathematics/Macaulay2/ChangeLog9
-rw-r--r--sci-mathematics/Macaulay2/Macaulay2-1.4-r1.ebuild146
-rw-r--r--sci-mathematics/Macaulay2/files/1.4-comint-use-fields.patch20
-rw-r--r--sci-mathematics/Macaulay2/files/1.4-fix-emacs-syntax-table.patch13
-rw-r--r--sci-mathematics/Macaulay2/files/1.4-pari-2.5-compat.patch17
5 files changed, 204 insertions, 1 deletions
diff --git a/sci-mathematics/Macaulay2/ChangeLog b/sci-mathematics/Macaulay2/ChangeLog
index d6cfc5d2a32e..8606d84c6c29 100644
--- a/sci-mathematics/Macaulay2/ChangeLog
+++ b/sci-mathematics/Macaulay2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/Macaulay2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/Macaulay2/ChangeLog,v 1.23 2011/05/14 14:34:21 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/Macaulay2/ChangeLog,v 1.24 2011/09/25 19:44:37 tomka Exp $
+
+*Macaulay2-1.4-r1 (25 Sep 2011)
+
+ 25 Sep 2011; Thomas Kahle <tomka@gentoo.org>
+ +files/1.4-comint-use-fields.patch, +files/1.4-fix-emacs-syntax-table.patch,
+ +Macaulay2-1.4-r1.ebuild, +files/1.4-pari-2.5-compat.patch:
+ Fix pari-2.5 compatibility (Bug 381347) and two emacs-improvements
14 May 2011; Thomas Kahle <tomka@gentoo.org> Macaulay2-1.4.ebuild:
x86 stable per bug 366379
diff --git a/sci-mathematics/Macaulay2/Macaulay2-1.4-r1.ebuild b/sci-mathematics/Macaulay2/Macaulay2-1.4-r1.ebuild
new file mode 100644
index 000000000000..e1660d8fa484
--- /dev/null
+++ b/sci-mathematics/Macaulay2/Macaulay2-1.4-r1.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/Macaulay2/Macaulay2-1.4-r1.ebuild,v 1.1 2011/09/25 19:44:37 tomka Exp $
+
+EAPI="2"
+
+inherit autotools elisp-common eutils flag-o-matic
+
+IUSE="emacs optimization"
+MY_REV="12617"
+
+FACTORYVER="3-1-1"
+
+DESCRIPTION="research tool for commutative algebra and algebraic geometry"
+SRC_BASE="http://www.math.uiuc.edu/${PN}/Downloads/"
+SRC_URI="${SRC_BASE}/OtherSourceCode/1.4/factory-${FACTORYVER}.tar.gz
+ ${SRC_BASE}/OtherSourceCode/1.4/libfac-${FACTORYVER}.tar.gz
+ http://www.math.uiuc.edu/${PN}/Extra/gc-7.2alpha5-2010-09-03.tar.gz
+ ${SRC_BASE}/SourceCode/${P}-r${MY_REV}-src.tar.bz2"
+
+HOMEPAGE="http://www.math.uiuc.edu/Macaulay2/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/gdbm
+ >=dev-libs/ntl-5.5.2
+ >=sci-mathematics/pari-2.3.4[gmp]
+ >=sys-libs/readline-6.1
+ dev-libs/libxml2:2
+ sci-mathematics/frobby
+ sci-mathematics/4ti2
+ sci-mathematics/nauty
+ >=sci-mathematics/normaliz-2.5
+ sci-mathematics/gfan
+ >=dev-libs/mpfr-3.0.0
+ >=sci-libs/mpir-2.1.1[cxx]
+ sci-libs/cddlib
+ sci-libs/cdd+
+ sci-libs/lrslib[gmp]
+ virtual/blas
+ virtual/lapack
+ dev-util/ctags
+ sys-libs/ncurses
+ sys-process/time
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+SITEFILE=70Macaulay2-gentoo.el
+
+S="${WORKDIR}/${P}-r${MY_REV}"
+
+pkg_setup () {
+ tc-export CC CPP CXX
+ append-cppflags "-I/usr/include/frobby"
+}
+
+src_prepare() {
+ # Patching .m2 files to look for external programs in
+ # /usr/bin
+ epatch "${FILESDIR}"/${PV}-paths-of-external-programs.patch
+
+ # The following three are all upstream and need to be removed on bump.
+ # Fix an incompatibility with pari-2.5
+ epatch "${FILESDIR}"/${PV}-pari-2.5-compat.patch
+ # Two M2.el improvements
+ epatch "${FILESDIR}"/${PV}-comint-use-fields.patch
+ epatch "${FILESDIR}"/${PV}-fix-emacs-syntax-table.patch
+
+ # Fixing make warnings about unavailable jobserver:
+ sed -i "s/\$(MAKE)/+ \$(MAKE)/g" "${S}"/distributions/Makefile.in
+
+ # Factory, and libfac are statically linked libraries which (in this flavor) are not used by any
+ # other program. We build them internally and don't install them
+ mkdir "${S}/BUILD/tarfiles" || die "Creation of directory failed"
+ cp "${DISTDIR}/factory-3-1-1.tar.gz" "${S}/BUILD/tarfiles/" \
+ || die "copy failed"
+ cp "${DISTDIR}/libfac-3-1-1.tar.gz" "${S}/BUILD/tarfiles/" \
+ || die "copy failed"
+ # Macaulay 2 in this version insists on a snapshot of boehm-gc that is not available elsewhere
+ # We will let it build its internal version until >=boehm-gc-7.2_alpha5 is in in tree. Note:
+ # The resulting QA warning is known.
+ cp "${DISTDIR}/gc-7.2alpha5-2010-09-03.tar.gz" "${S}/BUILD/tarfiles/" \
+ || die "copy failed"
+
+ eautoreconf
+}
+
+src_configure (){
+ # Recommended in bug #268064 Possibly unecessary
+ # but should not hurt anybody.
+ if ! use emacs; then
+ tags="ctags"
+ fi
+
+ # configure instead of econf to enable install with --prefix
+ ./configure --prefix="${D}/usr" \
+ --disable-encap \
+ --disable-strip \
+ $(use_enable optimization optimize) \
+ --enable-build-libraries="factory gc libfac" \
+ --with-unbuilt-programs="4ti2 gfan normaliz nauty cddplus lrslib" \
+ || die "failed to configure Macaulay"
+}
+
+src_compile() {
+ # Parallel build not supported yet
+ emake -j1 || die "failed to build Macaulay"
+
+ if use emacs; then
+ cd "${S}/Macaulay2/emacs"
+ elisp-compile *.el || die "elisp-compile failed"
+ fi
+}
+
+src_test() {
+ emake check || die "tests failed"
+}
+
+src_install () {
+ # Parallel install not supported yet
+ emake -j1 install || die "install failed"
+
+ # Remove emacs files and install them in the
+ # correct place if use emacs
+ rm -rf "${D}"/usr/share/emacs/site-lisp
+ if use emacs; then
+ cd "${S}/Macaulay2/emacs"
+ elisp-install ${PN} *.elc *.el || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "If you want to set a hot key for Macaulay2 in Emacs add a line similar to"
+ elog "(global-set-key [ f12 ] 'M2)"
+ elog "in order to set it to F12 (or choose a different one)."
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/Macaulay2/files/1.4-comint-use-fields.patch b/sci-mathematics/Macaulay2/files/1.4-comint-use-fields.patch
new file mode 100644
index 000000000000..5895f3ef2145
--- /dev/null
+++ b/sci-mathematics/Macaulay2/files/1.4-comint-use-fields.patch
@@ -0,0 +1,20 @@
+Index: Macaulay2/emacs/M2.el
+===================================================================
+--- Macaulay2/emacs/M2.el (revision 13949)
++++ Macaulay2/emacs/M2.el (revision 13951)
+@@ -38,7 +38,6 @@
+ \\{M2-comint-mode-map}"
+ (M2-common)
+ (setq comint-prompt-regexp M2-comint-prompt-regexp)
+- (setq comint-use-prompt-regexp-instead-of-fields t)
+ (set (make-local-variable 'comint-dynamic-complete-functions) '( M2-dynamic-complete-symbol comint-dynamic-complete-filename))
+ ;; give up trying to fix this:
+ ;; (set (make-local-variable 'ansi-color-for-comint-mode-on) nil)
+@@ -46,7 +45,6 @@
+
+ (defun M2-common()
+ "Set up features common to both Macaulay 2 major modes."
+- (set (make-local-variable 'comint-use-prompt-regexp-instead-of-fields) nil) ; we might want to start using "input fields", too!
+ (set (make-local-variable 'comment-start) "-- ")
+ (set (make-local-variable 'comment-end) "")
+ (set (make-local-variable 'comment-column) 60)
diff --git a/sci-mathematics/Macaulay2/files/1.4-fix-emacs-syntax-table.patch b/sci-mathematics/Macaulay2/files/1.4-fix-emacs-syntax-table.patch
new file mode 100644
index 000000000000..32fc43bc14a2
--- /dev/null
+++ b/sci-mathematics/Macaulay2/files/1.4-fix-emacs-syntax-table.patch
@@ -0,0 +1,13 @@
+Index: Macaulay2/emacs/M2.el
+===================================================================
+--- Macaulay2/emacs/M2.el (revision 13991)
++++ Macaulay2/emacs/M2.el (revision 14000)
+@@ -102,7 +102,7 @@
+ (mapcar
+ (function
+ (lambda (syntax-table)
+- (modify-syntax-entry ?\\ "\\" syntax-table)
++ (modify-syntax-entry ?\\ "." syntax-table)
+ (modify-syntax-entry ?- ". 12" syntax-table)
+ (modify-syntax-entry ?\n ">" syntax-table)
+ (modify-syntax-entry ?\^m ">" syntax-table)
diff --git a/sci-mathematics/Macaulay2/files/1.4-pari-2.5-compat.patch b/sci-mathematics/Macaulay2/files/1.4-pari-2.5-compat.patch
new file mode 100644
index 000000000000..5b254a8eb447
--- /dev/null
+++ b/sci-mathematics/Macaulay2/files/1.4-pari-2.5-compat.patch
@@ -0,0 +1,17 @@
+Index: Macaulay2/d/pari-c.c
+===================================================================
+--- Macaulay2/d/pari-c.c (revision 13515)
++++ Macaulay2/d/pari-c.c (revision 13519)
+@@ -154,9 +154,11 @@
+ */
+
+ #define pari_examine(x) do { fputs(" " #x ": ", stdout); voir(x,-1); } while (0)
+-#define pari_display(x) do { fputs(" " #x ": ", stdout); outbeaut(x); } while (0)
++#define pari_display(x) do { fputs(" " #x ": ", stdout); output(x); } while (0)
+ #define abs(x) ((x)<0?-(x):(x))
+
++#define max(a,b) ((a)>(b)?(a):(b))
++
+ static void gmp_examine0(mpz_t z) {
+ int i, n = max(z->_mp_alloc,abs(z->_mp_size));
+ printf("alloc %d size %d %s {",z->_mp_alloc,z->_mp_size,z->_mp_size < 0 ? "-" : "+");