summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-03-12 13:11:55 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-03-12 13:11:55 +0000
commitef573024090351712b2467c796c7c91877696a2a (patch)
treef86fec010bdfaef822a05653d25792e4f5c5a57c /sci-libs
parentRemoving Andres Loeh (kosmikus, #200333) from metadata.xml. (diff)
downloadgentoo-2-ef573024090351712b2467c796c7c91877696a2a.tar.gz
gentoo-2-ef573024090351712b2467c796c7c91877696a2a.tar.bz2
gentoo-2-ef573024090351712b2467c796c7c91877696a2a.zip
Version bump. Removed older versions
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/blas-goto/ChangeLog9
-rw-r--r--sci-libs/blas-goto/blas-goto-1.19.ebuild168
-rw-r--r--sci-libs/blas-goto/blas-goto-1.24.ebuild (renamed from sci-libs/blas-goto/blas-goto-1.22.ebuild)106
-rw-r--r--sci-libs/blas-goto/files/blas-goto-1.24-sharedlibs.patch18
4 files changed, 70 insertions, 231 deletions
diff --git a/sci-libs/blas-goto/ChangeLog b/sci-libs/blas-goto/ChangeLog
index d778c87fc8a4..1b855d234057 100644
--- a/sci-libs/blas-goto/ChangeLog
+++ b/sci-libs/blas-goto/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/blas-goto
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/ChangeLog,v 1.15 2008/02/12 17:56:31 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/ChangeLog,v 1.16 2008/03/12 13:11:54 bicatali Exp $
+
+*blas-goto-1.24 (12 Mar 2008)
+
+ 12 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/blas-goto-1.24-sharedlibs.patch, -blas-goto-1.19.ebuild,
+ -blas-goto-1.22.ebuild, +blas-goto-1.24.ebuild:
+ Version bump. Removed older versions
*blas-goto-1.22-r1 (12 Feb 2008)
diff --git a/sci-libs/blas-goto/blas-goto-1.19.ebuild b/sci-libs/blas-goto/blas-goto-1.19.ebuild
deleted file mode 100644
index 0cf2afb9e8ac..000000000000
--- a/sci-libs/blas-goto/blas-goto-1.19.ebuild
+++ /dev/null
@@ -1,168 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/blas-goto-1.19.ebuild,v 1.4 2007/10/11 17:38:06 bicatali Exp $
-
-inherit eutils fortran flag-o-matic toolchain-funcs
-
-MY_PN="GotoBLAS"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="The fastest implementations of the Basic Linear Algebra Subroutines"
-HOMEPAGE="http://www.tacc.utexas.edu/resources/software/software.php"
-SRC_URI="http://www.tacc.utexas.edu/resources/software/login/gotoblas/${MY_P}.tar.gz"
-LICENSE="tacc"
-SLOT="0"
-# See http://www.tacc.utexas.edu/resources/software/gotoblasfaq.php
-# for supported architectures
-KEYWORDS="~x86 ~amd64"
-IUSE="threads doc"
-RESTRICT="mirror"
-RDEPEND="app-admin/eselect-blas
- dev-util/pkgconfig
- doc? ( app-doc/blas-docs )"
-
-DEPEND="app-admin/eselect-blas
- >=sys-devel/binutils-2.17"
-
-S="${WORKDIR}/${MY_PN}"
-FORTRAN="g77 gfortran ifc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Set up C compiler
- if [[ $(tc-getCC) = *gcc ]]; then
- C_COMPILER="GNU"
- elif [[ $(tc-getCC) = icc ]]; then
- C_COMPILER="INTEL"
- else
- die "tc-getCC() returned an invalid C compiler; valid are gcc or icc."
- fi
-
- # Set up FORTRAN 77 compiler
- case ${FORTRANC} in
- g77)
- F_COMPILER="G77"
- ;;
- gfortran)
- F_COMPILER="GFORTRAN"
- F_LIB="-lgfortran"
- ;;
- ifc|ifort)
- F_COMPILER="INTEL"
- ;;
- *)
- die "fortran.eclass returned an invalid Fortran compiler \'${FORTRANC}\'; valid are ${FORTRAN}."
- esac
-
- # Fix shared lib build
- sed -i \
- -e "s:\(&& echo OK\):${F_LIB} \1:g" \
- "${S}"/exports/Makefile \
- || die "sed for shared libs failed"
-
- # Set up compilers
- sed -i \
- -e "s:^# \(C_COMPILER =\) GNU:\1 ${C_COMPILER}:g" \
- -e "s:^# \(F_COMPILER =\) G77:\1 ${F_COMPILER}:g" \
- -e "s:^# \(SMP = 1\):\1:g" \
- -e "s:\$(COMPILER_PREFIX)ar:$(tc-getAR):" \
- -e "s:\$(COMPILER_PREFIX)as:$(tc-getAS):" \
- -e "s:\$(COMPILER_PREFIX)ld:$(tc-getLD):" \
- -e "s:\$(COMPILER_PREFIX)ranlib:$(tc-getRANLIB):" \
- "${S}"/Makefile.rule \
- || die "sed for setting up compilers failed"
-
- # Threaded?
- if use threads; then
- sed -i \
- -e "s:^# \(SMP = 1\):\1:g" \
- "${S}"/Makefile.rule \
- || die "sed for threads failed"
- fi
-
- # If you need a 64-bit integer interface, also do this for "INTERFACE64 = 1"
- if use amd64; then
- sed -i \
- -e "s:^# \(BINARY64 = 1\):\1:g" \
- "${S}"/Makefile.rule \
- || die "sed for 64 binary failed"
- fi
-
- # Respect CFLAGS/FFLAGS
- if [[ -z "${FFLAGS}" ]]; then
- ewarn "FORTRAN FFLAGS undefined, using -O2"
- export FFLAGS="-O2"
- fi
-
- sed -i \
- -e '/^CFLAGS/s:=:+=:' \
- -e '/^FFLAGS/s:=:+=:' \
- "${S}"/Makefile.rule \
- || die "sed for flags failed"
-}
-
-src_compile() {
-
- # Make static library
- emake LDFLAGS="$(raw-ldflags)" || die "emake failed"
-
- # Make shared library
- cd exports
- emake so -j1 || die "emake failed"
-}
-
-src_test() {
- cd test
- emake || die "emake test failed"
- make clean
-}
-
-src_install() {
- local MAIN_DIR="/usr/$(get_libdir)/blas"
- local DIR="${MAIN_DIR}/goto"
-
- # dolib.so doesn't support our alternate locations
- exeinto ${DIR}
- doexe libgoto_*.so
- dosym libgoto_*.so ${DIR}/libgoto.so
- dosym libgoto_*.so ${DIR}/libgoto.so.0
- dosym libgoto_*.so ${DIR}/libgoto.so.0.0.0
-
- # dolib.a doesn't support our alternate locations
- insinto ${DIR}
- doins libgoto_*.a
- dosym libgoto_*.a ${DIR}/libgoto.a
-
- dodoc 01Readme.txt 03History.txt 04FAQ.txt
-
- cp "${FILESDIR}"/blas.pc.in blas.pc
- local extlibs=""
- use threads && extlibs="${extlibs} -lpthread"
- extlibs="${extlibs}"
- sed -i \
- -e "s/@LIBDIR@/$(get_libdir)/" \
- -e "s/@PV@/${PV}/" \
- -e "s/@EXTLIBS@/${extlibs}/" \
- blas.pc || die "sed blas.pc failed"
- insinto /usr/$(get_libdir)/blas/goto
- doins blas.pc
- ESELECT_PROF=goto
- eselect blas add $(get_libdir) "${FILESDIR}"/eselect.blas.goto ${ESELECT_PROF}
-}
-
-pkg_postinst() {
- local p=blas
- local current_lib=$(eselect ${p} show | cut -d' ' -f2)
- if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
- # work around eselect bug #189942
- local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
- [[ -e ${configfile} ]] && rm -f ${configfile}
- eselect ${p} set ${ESELECT_PROF}
- elog "${p} has been eselected to ${ESELECT_PROF}"
- else
- elog "Current eselected ${p} is ${current_lib}"
- elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
- elog "\t eselect ${p} set ${ESELECT_PROF}"
- fi
-}
diff --git a/sci-libs/blas-goto/blas-goto-1.22.ebuild b/sci-libs/blas-goto/blas-goto-1.24.ebuild
index cf7cc2e90268..cb5e61b49a34 100644
--- a/sci-libs/blas-goto/blas-goto-1.22.ebuild
+++ b/sci-libs/blas-goto/blas-goto-1.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/blas-goto-1.22.ebuild,v 1.1 2008/01/24 10:24:20 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/blas-goto-1.24.ebuild,v 1.1 2008/03/12 13:11:54 bicatali Exp $
inherit eutils fortran flag-o-matic toolchain-funcs
@@ -14,7 +14,7 @@ SLOT="0"
# See http://www.tacc.utexas.edu/resources/software/gotoblasfaq.php
# for supported architectures
KEYWORDS="~x86 ~amd64"
-IUSE="threads doc"
+IUSE="int64 threads doc"
RESTRICT="mirror"
RDEPEND="app-admin/eselect-blas
dev-util/pkgconfig
@@ -24,82 +24,66 @@ DEPEND="app-admin/eselect-blas
>=sys-devel/binutils-2.17"
S="${WORKDIR}/${MY_PN}"
-FORTRAN="g77 gfortran ifc"
+FORTRAN="gfortran g77 ifc"
+
+ESELECT_PROF=goto
src_unpack() {
unpack ${A}
cd "${S}"
- # Set up C compiler
- if [[ $(tc-getCC) = *gcc ]]; then
- C_COMPILER="GNU"
- elif [[ $(tc-getCC) = icc ]]; then
- C_COMPILER="INTEL"
- else
- die "tc-getCC() returned an invalid C compiler; valid are gcc or icc."
+ # patch to link with m and fortran libs, works with asneeded
+ epatch "${FILESDIR}"/${P}-sharedlibs.patch
+
+ # Set up C compiler: forcing gcc for now
+ if [[ $(tc-getCC) != *gcc ]]; then
+ ewarn "Your C compiler is set to $(tc-getCC)"
+ ewarn "${PN} needs gcc to inline assembler, others compilers have reported failures"
+ ewarn "Forcing gcc"
fi
+ C_COMPILER=GNU
# Set up FORTRAN 77 compiler
case ${FORTRANC} in
- g77)
- F_COMPILER="G77"
- ;;
- gfortran)
- F_COMPILER="GFORTRAN"
- F_LIB="-lgfortran"
- ;;
- ifc|ifort)
- F_COMPILER="INTEL"
- ;;
+ g77) F_COMPILER=G77;;
+ gfortran) F_COMPILER=GFORTRAN;;
+ ifc|ifort) F_COMPILER=INTEL;;
*)
- die "fortran.eclass returned an invalid Fortran compiler \'${FORTRANC}\'; valid are ${FORTRAN}."
+ die "Invalid Fortran compiler: ${FORTRANC}; valid are ${FORTRAN}."
esac
- # Fix shared lib build
- sed -i \
- -e "s:\(&& echo OK\):${F_LIB} \1:g" \
- "${S}"/exports/Makefile \
- || die "sed for shared libs failed"
-
# Set up compilers
sed -i \
-e "s:^# \(C_COMPILER =\) GNU:\1 ${C_COMPILER}:g" \
-e "s:^# \(F_COMPILER =\) G77:\1 ${F_COMPILER}:g" \
- -e "s:^# \(SMP = 1\):\1:g" \
- -e "s:\$(COMPILER_PREFIX)ar:$(tc-getAR):" \
- -e "s:\$(COMPILER_PREFIX)as:$(tc-getAS):" \
- -e "s:\$(COMPILER_PREFIX)ld:$(tc-getLD):" \
- -e "s:\$(COMPILER_PREFIX)ranlib:$(tc-getRANLIB):" \
- "${S}"/Makefile.rule \
- || die "sed for setting up compilers failed"
-
- # Threaded?
+ -e "s:\$(CROSS_BINUTILS)ar:$(tc-getAR):" \
+ -e "s:\$(CROSS_BINUTILS)as:$(tc-getAS):" \
+ -e "s:\$(CROSS_BINUTILS)ld:$(tc-getLD):" \
+ -e "s:\$(CROSS_BINUTILS)ranlib:$(tc-getRANLIB):" \
+ Makefile.rule \
+ || die "sed for toolchain failed"
+
if use threads; then
sed -i \
-e "s:^# \(SMP = 1\):\1:g" \
- "${S}"/Makefile.rule \
+ Makefile.rule \
|| die "sed for threads failed"
fi
- # If you need a 64-bit integer interface, also do this for "INTERFACE64 = 1"
if use amd64; then
sed -i \
-e "s:^# \(BINARY64 = 1\):\1:g" \
- "${S}"/Makefile.rule \
+ Makefile.rule \
|| die "sed for 64 binary failed"
fi
- # Respect CFLAGS/FFLAGS
- if [[ -z "${FFLAGS}" ]]; then
- ewarn "FORTRAN FFLAGS undefined, using -O2"
- export FFLAGS="-O2"
+ if use int64; then
+ sed -i \
+ -e "s:^# \(INTERFACE64 = 1\):\1:g" \
+ Makefile.rule \
+ || die "sed for 64 integers failed"
+ ESELECT_PROF="${ESELECT_PROF}-int64"
fi
-
- sed -i \
- -e '/^CFLAGS/s:=:+=:' \
- -e '/^FFLAGS/s:=:+=:' \
- "${S}"/Makefile.rule \
- || die "sed for flags failed"
}
src_compile() {
@@ -119,27 +103,26 @@ src_test() {
}
src_install() {
- local MAIN_DIR="/usr/$(get_libdir)/blas"
- local DIR="${MAIN_DIR}/goto"
+ local install_dir=/usr/$(get_libdir)/blas/goto
+ dodir ${install_dir}
# dolib.so doesn't support our alternate locations
- exeinto ${DIR}
- doexe libgoto_*.so
- dosym libgoto_*.so ${DIR}/libgoto.so
- dosym libgoto_*.so ${DIR}/libgoto.so.0
- dosym libgoto_*.so ${DIR}/libgoto.so.0.0.0
+ exeinto ${install_dir}
+ doexe libgoto_*.so || die "installing shared lib failed"
+ dosym libgoto_*.so ${install_dir}/libgoto.so
+ dosym libgoto_*.so ${install_dir}/libgoto.so.0
+ dosym libgoto_*.so ${install_dir}/libgoto.so.0.0.0
# dolib.a doesn't support our alternate locations
- insinto ${DIR}
- doins libgoto_*.a
- dosym libgoto_*.a ${DIR}/libgoto.a
+ insinto ${install_dir}
+ doins libgoto_*.a || die "installing static lib failed"
+ dosym libgoto_*.a ${install_dir}/libgoto.a
- dodoc 01Readme.txt 03History.txt 04FAQ.txt
+ dodoc 01Readme.txt 03History.txt 04FAQ.txt || die
cp "${FILESDIR}"/blas.pc.in blas.pc
local extlibs=""
use threads && extlibs="${extlibs} -lpthread"
- extlibs="${extlibs}"
sed -i \
-e "s/@LIBDIR@/$(get_libdir)/" \
-e "s/@PV@/${PV}/" \
@@ -147,7 +130,6 @@ src_install() {
blas.pc || die "sed blas.pc failed"
insinto /usr/$(get_libdir)/blas/goto
doins blas.pc
- ESELECT_PROF=goto
eselect blas add $(get_libdir) "${FILESDIR}"/eselect.blas.goto ${ESELECT_PROF}
}
diff --git a/sci-libs/blas-goto/files/blas-goto-1.24-sharedlibs.patch b/sci-libs/blas-goto/files/blas-goto-1.24-sharedlibs.patch
new file mode 100644
index 000000000000..1180c4ff0cf2
--- /dev/null
+++ b/sci-libs/blas-goto/files/blas-goto-1.24-sharedlibs.patch
@@ -0,0 +1,18 @@
+--- exports/Makefile.orig 2008-03-12 12:16:22.966541966 +0000
++++ exports/Makefile 2008-03-12 12:24:08.850292012 +0000
+@@ -104,13 +104,13 @@
+ ../$(LIBSONAME) : ../$(LIBNAME) linux.def
+ $(CC) $(CFLAGS) -shared -o ../$(LIBSONAME) \
+ -Wl,--whole-archive ../$(LIBNAME) -Wl,--no-whole-archive \
+- -Wl,--retain-symbols-file=linux.def $(PTHREADLIB)
++ -Wl,--retain-symbols-file=linux.def $(PTHREADLIB) -lm
+
+ endif
+
+ ifeq ($(OSNAME), FreeBSD)
+
+-so : ../$(LIBSONAME) test
++so : ../$(LIBSONAME)
+
+ ../$(LIBSONAME) : ../$(LIBNAME) linux.def
+ $(CC) $(CFLAGS) -shared -o ../$(LIBSONAME) \