summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-21 18:34:21 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-21 18:34:21 +0000
commitd0723cc98af40e96bf4b0040c6da0ce0b47a6b55 (patch)
tree1bed1469b9614d7b2fec90e895ad73d95b35a645 /sci-libs
parentRemoval of old version. (diff)
downloadgentoo-2-d0723cc98af40e96bf4b0040c6da0ce0b47a6b55.tar.gz
gentoo-2-d0723cc98af40e96bf4b0040c6da0ce0b47a6b55.tar.bz2
gentoo-2-d0723cc98af40e96bf4b0040c6da0ce0b47a6b55.zip
Fix byte-compilation.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/vtk/vtk-5.4.2-r1.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/sci-libs/vtk/vtk-5.4.2-r1.ebuild b/sci-libs/vtk/vtk-5.4.2-r1.ebuild
index a880c2d009e7..18ff14116249 100644
--- a/sci-libs/vtk/vtk-5.4.2-r1.ebuild
+++ b/sci-libs/vtk/vtk-5.4.2-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2-r1.ebuild,v 1.8 2010/04/29 01:15:58 arfrever Exp $
-
-EAPI="2"
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2-r1.ebuild,v 1.9 2010/05/21 18:34:21 arfrever Exp $
+EAPI="3"
PYTHON_DEPEND="python? 2"
+
inherit cmake-utils eutils flag-o-matic java-pkg-opt-2 python qt4 versionator toolchain-funcs
# Short package version
@@ -220,4 +220,14 @@ pkg_postinst() {
ewarn "For more information, please read:"
ewarn "http://public.kitware.com/cgi-bin/vtkfaq?req=show&file=faq07.005.htp"
fi
+
+ if use python; then
+ python_mod_optimize vtk
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup vtk
+ fi
}