summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-01-25 18:37:03 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-01-25 18:37:03 +0000
commitbefe719a0be17bdd5164167fef49c4a3d4a58c45 (patch)
tree6bc438a3b9327719f52b72c87028f08c7ad2e5e6 /sci-libs
parentVersion bump. (diff)
downloadgentoo-2-befe719a0be17bdd5164167fef49c4a3d4a58c45.tar.gz
gentoo-2-befe719a0be17bdd5164167fef49c4a3d4a58c45.tar.bz2
gentoo-2-befe719a0be17bdd5164167fef49c4a3d4a58c45.zip
New gdal should support python3.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gdal/ChangeLog5
-rw-r--r--sci-libs/gdal/gdal-1.8.0.ebuild9
2 files changed, 6 insertions, 8 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index f57cbd304952..f31548796242 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.104 2011/01/25 18:34:08 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.105 2011/01/25 18:37:03 scarabeus Exp $
+
+ 25 Jan 2011; Tomáš Chvátal <scarabeus@gentoo.org> gdal-1.8.0.ebuild:
+ New gdal should support python3.
*gdal-1.8.0 (25 Jan 2011)
*gdal-1.7.3 (25 Jan 2011)
diff --git a/sci-libs/gdal/gdal-1.8.0.ebuild b/sci-libs/gdal/gdal-1.8.0.ebuild
index 87cd5b823148..978979976fac 100644
--- a/sci-libs/gdal/gdal-1.8.0.ebuild
+++ b/sci-libs/gdal/gdal-1.8.0.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.8.0.ebuild,v 1.1 2011/01/25 18:34:08 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.8.0.ebuild,v 1.2 2011/01/25 18:37:03 scarabeus Exp $
EAPI="2"
WANT_AUTOCONF="2.5"
RUBY_OPTIONAL="yes"
USE_RUBY="ruby18"
-PYTHON_DEPEND="python? 2"
+PYTHON_DEPEND="python? *:2.6"
inherit autotools eutils perl-module python ruby-ng toolchain-funcs
@@ -62,11 +62,6 @@ DEPEND="${RDEPEND}
AT_M4DIR="${S}/m4"
MAKEOPTS+=" -j1"
-pkg_setup() {
- # only py2 is supported
- python_set_active_version 2
-}
-
src_unpack() {
# prevent ruby-ng.eclass from messing with the src path
default