summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-08-08 01:02:35 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-08-08 01:02:35 +0000
commitb1212469e1f7ecb76d80d7abc361ff5f0197193a (patch)
tree9d0911f3f76b056e0fbc15995c85804f765c0cfe /sci-libs
parent1.1 version bump for bug 143032. Thanks to Robert Gill <locke at sdf dot lone... (diff)
downloadgentoo-2-b1212469e1f7ecb76d80d7abc361ff5f0197193a.tar.gz
gentoo-2-b1212469e1f7ecb76d80d7abc361ff5f0197193a.tar.bz2
gentoo-2-b1212469e1f7ecb76d80d7abc361ff5f0197193a.zip
Version bump. This fixes bug #143076.
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/itpp/ChangeLog8
-rw-r--r--sci-libs/itpp/files/digest-itpp-3.10.43
-rw-r--r--sci-libs/itpp/itpp-3.10.4.ebuild58
3 files changed, 68 insertions, 1 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index 3ed7b79c04f9..d3675cb2883d 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.7 2006/07/12 01:52:16 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.8 2006/08/08 01:02:35 markusle Exp $
+
+*itpp-3.10.4 (08 Aug 2006)
+
+ 08 Aug 2006; Markus Dittrich <markusle@gentoo.org> +itpp-3.10.4.ebuild:
+ Version bump. Thanks to Adam Piatyszek <ediap@et.put.poznan.pl>
+ for the heads up. This fixes bug #143076.
*itpp-3.10.3 (12 Jul 2006)
diff --git a/sci-libs/itpp/files/digest-itpp-3.10.4 b/sci-libs/itpp/files/digest-itpp-3.10.4
new file mode 100644
index 000000000000..82153354e722
--- /dev/null
+++ b/sci-libs/itpp/files/digest-itpp-3.10.4
@@ -0,0 +1,3 @@
+MD5 955e1abdff090123c5f2e536251fb37c itpp-3.10.4.tar.bz2 796528
+RMD160 db114aaca16093c236352b3596834756abaa36aa itpp-3.10.4.tar.bz2 796528
+SHA256 a6c78b6b357796d26795c27f5081f084e116d108b3e8a8610b2a2966d5928935 itpp-3.10.4.tar.bz2 796528
diff --git a/sci-libs/itpp/itpp-3.10.4.ebuild b/sci-libs/itpp/itpp-3.10.4.ebuild
new file mode 100644
index 000000000000..51ae14f00876
--- /dev/null
+++ b/sci-libs/itpp/itpp-3.10.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-3.10.4.ebuild,v 1.1 2006/08/08 01:02:35 markusle Exp $
+
+inherit fortran
+
+DESCRIPTION="IT++ is a C++ library of mathematical, signal processing, speech processing, and communications classes and functions"
+LICENSE="GPL-2"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="blas cblas debug doc fftw lapack"
+
+DEPEND="fftw? ( >=sci-libs/fftw-3.0.0 )
+ blas? ( virtual/blas
+ cblas? ( || ( >=sci-libs/gsl-1.4
+ >=sci-libs/acml-2.5.3
+ >=sci-libs/blas-atlas-3.6.0
+ sci-libs/cblas-reference ) )
+ lapack? ( virtual/lapack ) )
+ doc? ( app-doc/doxygen
+ virtual/tetex )"
+
+pkg_setup() {
+ # lapack/cblas can only be used in conjunction with blas
+ if use cblas && ! use blas; then
+ die "USE=cblas requires USE=blas to be set"
+ fi
+ if use lapack && ! use blas; then
+ die "USE=lapack requires USE=blas to be set"
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if use blas; then
+ myconf="--with-blas=-lblas"
+ else
+ myconf="--without-blas"
+ fi
+ econf $(use_enable doc html-doc) \
+ $(use_enable debug) \
+ $(use_with cblas) \
+ $(use_with lapack) \
+ $(use_with fftw fft) \
+ "$myconf" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO || \
+ die "failed to install docs"
+}