summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-09-13 19:10:59 +0000
committerJustin Lecher <jlec@gentoo.org>2010-09-13 19:10:59 +0000
commit65fac243a4f2d3329e25359d0f5caf1e53cebc41 (patch)
tree7559ccb11386ab934a69cdaa8b75186e9f982a7c /sci-libs
parentdev-libs/linux-fusion is gone (bug #316869) (diff)
downloadgentoo-2-65fac243a4f2d3329e25359d0f5caf1e53cebc41.tar.gz
gentoo-2-65fac243a4f2d3329e25359d0f5caf1e53cebc41.tar.bz2
gentoo-2-65fac243a4f2d3329e25359d0f5caf1e53cebc41.zip
Respect CFLAGS
(Portage version: 2.2_rc80/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/neartree/ChangeLog8
-rw-r--r--sci-libs/neartree/files/2.3.1-gentoo.patch8
-rw-r--r--sci-libs/neartree/neartree-2.3.1-r1.ebuild51
3 files changed, 61 insertions, 6 deletions
diff --git a/sci-libs/neartree/ChangeLog b/sci-libs/neartree/ChangeLog
index 03e04e192654..f1cd43b33c26 100644
--- a/sci-libs/neartree/ChangeLog
+++ b/sci-libs/neartree/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/neartree
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/neartree/ChangeLog,v 1.6 2010/09/12 15:00:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/neartree/ChangeLog,v 1.7 2010/09/13 19:10:59 jlec Exp $
+
+*neartree-2.3.1-r1 (13 Sep 2010)
+
+ 13 Sep 2010; Justin Lecher <jlec@gentoo.org> files/2.3.1-gentoo.patch,
+ +neartree-2.3.1-r1.ebuild:
+ Respect CFLAGS
*neartree-2.3.1 (12 Sep 2010)
diff --git a/sci-libs/neartree/files/2.3.1-gentoo.patch b/sci-libs/neartree/files/2.3.1-gentoo.patch
index 63b14961ffa2..aac9c169f620 100644
--- a/sci-libs/neartree/files/2.3.1-gentoo.patch
+++ b/sci-libs/neartree/files/2.3.1-gentoo.patch
@@ -1,5 +1,5 @@
diff --git a/Makefile b/Makefile
-index 38b63c5..ad91c99 100644
+index 38b63c5..4e6bc40 100644
--- a/Makefile
+++ b/Makefile
@@ -42,17 +42,17 @@
@@ -44,14 +44,12 @@ index 38b63c5..ad91c99 100644
#INSTALL_PREFIX = $(HOME)
endif
-@@ -110,11 +110,11 @@ CPPLIBRARIES = -lm
- #
+@@ -111,10 +111,10 @@ CPPLIBRARIES = -lm
CLIBRARIES = $(CVECTOR_LIBLOC) -lCVector -lm
--COMPILE_COMMAND = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c
+ COMPILE_COMMAND = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c
-CPPCOMPILE_COMMAND = $(LIBTOOL) --mode=compile $(CXX) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c
-LIBRARY_LINK_COMMAND = $(LIBTOOL) --mode=link $(CC) -version-info $(VERSION) -release $(RELEASE) -no-undefined -rpath $(INSTALL_PREFIX)/lib
-+COMPILE_COMMAND = $(LIBTOOL) --mode=compile $(CC) $(CXXFLAGS) $(INCLUDES) $(WARNINGS) -c
+CPPCOMPILE_COMMAND = $(LIBTOOL) --mode=compile $(CXX) $(CXXFLAGS) $(INCLUDES) $(WARNINGS) -c
+LIBRARY_LINK_COMMAND = $(LIBTOOL) --mode=link $(CC) -version-info $(VERSION) -release $(RELEASE) -no-undefined -rpath $(INSTALL_PREFIX)/GENTOOLIBDIR $(LDFLAGS)
BUILD_COMMAND_LOCAL = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(INCLUDES)
diff --git a/sci-libs/neartree/neartree-2.3.1-r1.ebuild b/sci-libs/neartree/neartree-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..5261ed85dc2e
--- /dev/null
+++ b/sci-libs/neartree/neartree-2.3.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/neartree/neartree-2.3.1-r1.ebuild,v 1.1 2010/09/13 19:10:59 jlec Exp $
+
+EAPI="3"
+
+inherit base flag-o-matic multilib toolchain-funcs versionator
+
+MY_PN=NearTree
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Function library efficiently solving the Nearest Neighbor Problem(known as the post office problem)"
+HOMEPAGE="http://neartree.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${MY_P}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-libs/cvector"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/2.1.4-test.patch
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+
+ sed \
+ -e "s:GENTOOLIBDIR:$(get_libdir):g" \
+ -e "s:/usr:${EPREFIX}/usr:g" \
+ -i Makefile
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ all || die
+}
+
+src_install() {
+ emake \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ DESTDIR="${D}" install || die
+
+ dodoc README_NearTree.txt || die
+ dohtml *.html || die
+}