summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-04-07 15:49:52 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-04-07 15:49:52 +0000
commit5e9e1c208f45b44f5fa8590ac070c3e4177052c8 (patch)
tree70214f1ed33af297b7d2ed7847419f699d54c4c7 /sci-libs
parentstable amd64, bug 165591 (diff)
downloadgentoo-2-5e9e1c208f45b44f5fa8590ac070c3e4177052c8.tar.gz
gentoo-2-5e9e1c208f45b44f5fa8590ac070c3e4177052c8.tar.bz2
gentoo-2-5e9e1c208f45b44f5fa8590ac070c3e4177052c8.zip
Fix location for amd64 and remove USE=static, bug 173624 thanks to Georgi Chulkov <g.chulkov@iu-bremen.de>, Thomas A. (gentoofan23) <gentoofan23@gmail.com>, philantrop and jakub
(Portage version: 2.1.2.3)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/djbfft/ChangeLog7
-rw-r--r--sci-libs/djbfft/djbfft-0.76.ebuild38
2 files changed, 20 insertions, 25 deletions
diff --git a/sci-libs/djbfft/ChangeLog b/sci-libs/djbfft/ChangeLog
index 923c39b45d43..33a497a4f117 100644
--- a/sci-libs/djbfft/ChangeLog
+++ b/sci-libs/djbfft/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/djbfft
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/djbfft/ChangeLog,v 1.8 2007/02/04 18:26:10 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/djbfft/ChangeLog,v 1.9 2007/04/07 15:49:52 genstef Exp $
+
+ 07 Apr 2007; Stefan Schweizer <genstef@gentoo.org> djbfft-0.76.ebuild:
+ Fix location for amd64 and remove USE=static, bug 173624 thanks to Georgi
+ Chulkov <g.chulkov@iu-bremen.de>, Thomas A. (gentoofan23)
+ <gentoofan23@gmail.com>, philantrop and jakub
04 Feb 2007; Simon Stelling <blubb@gentoo.org> djbfft-0.76.ebuild:
fix multilib-strict; bug 158373
diff --git a/sci-libs/djbfft/djbfft-0.76.ebuild b/sci-libs/djbfft/djbfft-0.76.ebuild
index fc117a7817d3..f87009d331d1 100644
--- a/sci-libs/djbfft/djbfft-0.76.ebuild
+++ b/sci-libs/djbfft/djbfft-0.76.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/djbfft/djbfft-0.76.ebuild,v 1.8 2007/02/04 18:26:10 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/djbfft/djbfft-0.76.ebuild,v 1.9 2007/04/07 15:49:52 genstef Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -11,7 +11,7 @@ SRC_URI="http://cr.yp.to/djbfft/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="alpha amd64 arm ~hppa ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="static"
+IUSE=""
# the "check" target of the Makefile (version 0.76 at least) only checks if
# all files were installed with correct permissions. Can't check that at
@@ -26,41 +26,31 @@ src_unpack() {
ALLOWED_FLAGS="-fstack-protector -march -mcpu -pipe -mpreferred-stack-boundary -ffast-math"
strip-flags
- MY_CFLAGS="$CFLAGS -O1 -fomit-frame-pointer"
- use x86 && MY_CFLAGS="$MY_CFLAGS -malign-double"
+ MY_CFLAGS="${CFLAGS} -O1 -fomit-frame-pointer"
+ use x86 && MY_CFLAGS="${MY_CFLAGS} -malign-double"
- if use static ; then
- LIBPERMS="0644"
- LIBDJBFFT="libdjbfft.a"
- else
- LIBPERMS="0755"
- LIBDJBFFT="libdjbfft.so.${MY_PV}"
- fi
+ LIBPERMS="0755"
+ LIBDJBFFT="libdjbfft.so.${MY_PV}"
- unpack "${A}"
+ unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-gcc3.patch"
epatch "${FILESDIR}/${P}-shared.patch"
+
sed -i -e "s:\"lib\":\"$(get_libdir)\":" hier.c
- if use static ; then
- echo "$(tc-getCC) $MY_CFLAGS" > "conf-cc"
- else
- echo "$(tc-getCC) $MY_CFLAGS -fPIC -DPIC" > "conf-cc"
- fi
- echo "$(tc-getCC) $LDFLAGS" > "conf-ld"
+ echo "$(tc-getCC) $MY_CFLAGS -fPIC -DPIC" > "conf-cc"
+ echo "$(tc-getCC) ${LDFLAGS}" > "conf-ld"
echo "${MY_D}" > "conf-home"
einfo "conf-cc: $(<conf-cc)"
}
src_compile() {
- emake LIBDJBFFT="$LIBDJBFFT" LIBPERMS="$LIBPERMS" || die
+ emake LIBDJBFFT="$LIBDJBFFT" LIBPERMS="$LIBPERMS" || die "emake failed"
}
src_install() {
- make LIBDJBFFT="$LIBDJBFFT" setup check || die
- if ! use static ; then
- ln -snf "${LIBDJBFFT}" "${MY_D}/lib/libdjbfft.so"
- ln -snf "${LIBDJBFFT}" "${MY_D}/lib/libdjbfft.so.${MY_PV%%.*}"
- fi
+ make LIBDJBFFT="$LIBDJBFFT" setup check || die "install failed"
+ dosym "${LIBDJBFFT}" /usr/$(get_libdir)/libdjbfft.so
+ dosym "${LIBDJBFFT}" /usr/$(get_libdir)/libdjbfft.so.${MY_PV%%.*}
dodoc CHANGES README TODO VERSION
}