summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-08 18:24:58 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-08 18:24:58 +0000
commit324158907b9065d94050168f75a27f9380728287 (patch)
treef3490a2cf958a30d152b0cc40975da54d4148ae2 /sci-libs
parentVersion bump. Switch to github tarball to make tests pass. (diff)
downloadgentoo-2-324158907b9065d94050168f75a27f9380728287.tar.gz
gentoo-2-324158907b9065d94050168f75a27f9380728287.tar.bz2
gentoo-2-324158907b9065d94050168f75a27f9380728287.zip
Version bump
(Portage version: 2.2.01.20796-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/lis/ChangeLog7
-rw-r--r--sci-libs/lis/lis-1.2.91.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/sci-libs/lis/ChangeLog b/sci-libs/lis/ChangeLog
index b3c64711c6a1..f4fd5e832c88 100644
--- a/sci-libs/lis/ChangeLog
+++ b/sci-libs/lis/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/lis
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lis/ChangeLog,v 1.2 2012/08/02 05:08:47 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lis/ChangeLog,v 1.3 2012/08/08 18:24:58 bicatali Exp $
+
+*lis-1.2.91 (08 Aug 2012)
+
+ 08 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> +lis-1.2.91.ebuild:
+ Version bump
*lis-1.2.90 (02 Aug 2012)
diff --git a/sci-libs/lis/lis-1.2.91.ebuild b/sci-libs/lis/lis-1.2.91.ebuild
new file mode 100644
index 000000000000..e58efca1efca
--- /dev/null
+++ b/sci-libs/lis/lis-1.2.91.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lis/lis-1.2.91.ebuild,v 1.1 2012/08/08 18:24:58 bicatali Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+inherit autotools-utils fortran-2
+
+DESCRIPTION="Library of Iterative Solvers for Linear Systems"
+HOMEPAGE="http://www.ssisc.org/lis/index.en.html"
+SRC_URI="http://www.ssisc.org/lis/dl/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fma fortran mpi openmp quad saamg sse2 static-libs"
+
+RDEPEND="mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ fortran? ( virtual/fortran )"
+
+PATCHES=( ${FILESDIR}/${PN}-1.2.62-autotools.patch )
+
+pkg_setup() {
+ if use openmp; then
+ [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp && \
+ die "You have openmp enabled but your current gcc does not support it"
+ export FORTRAN_NEED_OPENMP=1
+ fi
+ use fortran && fortran-2_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable fortran)
+ $(use_enable openmp omp)
+ $(use_enable quad)
+ $(use_enable fma)
+ $(use_enable sse2)
+ $(use_enable saamg)
+ $(use_enable mpi)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc doc/*.pdf
+}