summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2011-01-18 18:12:07 +0000
committerThomas Kahle <tomka@gentoo.org>2011-01-18 18:12:07 +0000
commit12e72d48258db1050f030460a04ea0cfd26d5804 (patch)
treef56fd25088e55feac011130483f1bbb7cd5f3886 /sci-libs
parentVersion bump. (diff)
downloadgentoo-2-12e72d48258db1050f030460a04ea0cfd26d5804.tar.gz
gentoo-2-12e72d48258db1050f030460a04ea0cfd26d5804.tar.bz2
gentoo-2-12e72d48258db1050f030460a04ea0cfd26d5804.zip
bump to 2.2.1
(Portage version: 2.1.9.33/cvs/Linux i686)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mpir/ChangeLog9
-rw-r--r--sci-libs/mpir/mpir-2.2.1.ebuild65
2 files changed, 72 insertions, 2 deletions
diff --git a/sci-libs/mpir/ChangeLog b/sci-libs/mpir/ChangeLog
index 175ed916efe3..5f85e5305367 100644
--- a/sci-libs/mpir/ChangeLog
+++ b/sci-libs/mpir/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/mpir
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mpir/ChangeLog,v 1.3 2010/12/16 09:55:08 tomka Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mpir/ChangeLog,v 1.4 2011/01/18 18:12:07 tomka Exp $
+
+*mpir-2.2.1 (18 Jan 2011)
+
+ 18 Jan 2011; Thomas Kahle <tomka@gentoo.org> +mpir-2.2.1.ebuild:
+ bump to 2.2.1
*mpir-2.2.0 (16 Dec 2010)
diff --git a/sci-libs/mpir/mpir-2.2.1.ebuild b/sci-libs/mpir/mpir-2.2.1.ebuild
new file mode 100644
index 000000000000..adbb8d44fd19
--- /dev/null
+++ b/sci-libs/mpir/mpir-2.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mpir/mpir-2.2.1.ebuild,v 1.1 2011/01/18 18:12:07 tomka Exp $
+
+EAPI="3"
+
+inherit eutils autotools
+
+DESCRIPTION="Library for arbitrary precision integer arithmetic derived from version 4.2.1 of gmp"
+HOMEPAGE="http://www.mpir.org/"
+SRC_URI="http://www.mpir.org/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cxx cpudetection"
+
+DEPEND="x86? ( dev-lang/yasm )
+ amd64? ( dev-lang/yasm )"
+RDEPEND=""
+
+src_prepare(){
+ epatch \
+ "${FILESDIR}/${PN}-2.2.0-yasm.patch" \
+ "${FILESDIR}/${PN}-1.3.0-ABI-multilib.patch"
+ # In the same way there was QA regarding executable stacks
+ # with GMP we have some here as well. We cannot apply the
+ # GMP solution as yasm is used, at least on x86/amd64.
+ # Furthermore we are able to patch config.ac.
+
+ ebegin "Patching assembler files to remove executable sections"
+
+ for i in $(find . -type f -name '*.asm') ; do
+ cat >> $i <<-EOF
+ #if defined(__linux__) && defined(__ELF__)
+ .section .note.GNU-stack,"",%progbits
+ #endif
+ EOF
+ done
+
+ for i in $(find . -type f -name '*.as') ; do
+ cat >> $i <<-EOF
+ %ifidn __OUTPUT_FORMAT__,elf
+ section .note.GNU-stack noalloc noexec nowrite progbits
+ %endif
+ EOF
+ done
+
+ eend
+
+ eautoreconf
+}
+
+src_configure() {
+# beware that cpudetection aka fat binaries is x86/amd64 only.
+# Place mpir in profiles/arch/$arch/package.use.mask when making it available on $arch.
+ econf \
+ $(use_enable cxx) \
+ $(use_enable cpudetection fat)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README NEWS || die
+}