summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-04-21 16:06:40 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-04-21 16:06:40 +0000
commit99a5ab0f4718a3c08724714ae19bcb48804fec65 (patch)
tree6d32eb7889dab7bfce17b3fbb8f9b99feb0dc826 /sci-libs/scipy
parentFix up metadata.xml. If there's no maintainer for the package, the metadata a... (diff)
downloadgentoo-2-99a5ab0f4718a3c08724714ae19bcb48804fec65.tar.gz
gentoo-2-99a5ab0f4718a3c08724714ae19bcb48804fec65.tar.bz2
gentoo-2-99a5ab0f4718a3c08724714ae19bcb48804fec65.zip
Removed buggy versions
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/ChangeLog10
-rw-r--r--sci-libs/scipy/files/scipy-0.6.0-clapack-symbol-fix.patch102
-rw-r--r--sci-libs/scipy/scipy-0.5.2.ebuild101
-rw-r--r--sci-libs/scipy/scipy-0.6.0-r2.ebuild128
-rw-r--r--sci-libs/scipy/scipy-0.6.0-r3.ebuild126
5 files changed, 7 insertions, 460 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index 87bf689cb0a0..cf4a1a5fa8f4 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.29 2008/04/17 00:43:14 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.30 2008/04/21 16:06:39 bicatali Exp $
+
+ 21 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/scipy-0.6.0-clapack-symbol-fix.patch, -scipy-0.5.2.ebuild,
+ -scipy-0.6.0-r2.ebuild, -scipy-0.6.0-r3.ebuild:
+ Removed buggy versions
17 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org>
scipy-0.6.0-r4.ebuild:
- Put append-ldflags in pkg_setup and make it available always (bug #
- 217914)
+ Put append-ldflags in pkg_setup and make it available always (bug #217914)
26 Mar 2008; Markus Rothe <corsair@gentoo.org> scipy-0.6.0-r4.ebuild:
Added ~ppc64; bug #211791
diff --git a/sci-libs/scipy/files/scipy-0.6.0-clapack-symbol-fix.patch b/sci-libs/scipy/files/scipy-0.6.0-clapack-symbol-fix.patch
deleted file mode 100644
index ff2d521363d2..000000000000
--- a/sci-libs/scipy/files/scipy-0.6.0-clapack-symbol-fix.patch
+++ /dev/null
@@ -1,102 +0,0 @@
-diff -Naur scipy-0.6.0/scipy/linalg/generic_clapack.pyf scipy-0.6.0-new/scipy/linalg/generic_clapack.pyf
---- scipy-0.6.0/scipy/linalg/generic_clapack.pyf 2007-09-22 03:56:25.000000000 -0400
-+++ scipy-0.6.0-new/scipy/linalg/generic_clapack.pyf 2007-10-13 10:13:53.000000000 -0400
-@@ -20,7 +20,7 @@
- ! U is unit upper diagonal triangular, L is lower triangular,
- ! piv pivots columns.
-
-- fortranname clapack_<tchar=s,d,c,z>gesv
-+ fortranname <tchar=s,d,c,z>gesv_
- integer intent(c,hide) :: <tchar=s,d,c,z>gesv
- callstatement <tchar=s,d,c,z>gesv_return_value = info = (*f2py_func)(102-rowmajor,n,nrhs,a,n,piv,b,n)
- callprotoargument const int,const int,const int,<type_in_c>*,const int,int*,<type_in_c>*,const int
-@@ -44,7 +44,7 @@
- ! Compute an LU factorization of a general M-by-N matrix A.
- ! A * P = L * U
- threadsafe
-- fortranname clapack_<tchar=s,d,c,z>getrf
-+ fortranname <tchar=s,d,c,z>getrf_
- integer intent(c,hide) :: <tchar=s,d,c,z>getrf
- callstatement <tchar=s,d,c,z>getrf_return_value = info = (*f2py_func)(102-rowmajor,m,n,a,(rowmajor?n:m),piv)
- callprotoargument const int,const int,const int,<type_in_c>*,const int,int*
-@@ -67,7 +67,7 @@
- ! Solve A^H * X = B if trans=2
- ! A * P = L * U
-
-- fortranname clapack_<tchar=s,d,c,z>getrs
-+ fortranname <tchar=s,d,c,z>getrs_
- integer intent(c,hide) :: <tchar=s,d,c,z>getrs
- callstatement <tchar=s,d,c,z>getrs_return_value = info = (*f2py_func)(102-rowmajor,111+trans,n,nrhs,lu,n,piv,b,n)
- callprotoargument const int,const int,const int,const int,<type_in_c>*,const int,int*,<type_in_c>*,const int
-@@ -91,7 +91,7 @@
- ! Find A inverse A^-1.
- ! A * P = L * U
-
-- fortranname clapack_<tchar=s,d,c,z>getri
-+ fortranname <tchar=s,d,c,z>getri_
- integer intent(c,hide) :: <tchar=s,d,c,z>getri
- callstatement <tchar=s,d,c,z>getri_return_value = info = (*f2py_func)(102-rowmajor,n,lu,n,piv)
- callprotoargument const int,const int,<type_in_c>*,const int,const int*
-@@ -115,7 +115,7 @@
- ! A = L * L^T, C = L if lower = 1
- ! C is triangular matrix of the corresponding Cholesky decomposition.
-
-- fortranname clapack_<tchar=s,d,c,z>posv
-+ fortranname <tchar=s,d,c,z>posv_
- integer intent(c,hide) :: <tchar=s,d,c,z>posv
- callstatement <tchar=s,d,c,z>posv_return_value = info = (*f2py_func)(102-rowmajor,121+lower,n,nrhs,a,n,b,n)
- callprotoargument const int,const int,const int,const int,<type_in_c>*,const int,<type_in_c>*,const int
-@@ -142,7 +142,7 @@
- ! C is triangular matrix of the corresponding Cholesky decomposition.
- ! clean==1 zeros strictly lower or upper parts of U or L, respectively
-
-- fortranname clapack_<tchar=s,d>potrf
-+ fortranname <tchar=s,d>potrf_
- integer intent(c,hide) :: <tchar=s,d>potrf
- callstatement <tchar=s,d>potrf_return_value = info = (*f2py_func)(102-rowmajor,121+lower,n,a,n); if(clean){int i,j;if(lower){for(i=0;i<n;++i) for(j=i+1;j<n;++j) *(a+i*n+j)=0.0;} else {for(i=0;i<n;++i) for(j=i+1;j<n;++j) *(a+j*n+i)=0.0;}}
- callprotoargument const int,const int,const int,<type_in_c>*,const int
-@@ -167,7 +167,7 @@
- ! C is triangular matrix of the corresponding Cholesky decomposition.
- ! clean==1 zeros strictly lower or upper parts of U or L, respectively
-
-- fortranname clapack_<tchar=c,z>potrf
-+ fortranname <tchar=c,z>potrf_
- integer intent(c,hide) :: <tchar=c,z>potrf
- callstatement <tchar=c,z>potrf_return_value = info = (*f2py_func)(102-rowmajor,121+lower,n,a,n); if(clean){int i,j,k;if(lower){for(i=0;i<n;++i) for(j=i+1;j<n;++j) {k=i*n+j;(a+k)->r=(a+k)->i=0.0;}} else {for(i=0;i<n;++i) for(j=i+1;j<n;++j) {k=j*n+i;(a+k)->r=(a+k)->i=0.0;}}}
- callprotoargument const int,const int,const int,<type_in_c>*,const int
-@@ -193,7 +193,7 @@
- ! A = L * L^T, C = L if lower = 1
- ! C is triangular matrix of the corresponding Cholesky decomposition.
-
-- fortranname clapack_<tchar=s,d,c,z>potrs
-+ fortranname <tchar=s,d,c,z>potrs_
- integer intent(c,hide) :: <tchar=s,d,c,z>potrs
- callstatement <tchar=s,d,c,z>potrs_return_value = info = (*f2py_func)(102-rowmajor,121+lower,n,nrhs,c,n,b,n)
- callprotoargument const int,const int,const int,const int,<type_in_c>*,const int,<type_in_c>*,const int
-@@ -219,7 +219,7 @@
- ! A = L * L^T, C = L if lower = 1
- ! C is triangular matrix of the corresponding Cholesky decomposition.
-
-- fortranname clapack_<tchar=s,d,c,z>potri
-+ fortranname <tchar=s,d,c,z>potri_
- integer intent(c,hide) :: <tchar=s,d,c,z>potri
- callstatement <tchar=s,d,c,z>potri_return_value = info = (*f2py_func)(102-rowmajor,121+lower,n,c,n)
- callprotoargument const int,const int,const int,<type_in_c>*,const int
-@@ -243,7 +243,7 @@
- ! L * L^T, C = L if lower = 1
- ! C is triangular matrix of the corresponding Cholesky decomposition.
-
-- fortranname clapack_<tchar=s,d,c,z>lauum
-+ fortranname <tchar=s,d,c,z>lauum_
- integer intent(c,hide) :: <tchar=s,d,c,z>lauum
- callstatement <tchar=s,d,c,z>lauum_return_value = info = (*f2py_func)(102-rowmajor,121+lower,n,c,n)
- callprotoargument const int,const int,const int,<type_in_c>*,const int
-@@ -267,7 +267,7 @@
- ! C is non-unit triangular matrix if unitdiag = 0
- ! C is unit triangular matrix if unitdiag = 1
-
-- fortranname clapack_<tchar=s,d,c,z>trtri
-+ fortranname <tchar=s,d,c,z>trtri_
- integer intent(c,hide) :: <tchar=s,d,c,z>trtri
- callstatement <tchar=s,d,c,z>trtri_return_value = info = (*f2py_func)(102-rowmajor,121+lower,131+unitdiag,n,c,n)
- callprotoargument const int,const int,const int,const int,<type_in_c>*,const int
diff --git a/sci-libs/scipy/scipy-0.5.2.ebuild b/sci-libs/scipy/scipy-0.5.2.ebuild
deleted file mode 100644
index 00856bf72100..000000000000
--- a/sci-libs/scipy/scipy-0.5.2.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.5.2.ebuild,v 1.1 2007/01/31 09:03:43 nerdboy Exp $
-
-inherit distutils fortran
-
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-DESCRIPTION="Open source scientific tools for Python"
-HOMEPAGE="http://www.scipy.org/"
-LICENSE="BSD"
-
-SLOT="0"
-IUSE="fftw"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-
-# doc says scipy needs to compile all libraries with the same compiler
-RDEPEND=">=dev-lang/python-2.3.3
- >=dev-python/numpy-1.0
- virtual/blas
- virtual/lapack
- fftw? ( sci-libs/fftw )"
-
-DEPEND="${RDEPEND}"
-
-# install doc claims fftw-2 is faster for complex ffts.
-# wxwindows seems to have disapeared : ?
-# f2py seems to be in numpy.
-
-FORTRAN="g77 gfortran"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- echo "[atlas]" > site.cfg
- echo "include_dirs = /usr/include/atlas" >> site.cfg
- echo -n "library_dirs = /usr/$(get_libdir)/lapack:/usr/$(get_libdir):" \
- >> site.cfg
- if [ -d "/usr/$(get_libdir)/blas/threaded-atlas" ]; then
- echo "/usr/$(get_libdir)/blas/threaded-atlas" >> site.cfg
- echo "atlas_libs = lapack, blas, cblas, atlas, pthread" >> site.cfg
- else
- echo "/usr/$(get_libdir)/blas/atlas" >> site.cfg
- echo "atlas_libs = lapack, blas, cblas, atlas" >> site.cfg
- fi
-
- export FFTW3=None
- if use fftw; then
- echo "[fftw] " >> site.cfg
- echo "fftw_libs = rfftw, fftw" >> site.cfg
- echo "fftw_opt_libs = rfftw_threads, fftw_threads" >> site.cfg
- else
- export FFTW=None
- fi
-}
-
-src_compile() {
- # Map compilers to what scipy calls them
- local SCIPY_FC
- case "${FORTRANC}" in
- gfortran)
- SCIPY_FC="gnu95"
- ;;
- g77)
- SCIPY_FC="gnu"
- ;;
- g95)
- SCIPY_FC="g95"
- ;;
- ifc|ifort)
- if use ia64; then
- SCIPY_FC="intele"
- else
- SCIPY_FC="intel"
- fi
- ;;
- *)
- local msg="Invalid Fortran compiler \'${FORTRANC}\'"
- eerror "${msg}"
- die "${msg}"
- ;;
- esac
-
- # http://projects.scipy.org/scipy/numpy/ticket/182
- # Can't set LDFLAGS
- unset LDFLAGS
-
- # need to build with -fPIC (bug #149153)
- export F77LFLAGS="${F77LFLAGS} -fPIC"
-
- distutils_src_compile \
- config_fc \
- --fcompiler=${SCIPY_FC} \
- --opt="${CFLAGS}" \
- || die "compilation failed"
-}
-
-src_install() {
- distutils_src_install
- dodoc *.txt
-}
diff --git a/sci-libs/scipy/scipy-0.6.0-r2.ebuild b/sci-libs/scipy/scipy-0.6.0-r2.ebuild
deleted file mode 100644
index 2813e1abd714..000000000000
--- a/sci-libs/scipy/scipy-0.6.0-r2.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.6.0-r2.ebuild,v 1.1 2007/10/18 14:17:10 markusle Exp $
-
-NEED_PYTHON=2.3
-
-inherit eutils distutils fortran
-
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/"
-LICENSE="BSD"
-
-SLOT="0"
-
-IUSE="fftw umfpack sandbox"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-
-DEPEND=">=dev-python/numpy-1.0.3.1
- virtual/lapack
- fftw? ( =sci-libs/fftw-2.1* )
- umfpack? ( sci-libs/umfpack dev-lang/swig )
- sandbox? ( >=sci-libs/netcdf-3.6 x11-libs/libX11 )"
-
-RDEPEND=">=dev-python/numpy-1.0.3.1
- dev-python/imaging
- virtual/lapack
- fftw? ( =sci-libs/fftw-2.1* )
- umfpack? ( sci-libs/umfpack )
- sandbox? ( >=sci-libs/netcdf-3.6 x11-libs/libX11 )"
-
-# test still buggy on lapack with 2 failures on check_syevr
-# (lapack float). check every version bump.
-RESTRICT="test"
-
-DOCS="THANKS.txt DEVELOPERS.txt LATEST.txt TOCHANGE.txt FORMAT_GUIDELINES.txt"
-
-scipy_fortran_setup() {
- FORTRAN="gfortran g77 ifc"
- fortran_pkg_setup
- local fc=
- case ${FORTRANC} in
- gfortran) fc=gnu95 ;;
- g77) fc=gnu ;;
- ifc|ifort)
- if use ia64; then
- fc=intele
- elif use amd64; then
- fc=intelem
- else
- fc=intel
- fi
- ;;
- *) eerror "Unknown fortran compiler: ${FORTRANC}"
- die "scipy_fortran_setup failed" ;;
- esac
-
- # when fortran flags are set, pic is removed.
- use amd64 && [[ -n ${FFLAGS} ]] && FFLAGS="${FFLAGS} -fPIC"
- export SCIPY_FCONFIG="config_fc --fcompiler=${fc}"
-}
-
-# see numpy ebuild about unsetting LDFLAGS
-LDFLAGS_sav="${LDFLAGS}"
-unset LDFLAGS
-
-pkg_setup() {
- [[ -n ${LDFLAGS_sav} ]] && einfo "Ignoring LDFLAGS=${LDFLAGS_sav}"
- if use umfpack && ! built_with_use dev-lang/swig python; then
- eerror "With umfpack enabled you need"
- eerror "dev-lang/swig with python enabled"
- einfo "Please re-emerge swig with USE=python"
- die "needs swig with python"
- fi
- # scipy automatically detects libraries by default
- export FFTW=None FFTW3=None UMFPACK=None DJBFFT=None
- use fftw && unset FFTW
- use umfpack && unset UMFPACK
- use sandbox && elog "Warning: using sandbox modules at your own risk!"
- scipy_fortran_setup
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-randomkit.patch
- epatch "${FILESDIR}"/${P}-cdf.patch
- epatch "${FILESDIR}"/${P}-fftw-fix.patch
- epatch "${FILESDIR}"/${P}-clapack-symbol-fix.patch
-
- if use sandbox; then
- cd scipy/sandbox
- ls -1 */__init__.py \
- | sed -e 's:/__init__.py::' \
- | grep -v exmplpackage \
- > enabled_packages.txt \
- || die "sandbox listing failed"
- fi
-}
-
-src_compile() {
- distutils_src_compile ${SCIPY_FCONFIG}
-}
-
-src_test() {
- "${python}" setup.py install \
- --home="${S}"/test \
- --no-compile \
- ${SCIPY_FCONFIG} || die "install test failed"
- pushd "${S}"/test/lib*/python
- PYTHONPATH=. "${python}" -c \
- "import scipy as s;import sys;sys.exit(s.test(10,3))" \
- 2>&1 | tee test.log
- grep -q OK test.log || die "test failed"
- popd
- rm -rf test
-}
-
-src_install() {
- distutils_src_install ${SCIPY_FCONFIG}
-}
-
-pkg_postinst() {
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer if you don't like the default one. Ex:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}
diff --git a/sci-libs/scipy/scipy-0.6.0-r3.ebuild b/sci-libs/scipy/scipy-0.6.0-r3.ebuild
deleted file mode 100644
index 5d8c88fae284..000000000000
--- a/sci-libs/scipy/scipy-0.6.0-r3.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.6.0-r3.ebuild,v 1.1 2007/12/17 12:28:19 bicatali Exp $
-
-NEED_PYTHON=2.3
-
-inherit eutils distutils fortran flag-o-matic
-
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/"
-LICENSE="BSD"
-
-SLOT="0"
-
-IUSE="fftw umfpack sandbox"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-
-DEPEND=">=dev-python/numpy-1.0.3.1
- virtual/lapack
- fftw? ( =sci-libs/fftw-2.1* )
- umfpack? ( sci-libs/umfpack dev-lang/swig )
- sandbox? ( >=sci-libs/netcdf-3.6 x11-libs/libX11 )"
-
-RDEPEND=">=dev-python/numpy-1.0.3.1
- dev-python/imaging
- virtual/lapack
- fftw? ( =sci-libs/fftw-2.1* )
- umfpack? ( sci-libs/umfpack )
- sandbox? ( >=sci-libs/netcdf-3.6 x11-libs/libX11 )"
-
-# test still buggy on lapack with 2 failures on check_syevr
-# (lapack float). check every version bump.
-RESTRICT="test"
-
-DOCS="THANKS.txt DEVELOPERS.txt LATEST.txt TOCHANGE.txt FORMAT_GUIDELINES.txt"
-
-scipy_fortran_setup() {
- FORTRAN="gfortran g77 ifc"
- fortran_pkg_setup
- local fc=
- case ${FORTRANC} in
- gfortran) fc=gnu95 ;;
- g77) fc=gnu ;;
- ifc|ifort)
- if use ia64; then
- fc=intele
- elif use amd64; then
- fc=intelem
- else
- fc=intel
- fi
- ;;
- *) eerror "Unknown fortran compiler: ${FORTRANC}"
- die "scipy_fortran_setup failed" ;;
- esac
-
- # when fortran flags are set, pic is removed.
- use amd64 && [[ -n ${FFLAGS} ]] && FFLAGS="${FFLAGS} -fPIC"
- export SCIPY_FCONFIG="config_fc --fcompiler=${fc}"
-}
-
-# whatever LDFLAGS set will break linking
-# see progress in http://projects.scipy.org/scipy/numpy/ticket/573
-[ -n "${LDFLAGS}" ] && append-ldflags -shared
-
-pkg_setup() {
- if use umfpack && ! built_with_use dev-lang/swig python; then
- eerror "With umfpack enabled you need"
- eerror "dev-lang/swig with python enabled"
- einfo "Please re-emerge swig with USE=python"
- die "needs swig with python"
- fi
- # scipy automatically detects libraries by default
- export FFTW=None FFTW3=None UMFPACK=None DJBFFT=None
- use fftw && unset FFTW
- use umfpack && unset UMFPACK
- use sandbox && elog "Warning: using sandbox modules at your own risk!"
- scipy_fortran_setup
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-randomkit.patch
- epatch "${FILESDIR}"/${P}-cdf.patch
- epatch "${FILESDIR}"/${P}-fftw-fix.patch
-
- if use sandbox; then
- cd scipy/sandbox
- ls -1 */__init__.py \
- | sed -e 's:/__init__.py::' \
- | grep -v exmplpackage \
- > enabled_packages.txt \
- || die "sandbox listing failed"
- fi
-}
-
-src_compile() {
- distutils_src_compile ${SCIPY_FCONFIG}
-}
-
-src_test() {
- "${python}" setup.py install \
- --home="${S}"/test \
- --no-compile \
- ${SCIPY_FCONFIG} || die "install test failed"
- pushd "${S}"/test/lib*/python
- PYTHONPATH=. "${python}" -c \
- "import scipy as s;import sys;sys.exit(s.test(10,3))" \
- 2>&1 | tee test.log
- grep -q OK test.log || die "test failed"
- popd
- rm -rf test
-}
-
-src_install() {
- distutils_src_install ${SCIPY_FCONFIG}
-}
-
-pkg_postinst() {
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer if you don't like the default one. Ex:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}