summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-01-21 19:04:57 +0000
committerFabian Groffen <grobian@gentoo.org>2010-01-21 19:04:57 +0000
commitae0a97f838eab291b635d3ed616f6b8c5be9c426 (patch)
treec5c8f37093e553cb8f6fa3791969de1b23e253a7 /sci-libs/qrupdate
parentVersion bump. (diff)
downloadgentoo-2-ae0a97f838eab291b635d3ed616f6b8c5be9c426.tar.gz
gentoo-2-ae0a97f838eab291b635d3ed616f6b8c5be9c426.tar.bz2
gentoo-2-ae0a97f838eab291b635d3ed616f6b8c5be9c426.zip
Revbump to add Prefix awareness, fix up buildsystem to properly support DESTDIR installs, fix shared libs install for Darwin hosts. Both patches got accepted and committed upstream. Bug #301437
(Portage version: 2.2.00.15200-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sci-libs/qrupdate')
-rw-r--r--sci-libs/qrupdate/ChangeLog11
-rw-r--r--sci-libs/qrupdate/files/qrupdate-1.1.0-darwin-dylib.patch51
-rw-r--r--sci-libs/qrupdate/files/qrupdate-1.1.0-destdir.patch40
-rw-r--r--sci-libs/qrupdate/qrupdate-1.1.0-r1.ebuild51
4 files changed, 152 insertions, 1 deletions
diff --git a/sci-libs/qrupdate/ChangeLog b/sci-libs/qrupdate/ChangeLog
index 2e5094c06f33..086d75afd1d8 100644
--- a/sci-libs/qrupdate/ChangeLog
+++ b/sci-libs/qrupdate/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-libs/qrupdate
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/ChangeLog,v 1.7 2010/01/12 05:16:13 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/ChangeLog,v 1.8 2010/01/21 19:04:57 grobian Exp $
+
+*qrupdate-1.1.0-r1 (21 Jan 2010)
+
+ 21 Jan 2010; Fabian Groffen <grobian@gentoo.org>
+ +qrupdate-1.1.0-r1.ebuild, +files/qrupdate-1.1.0-darwin-dylib.patch,
+ +files/qrupdate-1.1.0-destdir.patch:
+ Revbump to add Prefix awareness, fix up buildsystem to properly support
+ DESTDIR installs, fix shared libs install for Darwin hosts. Both patches
+ got accepted and committed upstream.
*qrupdate-1.1.0 (12 Jan 2010)
diff --git a/sci-libs/qrupdate/files/qrupdate-1.1.0-darwin-dylib.patch b/sci-libs/qrupdate/files/qrupdate-1.1.0-darwin-dylib.patch
new file mode 100644
index 000000000000..b2e3f109d156
--- /dev/null
+++ b/sci-libs/qrupdate/files/qrupdate-1.1.0-darwin-dylib.patch
@@ -0,0 +1,51 @@
+Add support for building Mach-O dylibs on Darwin.
+
+Applied upstream:
+http://qrupdate.svn.sourceforge.net/viewvc/qrupdate?view=rev&revision=21
+
+--- src/Makefile
++++ src/Makefile
+@@ -36,7 +36,12 @@
+
+ lib: ../libqrupdate.a
+
+-solib: ../libqrupdate.so
++ifeq ($(shell uname),Darwin)
++SOEXT=.dylib
++else
++SOEXT=.so
++endif
++solib: ../libqrupdate$(SOEXT)
+
+ ../libqrupdate.a: $(OBJS)
+ ar -cr $@ $(OBJS)
+@@ -45,6 +47,10 @@
+ $(FC) $(FFLAGS) $(LDFLAGS) -shared -o $@ -Wl,-soname=libqrupdate.so.$(MAJOR) $(OBJS) \
+ $(BLAS) $(LAPACK)
+
++../libqrupdate.dylib: $(OBJS)
++ $(FC) $(FFLAGS) $(LDFLAGS) -dynamiclib -o $@ -install_name $(PREFIX)/$(LIBDIR)/libqrupdate.$(MAJOR).dylib $(OBJS) \
++ $(BLAS) $(LAPACK)
++
+ $(OBJS): %.o: %.f
+ $(FC) $(FFLAGS) $(FPICFLAGS) -c $<
+
+@@ -59,10 +63,17 @@
+
+ install: install-shlib install-staticlib
+
+-install-shlib: ../libqrupdate.so
++install-shlib: ../libqrupdate$(SOEXT) install-lib$(SOEXT)
++
++install-lib.so:
+ install -D -m644 ../libqrupdate.so $(PREFIX)/$(LIBDIR)/libqrupdate.so.$(VERSION)
+ ln -s libqrupdate.so.$(VERSION) $(PREFIX)/$(LIBDIR)/libqrupdate.so.$(MAJOR)
+ ln -s libqrupdate.so.$(VERSION) $(PREFIX)/$(LIBDIR)/libqrupdate.so
+
++install-lib.dylib:
++ install -D -m644 ../libqrupdate.dylib $(PREFIX)/$(LIBDIR)/libqrupdate.$(VERSION).dylib
++ ln -s libqrupdate.$(VERSION).dylib $(PREFIX)/$(LIBDIR)/libqrupdate.$(MAJOR).dylib
++ ln -s libqrupdate.$(VERSION).dylib $(PREFIX)/$(LIBDIR)/libqrupdate.dylib
++
+ install-staticlib: ../libqrupdate.a
+ install -D -m644 ../libqrupdate.a $(PREFIX)/$(LIBDIR)/libqrupdate.a
diff --git a/sci-libs/qrupdate/files/qrupdate-1.1.0-destdir.patch b/sci-libs/qrupdate/files/qrupdate-1.1.0-destdir.patch
new file mode 100644
index 000000000000..b0ff69b29d0f
--- /dev/null
+++ b/sci-libs/qrupdate/files/qrupdate-1.1.0-destdir.patch
@@ -0,0 +1,40 @@
+Support DESTDIR installs
+
+http://qrupdate.svn.sourceforge.net/viewvc/qrupdate?view=rev&revision=22
+
+--- Makeconf
++++ Makeconf
+@@ -17,6 +17,9 @@
+ # The default library dir
+ LIBDIR=lib
+
++# Destination installation offset
++DESTDIR=
++
+ # set default prefix to /usr/local
+ ifeq ($(strip $(PREFIX)),)
+ PREFIX=/usr/local
+--- src/Makefile
++++ src/Makefile
+@@ -65,14 +65,14 @@
+ install-shlib: ../libqrupdate$(SOEXT) install-lib$(SOEXT)
+
+ install-lib.so:
+- install -D -m644 ../libqrupdate.so $(PREFIX)/$(LIBDIR)/libqrupdate.so.$(VERSION)
+- ln -s libqrupdate.so.$(VERSION) $(PREFIX)/$(LIBDIR)/libqrupdate.so.$(MAJOR)
+- ln -s libqrupdate.so.$(VERSION) $(PREFIX)/$(LIBDIR)/libqrupdate.so
++ install -D -m644 ../libqrupdate.so $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.so.$(VERSION)
++ ln -s libqrupdate.so.$(VERSION) $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.so.$(MAJOR)
++ ln -s libqrupdate.so.$(VERSION) $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.so
+
+ install-lib.dylib:
+- install -D -m644 ../libqrupdate.dylib $(PREFIX)/$(LIBDIR)/libqrupdate.$(VERSION).dylib
+- ln -s libqrupdate.$(VERSION).dylib $(PREFIX)/$(LIBDIR)/libqrupdate.$(MAJOR).dylib
+- ln -s libqrupdate.$(VERSION).dylib $(PREFIX)/$(LIBDIR)/libqrupdate.dylib
++ install -D -m644 ../libqrupdate.dylib $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.$(VERSION).dylib
++ ln -s libqrupdate.$(VERSION).dylib $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.$(MAJOR).dylib
++ ln -s libqrupdate.$(VERSION).dylib $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.dylib
+
+ install-staticlib: ../libqrupdate.a
+- install -D -m644 ../libqrupdate.a $(PREFIX)/$(LIBDIR)/libqrupdate.a
++ install -D -m644 ../libqrupdate.a $(DESTDIR)$(PREFIX)/$(LIBDIR)/libqrupdate.a
diff --git a/sci-libs/qrupdate/qrupdate-1.1.0-r1.ebuild b/sci-libs/qrupdate/qrupdate-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..c51ad8497409
--- /dev/null
+++ b/sci-libs/qrupdate/qrupdate-1.1.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.1.0-r1.ebuild,v 1.1 2010/01/21 19:04:57 grobian Exp $
+
+EAPI="2"
+
+inherit eutils fortran multilib
+
+DESCRIPTION="A library for fast updating of QR and Cholesky decompositions"
+HOMEPAGE="http://sourceforge.net/projects/qrupdate"
+SRC_URI="mirror://sourceforge/qrupdate/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+IUSE=""
+
+RDEPEND="virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+FORTRAN="gfortran ifc g77"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.1-makefile.patch
+ # both patches below are already in upstream SVN
+ epatch "${FILESDIR}"/${PN}-1.1.0-darwin-dylib.patch
+ epatch "${FILESDIR}"/${PN}-1.1.0-destdir.patch
+
+ local BLAS_LIBS="$(pkg-config --libs blas)"
+ local LAPACK_LIBS="$(pkg-config --libs lapack)"
+
+ sed -i Makeconf \
+ -e "s:gfortran:${FORTRANC}:g" \
+ -e "s:FFLAGS=.*:FFLAGS=${FFLAGS}:" \
+ -e "s:BLAS=.*:BLAS=${BLAS_LIBS}:" \
+ -e "s:LAPACK=.*:LAPACK=${LAPACK_LIBS}:" \
+ -e "/^LIBDIR=/a\PREFIX=${EPREFIX}/usr" \
+ || die "Failed to set up Makeconf"
+}
+
+src_compile() {
+ emake solib || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-shlib || die "emake install failed"
+
+ dodoc README ChangeLog || die "dodoc failed"
+}