summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-02 10:34:58 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-02 10:34:58 +0000
commit8b37aa653307c10995a7744fb2f6f3a1cd12cc41 (patch)
treedbc779f0cdb2a0b8fe725c1fb5d3a7826e08cf67 /sci-libs/nlopt
parentVersion bump (diff)
downloadgentoo-2-8b37aa653307c10995a7744fb2f6f3a1cd12cc41.tar.gz
gentoo-2-8b37aa653307c10995a7744fb2f6f3a1cd12cc41.tar.bz2
gentoo-2-8b37aa653307c10995a7744fb2f6f3a1cd12cc41.zip
Restrict Py 3.*
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/nlopt')
-rw-r--r--sci-libs/nlopt/ChangeLog6
-rw-r--r--sci-libs/nlopt/nlopt-2.2.1.ebuild11
-rw-r--r--sci-libs/nlopt/nlopt-2.2.ebuild11
3 files changed, 19 insertions, 9 deletions
diff --git a/sci-libs/nlopt/ChangeLog b/sci-libs/nlopt/ChangeLog
index e5407d6bfe98..03f61728b2fc 100644
--- a/sci-libs/nlopt/ChangeLog
+++ b/sci-libs/nlopt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/nlopt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.6 2010/09/27 06:35:45 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.7 2010/12/02 10:34:58 jlec Exp $
+
+ 02 Dec 2010; Justin Lecher <jlec@gentoo.org> nlopt-2.2.ebuild,
+ nlopt-2.2.1.ebuild:
+ Restrict Py 3.*
*nlopt-2.2.1 (27 Sep 2010)
diff --git a/sci-libs/nlopt/nlopt-2.2.1.ebuild b/sci-libs/nlopt/nlopt-2.2.1.ebuild
index 66b38f7825af..b661cc0e796f 100644
--- a/sci-libs/nlopt/nlopt-2.2.1.ebuild
+++ b/sci-libs/nlopt/nlopt-2.2.1.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.1.ebuild,v 1.1 2010/09/27 06:35:45 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.1.ebuild,v 1.2 2010/12/02 10:34:58 jlec Exp $
EAPI=3
+
SUPPORT_PYTHON_ABIS="1"
PYTHON_DEPEND="python? *"
+RESTRICT_PYTHON_ABIS="3.*"
+
inherit eutils python
DESCRIPTION="Non-linear optimization library"
@@ -13,11 +16,11 @@ SRC_URI="${HOMEPAGE}/${P}.tar.gz"
LICENSE="LGPL-2.1 MIT"
KEYWORDS="~amd64 ~x86"
-
SLOT="0"
IUSE="cxx guile octave python static-libs"
-DEPEND="guile? ( dev-scheme/guile )
+DEPEND="
+ guile? ( dev-scheme/guile )
octave? ( sci-mathematics/octave )
python? ( dev-python/numpy )"
RDEPEND="${DEPEND}"
@@ -77,7 +80,7 @@ src_install() {
python_clean_installation_image
fi
- dodoc AUTHORS ChangeLog NEWS README
+ dodoc AUTHORS ChangeLog NEWS README || die
for r in */README; do newdoc ${r} README.$(dirname ${r}); done
}
diff --git a/sci-libs/nlopt/nlopt-2.2.ebuild b/sci-libs/nlopt/nlopt-2.2.ebuild
index d4fc6a6caab3..c6797014ad2d 100644
--- a/sci-libs/nlopt/nlopt-2.2.ebuild
+++ b/sci-libs/nlopt/nlopt-2.2.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.ebuild,v 1.3 2010/08/10 22:04:01 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.ebuild,v 1.4 2010/12/02 10:34:58 jlec Exp $
EAPI=3
+
SUPPORT_PYTHON_ABIS="1"
PYTHON_DEPEND="python? *"
+RESTRICT_PYTHON_ABIS="3.*"
+
inherit eutils python
DESCRIPTION="Non-linear optimization library"
@@ -13,11 +16,11 @@ SRC_URI="${HOMEPAGE}/${P}.tar.gz"
LICENSE="LGPL-2.1 MIT"
KEYWORDS="~amd64 ~x86"
-
SLOT="0"
IUSE="cxx guile octave python static-libs"
-DEPEND="guile? ( dev-scheme/guile )
+DEPEND="
+ guile? ( dev-scheme/guile )
octave? ( sci-mathematics/octave )
python? ( dev-python/numpy )"
RDEPEND="${DEPEND}"
@@ -77,7 +80,7 @@ src_install() {
python_clean_installation_image
fi
- dodoc AUTHORS ChangeLog NEWS README
+ dodoc AUTHORS ChangeLog NEWS README || die
for r in */README; do newdoc ${r} README.$(dirname ${r}); done
}