summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-08-13 17:42:40 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-08-13 17:42:40 +0000
commitc89ce23409223a62104e28e4a885215ad4cb01b5 (patch)
treee29d1790952e9647e959799d58e11263be6f67c8 /sci-libs/netcdf
parentStable on ppc64; bug #139052 (diff)
downloadgentoo-2-c89ce23409223a62104e28e4a885215ad4cb01b5.tar.gz
gentoo-2-c89ce23409223a62104e28e4a885215ad4cb01b5.tar.bz2
gentoo-2-c89ce23409223a62104e28e4a885215ad4cb01b5.zip
simplified fortran handling in pkg_setup (see bug 82431)
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'sci-libs/netcdf')
-rw-r--r--sci-libs/netcdf/ChangeLog6
-rw-r--r--sci-libs/netcdf/netcdf-3.6.1.ebuild25
2 files changed, 8 insertions, 23 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index ca36bbbc82d5..9bcbc867e037 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/netcdf
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.28 2006/08/06 22:19:44 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.29 2006/08/13 17:42:40 nerdboy Exp $
+
+ 13 Aug 2006; Steve Arnold <nerdboy@gentoo.org> netcdf-3.6.1.ebuild:
+ Simplified fortran handling in pkg_setup (see bug 82431) to let the
+ eclass do the work (and hopefully handle the ifc/ifort thing correctly).
06 Aug 2006; Jason Wever <weeve@gentoo.org> netcdf-3.6.1.ebuild:
Stable on SPARC wrt bug #82431.
diff --git a/sci-libs/netcdf/netcdf-3.6.1.ebuild b/sci-libs/netcdf/netcdf-3.6.1.ebuild
index 880d9e19e0e3..689ebd7e32be 100644
--- a/sci-libs/netcdf/netcdf-3.6.1.ebuild
+++ b/sci-libs/netcdf/netcdf-3.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.1.ebuild,v 1.11 2006/08/06 22:19:44 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.1.ebuild,v 1.12 2006/08/13 17:42:40 nerdboy Exp $
inherit fortran eutils toolchain-funcs
@@ -17,27 +17,8 @@ S="${WORKDIR}/${P}/src"
pkg_setup() {
if use fortran ; then
- if test -d /opt/intel/fortran90 ; then
- FORTRAN="ifc"
- need_fortran "ifc"
- einfo "Configuring for Intel Fortran..."
- elif [ $(gcc-major-version) -ge 4 ] \
- && built_with_use sys-devel/gcc fortran ; then
- FORTRAN="gfortran"
- need_fortran "gfortran"
- einfo "Configuring for GNU Fortran 90..."
- else
- ewarn "Can't find a usable Fortran 90 compiler."
- ewarn "No F90 interface should be built, however,"
- ewarn "another Fortran compiler may be detected by"
- ewarn "configure."
- fi
- if [ $(gcc-major-version) -eq 3 ] \
- && built_with_use sys-devel/gcc fortran ; then
- FORTRAN="g77"
- need_fortran "g77"
- einfo "Configuring for GNU Fortran 77..."
- fi
+ need_fortran "gfortran ifc g77"
+# fortran_pkg_setup
else
FORTRAN=""
fi