summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-28 22:19:50 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-28 22:19:50 +0000
commit29e2dfa8c123976dfaa830a1c93a736bb3ad4810 (patch)
tree66dd45de3aac9a23526daee6028855af6d06a0bf /sci-libs/netcdf/files
parentOnly define epause and ebeep in EAPIs 0 1 2. Mark built_with_use as deprecated. (diff)
downloadgentoo-2-29e2dfa8c123976dfaa830a1c93a736bb3ad4810.tar.gz
gentoo-2-29e2dfa8c123976dfaa830a1c93a736bb3ad4810.tar.bz2
gentoo-2-29e2dfa8c123976dfaa830a1c93a736bb3ad4810.zip
Fixed for mpi, now uses exclusively system cfortran, and cleaned the pkg-config files. Thanks Xarthisius for his help.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/netcdf/files')
-rw-r--r--sci-libs/netcdf/files/netcdf-4.0.1-cfortran.patch34
-rw-r--r--sci-libs/netcdf/files/netcdf-4.0.1-pkgconfig.patch45
2 files changed, 79 insertions, 0 deletions
diff --git a/sci-libs/netcdf/files/netcdf-4.0.1-cfortran.patch b/sci-libs/netcdf/files/netcdf-4.0.1-cfortran.patch
new file mode 100644
index 000000000000..56b761df1be3
--- /dev/null
+++ b/sci-libs/netcdf/files/netcdf-4.0.1-cfortran.patch
@@ -0,0 +1,34 @@
+--- netcdf-4.0.1.orig/configure.ac 2009-03-26 13:10:02.000000000 +0100
++++ netcdf-4.0.1/configure.ac 2010-01-28 19:01:47.156238559 +0100
+@@ -801,7 +801,7 @@
+ *)
+ # If it's a gnu compiler, guess f2c.
+ if test "x$ac_cv_fc_compiler_gnu" = xyes; then
+- AC_DEFINE(f2cFortran, [1], [Turned on by netCDF configure.])
++ AC_DEFINE(gFortran, [1], [Turned on by netCDF configure.])
+ fi
+ ;;
+ esac
+
+--- netcdf-4.0.1.orig/fortran/ncfortran.h 2009-02-19 13:50:25.000000000 +0100
++++ netcdf-4.0.1/fortran/ncfortran.h 2009-09-24 21:10:08.000000000 +0200
+@@ -660,7 +660,7 @@
+ * The following is for f2c-support only.
+ */
+
+-#if defined(f2cFortran) && !defined(pgiFortran)
++#if defined(f2cFortran) && !defined(pgiFortran) && !defined(gFortran)
+
+ /*
+ * The f2c(1) utility on BSD/OS and Linux systems adds an additional
+--- netcdf-4.0.1.orig/nf_test/fortlib.c 2009-09-24 21:11:12.000000000 +0200
++++ netcdf-4.0.1/nf_test/fortlib.c 2009-09-24 21:11:36.000000000 +0200
+@@ -14,7 +14,7 @@
+ #include "../fortran/ncfortran.h"
+
+
+-#if defined(f2cFortran) && !defined(pgiFortran)
++#if defined(f2cFortran) && !defined(pgiFortran) && !defined(gFortran)
+ /*
+ * The f2c(1) utility on BSD/OS and Linux systems adds an additional
+ * underscore suffix (besides the usual one) to global names that have
diff --git a/sci-libs/netcdf/files/netcdf-4.0.1-pkgconfig.patch b/sci-libs/netcdf/files/netcdf-4.0.1-pkgconfig.patch
new file mode 100644
index 000000000000..4bd940fee82e
--- /dev/null
+++ b/sci-libs/netcdf/files/netcdf-4.0.1-pkgconfig.patch
@@ -0,0 +1,45 @@
+diff -Nru netcdf-4.0.1.orig/configure.ac netcdf-4.0.1/configure.ac
+--- netcdf-4.0.1.orig/configure.ac 2009-03-26 12:10:02.000000000 +0000
++++ netcdf-4.0.1/configure.ac 2010-01-28 22:10:56.000000000 +0000
+@@ -1159,11 +1159,11 @@
+ fi
+ if test "x$enable_netcdf_4" = xyes ; then
+ if test "x$HDF5DIR" != x ; then
+- NC_LIBS="$NC_LIBS -L$HDF5DIR"
++ NC_LIBS="$NC_LIBS -L$HDF5DIR/lib"
+ fi
+ NC_LIBS="$NC_LIBS -lhdf5_hl -lhdf5 $SZLIB_LIBS"
+ if test "x$ZLIBDIR" != x ; then
+- NC_LIBS="$NC_LIBS -L$ZLIBDIR"
++ NC_LIBS="$NC_LIBS -L$ZLIBDIR/lib"
+ fi
+ NC_LIBS="$NC_LIBS -lz $LIBS"
+ fi
+diff -Nru netcdf-4.0.1.orig/nc-config.in netcdf-4.0.1/nc-config.in
+--- netcdf-4.0.1.orig/nc-config.in 2009-03-18 20:28:46.000000000 +0000
++++ netcdf-4.0.1/nc-config.in 2010-01-28 21:48:02.000000000 +0000
+@@ -4,9 +4,9 @@
+ #
+
+ prefix=@prefix@
+-exec_prefix=${prefix}
+-libdir=${exec_prefix}/lib
+-includedir=${prefix}/include
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
+
+ cc="@CC@"
+ cxx="@CXX@"
+diff -Nru netcdf-4.0.1.orig/netcdf.pc.in netcdf-4.0.1/netcdf.pc.in
+--- netcdf-4.0.1.orig/netcdf.pc.in 2009-03-19 12:22:33.000000000 +0000
++++ netcdf-4.0.1/netcdf.pc.in 2010-01-28 22:11:32.000000000 +0000
+@@ -6,7 +6,7 @@
+ cppcompiler=@CXX@
+ fcompiler=@FC@
+ fflags=@FFLAGS@ -I${includedir}
+-flibs=@FLIBS@ @NC_FLIBS@
++flibs=@NC_FLIBS@
+
+ Name: @PACKAGE@
+ Description: NetCDF Client Library