summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-25 10:29:25 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-25 10:29:25 +0000
commit1ac1b8046b3050433ba0b72dd7c116206868b26b (patch)
tree8709d8f0932344b7a8e9d6696200eaa6e2508c49 /sci-libs/mmtk
parentVersion bump to ruby-gnome 0.19.4. (diff)
downloadgentoo-2-1ac1b8046b3050433ba0b72dd7c116206868b26b.tar.gz
gentoo-2-1ac1b8046b3050433ba0b72dd7c116206868b26b.tar.bz2
gentoo-2-1ac1b8046b3050433ba0b72dd7c116206868b26b.zip
Version Bump, Python ABI fixes, #316225
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/mmtk')
-rw-r--r--sci-libs/mmtk/ChangeLog7
-rw-r--r--sci-libs/mmtk/mmtk-2.7.1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/sci-libs/mmtk/ChangeLog b/sci-libs/mmtk/ChangeLog
index 11988cfe1558..19c921eca5be 100644
--- a/sci-libs/mmtk/ChangeLog
+++ b/sci-libs/mmtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/mmtk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mmtk/ChangeLog,v 1.6 2010/02/11 22:31:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mmtk/ChangeLog,v 1.7 2010/04/25 10:29:25 jlec Exp $
+
+*mmtk-2.7.1 (25 Apr 2010)
+
+ 25 Apr 2010; Justin Lecher <jlec@gentoo.org> +mmtk-2.7.1.ebuild:
+ Version Bump, Python ABI fixes, #316225
*mmtk-2.6.1 (11 Feb 2010)
diff --git a/sci-libs/mmtk/mmtk-2.7.1.ebuild b/sci-libs/mmtk/mmtk-2.7.1.ebuild
new file mode 100644
index 000000000000..32ca445e6fdd
--- /dev/null
+++ b/sci-libs/mmtk/mmtk-2.7.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mmtk/mmtk-2.7.1.ebuild,v 1.1 2010/04/25 10:29:25 jlec Exp $
+
+EAPI="2"
+
+PYTHON_MODNAME=${MY_PN}
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+# This number identifies each release on the CRU website.
+# Can't figure out how to avoid hardcoding it.
+NUMBER="2936"
+
+MY_PN=${PN/mmtk/MMTK}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Molecular Modeling ToolKit for Python"
+HOMEPAGE="http://dirac.cnrs-orleans.fr/MMTK/"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${NUMBER}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/scientificpython-2.6"
+DEPEND="${RDEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ sed -i -e "/ext_package/d" \
+ "${S}"/setup.py \
+ || die
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc README* Doc/CHANGELOG || die
+ dohtml -r Doc/{HTML,Reference} || die
+
+ insinto /usr/share/doc/${PF}/pdf
+ doins Doc/PDF/manual.pdf || die
+}