summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-10-10 20:55:34 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-10-10 20:55:34 +0000
commit8e66ce1ad806f72b0b487ee0020d8333a6578751 (patch)
tree61d912949a05e65930d0cedb4fc92a310d096a51 /sci-libs/libspatialindex
parentversion bump (diff)
downloadgentoo-2-8e66ce1ad806f72b0b487ee0020d8333a6578751.tar.gz
gentoo-2-8e66ce1ad806f72b0b487ee0020d8333a6578751.tar.bz2
gentoo-2-8e66ce1ad806f72b0b487ee0020d8333a6578751.zip
version bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'sci-libs/libspatialindex')
-rw-r--r--sci-libs/libspatialindex/ChangeLog8
-rw-r--r--sci-libs/libspatialindex/libspatialindex-1.8.4.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/sci-libs/libspatialindex/ChangeLog b/sci-libs/libspatialindex/ChangeLog
index 5f1f4a0ea21a..1a7a212e9713 100644
--- a/sci-libs/libspatialindex/ChangeLog
+++ b/sci-libs/libspatialindex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/libspatialindex
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libspatialindex/ChangeLog,v 1.8 2014/10/10 11:01:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libspatialindex/ChangeLog,v 1.9 2014/10/10 20:55:34 hasufell Exp $
+
+*libspatialindex-1.8.4 (10 Oct 2014)
+
+ 10 Oct 2014; Julian Ospald <hasufell@gentoo.org>
+ +libspatialindex-1.8.4.ebuild:
+ version bump
10 Oct 2014; Agostino Sarubbo <ago@gentoo.org> libspatialindex-1.8.1.ebuild:
Stable for x86, wrt bug #523540
diff --git a/sci-libs/libspatialindex/libspatialindex-1.8.4.ebuild b/sci-libs/libspatialindex/libspatialindex-1.8.4.ebuild
new file mode 100644
index 000000000000..9d9b3ca698ae
--- /dev/null
+++ b/sci-libs/libspatialindex/libspatialindex-1.8.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libspatialindex/libspatialindex-1.8.4.ebuild,v 1.1 2014/10/10 20:55:34 hasufell Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_PN="spatialindex-src"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="General framework for developing spatial indices"
+HOMEPAGE="http://libspatialindex.github.com/"
+SRC_URI="http://download.osgeo.org/libspatialindex/${MY_P}.tar.bz2"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0/4"
+IUSE="debug static-libs"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.8.1-QA.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}