summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-22 03:32:23 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-22 03:32:23 +0000
commit96a98175d72aea8bcd8528d99a5026416695937a (patch)
tree4db7263269222cf8a2a69663f86d2d49610a45d3 /sci-libs/hypre
parentRemove old. (diff)
downloadgentoo-2-96a98175d72aea8bcd8528d99a5026416695937a.tar.gz
gentoo-2-96a98175d72aea8bcd8528d99a5026416695937a.tar.bz2
gentoo-2-96a98175d72aea8bcd8528d99a5026416695937a.zip
Initial import from the science overlay. Version bump, rewritten from scratch.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/hypre')
-rw-r--r--sci-libs/hypre/ChangeLog11
-rw-r--r--sci-libs/hypre/Manifest4
-rw-r--r--sci-libs/hypre/hypre-2.8.0b.ebuild73
-rw-r--r--sci-libs/hypre/metadata.xml9
4 files changed, 97 insertions, 0 deletions
diff --git a/sci-libs/hypre/ChangeLog b/sci-libs/hypre/ChangeLog
new file mode 100644
index 000000000000..3585f8e413a4
--- /dev/null
+++ b/sci-libs/hypre/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/hypre
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hypre/ChangeLog,v 1.1 2012/01/22 03:32:23 bicatali Exp $
+
+*hypre-2.8.0b (22 Jan 2012)
+
+ 22 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +hypre-2.8.0b.ebuild,
+ +metadata.xml:
+ Initial import from the science overlay. Version bump, rewritten from
+ scratch.
+
diff --git a/sci-libs/hypre/Manifest b/sci-libs/hypre/Manifest
new file mode 100644
index 000000000000..41166b9a4e49
--- /dev/null
+++ b/sci-libs/hypre/Manifest
@@ -0,0 +1,4 @@
+DIST hypre-2.8.0b.tar.gz 9979835 RMD160 c8fc3cf4adbc8f909a6fb55c1815bfb25f98c22e SHA1 5824d0e0fb6bd2dd9b5f7cb138ae47813504976d SHA256 78c3b073e3bd0627d7102f6f53e71e74619f9a8cb1c5e6cefdb9a6b2e9c7b9f5
+EBUILD hypre-2.8.0b.ebuild 1701 RMD160 f30ab0eaebc4c0da4c536c2b3305344c89349d8c SHA1 cbad1c7d4d587a2b634779baf93ed97bb7bb2475 SHA256 f5be8fbef90073daef6a1f6040f553b9ae7eee5bb3b83688508a5601a6e74a78
+MISC ChangeLog 322 RMD160 08b6154f2c7e05d21b886a4354ea1665a1c73595 SHA1 89001b90c52aa532b86672ebe7ca0fd61a466a96 SHA256 db1739781bc28bd4e8c43983df4f52bdda859c61b312ed16782b61991d756244
+MISC metadata.xml 331 RMD160 9ea6abad7c0cb445992fd6cf42d6c7db0fdd7d9e SHA1 3975009e64c90d8ec558295f938144498423cf1c SHA256 cc2c2880be52382fbd3c0816d48b969469b1f66ef208fb32887a45dc8824d081
diff --git a/sci-libs/hypre/hypre-2.8.0b.ebuild b/sci-libs/hypre/hypre-2.8.0b.ebuild
new file mode 100644
index 000000000000..0c79d0d8013b
--- /dev/null
+++ b/sci-libs/hypre/hypre-2.8.0b.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hypre/hypre-2.8.0b.ebuild,v 1.1 2012/01/22 03:32:23 bicatali Exp $
+
+EAPI=4
+
+inherit fortran-2 eutils
+
+DESCRIPTION="Parallel matrix preconditioners library"
+HOMEPAGE="http://acts.nersc.gov/hypre/"
+SRC_URI="https://computation.llnl.gov/casc/hypre/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="blas doc examples fortran lapack mpi"
+
+RDEPEND="mpi? ( virtual/mpi )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )"
+DEPEND="${RDEPEND}
+ fortran? ( virtual/fortran )
+ dev-util/pkgconfig"
+
+DOCS=( "${WORKDIR}"/${P}/{CHANGELOG,COPYRIGHT,README} )
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ # link with system superlu and propagate LDFLAGS
+ sed -i \
+ -e 's:@LIBS@:@LIBS@ -lsuperlu:' \
+ -e 's:_SHARED@:_SHARED@ $(LDFLAGS):g' \
+ config/Makefile.config.in || die
+}
+
+src_configure() {
+ myeconfargs+=(
+ --enable-shared
+ --without-superlu
+ $(use_enable fortran)
+ $(use_with mpi MPI)
+ )
+ if use blas; then
+ myeconfargs+=(
+ --with-blas-libs="$(pkg-config --libs-only-l blas | sed -e 's/-l//g')"
+ --with-blas-lib-dirs="$(pkg-config --libs-only-L blas | sed -e 's/-L//g')"
+ )
+ else
+ myeconfargs+=( --without-blas )
+ fi
+ if use lapack; then
+ myeconfargs+=(
+ --with-lapack-libs="$(pkg-config --libs-only-l lapack | sed -e 's/-l//g')"
+ --with-lapack-lib-dirs="$(pkg-config --libs-only-L lapack | sed -e 's/-L//g')"
+ )
+ else
+ myeconfargs+=( --without-lapack )
+ fi
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ dolib.so hypre/lib/lib*
+ insinto /usr/include/hypre
+ doins -r hypre/include
+
+ use doc && dodoc "${WORKDIR}"/${P}/docs/*.pdf
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/hypre/metadata.xml b/sci-libs/hypre/metadata.xml
new file mode 100644
index 000000000000..1a2be524a2b4
--- /dev/null
+++ b/sci-libs/hypre/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<longdescription lang='en'>
+ Hypre is a set of matrix preconditioning libraries to aid in the
+ solution of large systems of linear equations.
+</longdescription>
+</pkgmetadata>