summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-11-06 19:56:41 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-11-06 19:56:41 +0000
commit105f10eb9436ea04c95cfdf18c695466400ba0f8 (patch)
treeced8128782d52693f3dc8147e6e0bd4456c98d9e /sci-libs/hdf5
parentStable for amd64, wrt bug #442044 (diff)
downloadgentoo-2-105f10eb9436ea04c95cfdf18c695466400ba0f8.tar.gz
gentoo-2-105f10eb9436ea04c95cfdf18c695466400ba0f8.tar.bz2
gentoo-2-105f10eb9436ea04c95cfdf18c695466400ba0f8.zip
Version bump
(Portage version: 2.2.0_alpha138/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'sci-libs/hdf5')
-rw-r--r--sci-libs/hdf5/ChangeLog9
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.10-buildsystem.patch33
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.10-implicits.patch54
-rw-r--r--sci-libs/hdf5/hdf5-1.8.10.ebuild103
4 files changed, 198 insertions, 1 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index 54540e8651cc..15523d49c0c2 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/hdf5
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.97 2012/11/04 14:09:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.98 2012/11/06 19:56:41 xarthisius Exp $
+
+*hdf5-1.8.10 (06 Nov 2012)
+
+ 06 Nov 2012; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/hdf5-1.8.10-buildsystem.patch, +files/hdf5-1.8.10-implicits.patch,
+ +hdf5-1.8.10.ebuild:
+ Version bump
04 Nov 2012; Agostino Sarubbo <ago@gentoo.org> hdf5-1.8.9-r2.ebuild:
Stable for amd64, wrt bug #440682
diff --git a/sci-libs/hdf5/files/hdf5-1.8.10-buildsystem.patch b/sci-libs/hdf5/files/hdf5-1.8.10-buildsystem.patch
new file mode 100644
index 000000000000..58bcc500165f
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.10-buildsystem.patch
@@ -0,0 +1,33 @@
+Prevent build system with messing up LD_LIBRARY_PATH
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -2331,8 +2331,6 @@ AC_TRY_COMPILE(,[
+ ##
+ AC_MSG_CHECKING([how to print long long])
+ AC_CACHE_VAL([hdf5_cv_printf_ll], [
+-LD_LIBRARY_PATH="$LD_LIBRARY_PATH`echo $AM_LDFLAGS $LDFLAGS | sed -e 's/-L/:/g' -e 's/ //g'`"
+-export LD_LIBRARY_PATH
+
+ for hdf5_cv_printf_ll in l ll L q unknown; do
+ AC_TRY_RUN([
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -125,8 +125,6 @@ settings_DATA=libhdf5.settings
+ # Remove the generated .c file if errors occur unless HDF5_Make_Ignore
+ # is set to ignore the error.
+ H5Tinit.c: H5detect$(EXEEXT)
+- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
+- sed -e 's/-L/:/g' -e 's/ //g'`" \
+ $(RUNSERIAL) ./H5detect$(EXEEXT) > $@ || \
+ (test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
+ ($(RM) $@ ; exit 1)
+@@ -137,8 +135,6 @@ H5Tinit.c: H5detect$(EXEEXT)
+ # Remove the generated .c file if errors occur unless HDF5_Make_Ignore
+ # is set to ignore the error.
+ H5lib_settings.c: H5make_libsettings$(EXEEXT) libhdf5.settings
+- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
+- sed -e 's/-L/:/g' -e 's/ //g'`" \
+ $(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > $@ || \
+ (test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
+ ($(RM) $@ ; exit 1)
diff --git a/sci-libs/hdf5/files/hdf5-1.8.10-implicits.patch b/sci-libs/hdf5/files/hdf5-1.8.10-implicits.patch
new file mode 100644
index 000000000000..a0b59b74e703
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.10-implicits.patch
@@ -0,0 +1,54 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1494,6 +1494,9 @@ case "$host_cpu-$host_vendor-$host_os" in
+ ## however, we do not do this since it breaks the big test on some
+ ## older platforms.
+ AM_CPPFLAGS="-D_BSD_SOURCE $AM_CPPFLAGS"
++
++ dnl _GNU_SOURCE is needed for vasprintf
++ AM_CPPFLAGS="-D_GNU_SOURCE $AM_CPPFLAGS"
+ ;;
+ esac
+
+--- a/hl/src/H5LTanalyze.c
++++ b/hl/src/H5LTanalyze.c
+@@ -49,6 +49,7 @@
+ #define YY_FLEX_MINOR_VERSION 5
+
+ #include <stdio.h>
++#include "H5pubconf.h"
+ #ifdef H5_HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
+--- a/test/cache_common.h
++++ b/test/cache_common.h
+@@ -702,5 +702,9 @@ void validate_mdc_config(hid_t file_id,
+ hbool_t compare_init,
+ int test_num);
+
++hbool_t resize_configs_are_equal(const H5C_auto_size_ctl_t *a,
++ const H5C_auto_size_ctl_t *b,
++ hbool_t compare_init);
++
+ #endif /* _CACHE_COMMON_H */
+
+--- a/tools/h5repack/testh5repack_detect_szip.c
++++ b/tools/h5repack/testh5repack_detect_szip.c
+@@ -18,6 +18,7 @@
+ #include "h5tools.h"
+ #include "h5tools_utils.h"
+ #include "h5test.h"
++#include "h5tools_utils.h"
+
+
+ /* Name of tool */
+--- a/tools/misc/talign.c
++++ b/tools/misc/talign.c
+@@ -23,6 +23,7 @@
+
+ #include "hdf5.h"
+ #include "H5private.h"
++#include "h5tools.h"
+
+ const char *fname = "talign.h5";
+ const char *setname = "align";
diff --git a/sci-libs/hdf5/hdf5-1.8.10.ebuild b/sci-libs/hdf5/hdf5-1.8.10.ebuild
new file mode 100644
index 000000000000..a2ba3a2d257a
--- /dev/null
+++ b/sci-libs/hdf5/hdf5-1.8.10.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.10.ebuild,v 1.1 2012/11/06 19:56:41 xarthisius Exp $
+
+EAPI=4
+
+FORTRAN_NEEDED=fortran
+
+inherit autotools eutils fortran-2 flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="General purpose library and file format for storing scientific data"
+HOMEPAGE="http://www.hdfgroup.org/HDF5/"
+SRC_URI="http://www.hdfgroup.org/ftp/HDF5/releases/${P}/src/${P}.tar.bz2"
+
+LICENSE="NCSA-HDF"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="cxx debug examples fortran fortran2003 mpi static-libs szip threads zlib"
+
+REQUIRED_USE="
+ cxx? ( !mpi ) mpi? ( !cxx )
+ threads? ( !cxx !mpi !fortran )
+ fortran2003? ( fortran )"
+
+RDEPEND="
+ mpi? ( virtual/mpi[romio] )
+ szip? ( >=sci-libs/szip-2.1 )
+ zlib? ( sys-libs/zlib )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool:2"
+
+pkg_setup() {
+ tc-export CXX CC # workaround for bug 285148
+ if use fortran; then
+ use fortran2003 && FORTRAN_STANDARD=2003
+ fortran-2_pkg_setup
+ fi
+ if use mpi; then
+ if has_version 'sci-libs/hdf5[-mpi]'; then
+ ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to enabling mpi support."
+ fi
+ export CC=mpicc
+ use fortran && export FC=mpif90
+ elif has_version 'sci-libs/hdf5[mpi]'; then
+ ewarn "Installing hdf5 with mpi disabled while having hdf5 installed with mpi enabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to disabling mpi support."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buildsystem.patch \
+ "${FILESDIR}"/${PN}-1.8.8-array_bounds.patch \
+ "${FILESDIR}"/${P}-implicits.patch \
+ "${FILESDIR}"/${PN}-1.8.9-static_libgfortran.patch \
+ "${FILESDIR}"/${PN}-1.8.9-mpicxx.patch
+ # respect gentoo examples directory
+ sed \
+ -e "s:hdf5_examples:doc/${PF}/examples:g" \
+ -i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
+ sed \
+ -e '/docdir/d' \
+ -i config/commence.am || die
+ if ! use examples; then
+ sed -e '/^install:/ s/install-examples//' \
+ -i Makefile.am || die #409091
+ fi
+ eautoreconf
+ # enable shared libs by default for h5cc config utility
+ sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/misc/h5cc.in || die
+ # bug #419677
+ use prefix && \
+ append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir) \
+ -Wl,-rpath,"${EPREFIX}"/$(get_libdir)
+}
+
+src_configure() {
+ econf \
+ --enable-production \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-deprecated-symbols \
+ --enable-shared \
+ --disable-silent-rules \
+ $(use_enable prefix sharedlib-rpath) \
+ $(use_enable static-libs static) \
+ $(use_enable debug debug all) \
+ $(use_enable debug codestack) \
+ $(use_enable cxx) \
+ $(use_enable fortran) \
+ $(use_enable fortran2003) \
+ $(use_enable mpi parallel) \
+ $(use_enable threads threadsafe) \
+ $(use_with szip szlib) \
+ $(use_with threads pthread) \
+ $(use_with zlib) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+}