summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-18 21:30:05 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-18 21:30:05 +0000
commit99e9c94611c062b5b4d524f5525e635362cc0ca2 (patch)
tree7b8e9220b30953e436d9dd09af1db7f52770d43d /sci-libs/hdf5/hdf5-1.8.9-r2.ebuild
parentsci-libs/hdf: Remove virtual/fortran and always call fortran-2_pkg_setup as i... (diff)
downloadgentoo-2-99e9c94611c062b5b4d524f5525e635362cc0ca2.tar.gz
gentoo-2-99e9c94611c062b5b4d524f5525e635362cc0ca2.tar.bz2
gentoo-2-99e9c94611c062b5b4d524f5525e635362cc0ca2.zip
sci-libs/hdf5: Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the updated fortran-2.eclass
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs/hdf5/hdf5-1.8.9-r2.ebuild')
-rw-r--r--sci-libs/hdf5/hdf5-1.8.9-r2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sci-libs/hdf5/hdf5-1.8.9-r2.ebuild b/sci-libs/hdf5/hdf5-1.8.9-r2.ebuild
index a868804f95b9..c4ab468ee4e1 100644
--- a/sci-libs/hdf5/hdf5-1.8.9-r2.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.9-r2.ebuild,v 1.4 2012/10/15 11:36:52 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.9-r2.ebuild,v 1.5 2012/10/18 21:30:05 jlec Exp $
EAPI=4
@@ -16,12 +16,13 @@ LICENSE="NCSA-HDF"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="cxx debug examples fortran fortran2003 mpi static-libs szip threads zlib"
-REQUIRED_USE="cxx? ( !mpi ) mpi? ( !cxx )
+
+REQUIRED_USE="
+ cxx? ( !mpi ) mpi? ( !cxx )
threads? ( !cxx !mpi !fortran )
fortran2003? ( fortran )"
RDEPEND="
- fortran? ( virtual/fortran )
mpi? ( virtual/mpi[romio] )
szip? ( >=sci-libs/szip-2.1 )
zlib? ( sys-libs/zlib )"
@@ -30,7 +31,7 @@ DEPEND="${RDEPEND}
sys-devel/libtool:2"
pkg_setup() {
- tc-export CXX CC FC # workaround for bug 285148
+ tc-export CXX CC # workaround for bug 285148
if use fortran; then
use fortran2003 && FORTRAN_STANDARD=2003
fortran-2_pkg_setup