summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-12-20 23:16:07 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-12-20 23:16:07 +0000
commit4c18dc7a50212d04368d6577d954ef80a70a0683 (patch)
tree9c35a84cc6fbd3a2ab091b93f885284df1f99907 /sci-libs/grib_api
parentStable for AMD64, wrt bug #390963 (diff)
downloadgentoo-2-4c18dc7a50212d04368d6577d954ef80a70a0683.tar.gz
gentoo-2-4c18dc7a50212d04368d6577d954ef80a70a0683.tar.bz2
gentoo-2-4c18dc7a50212d04368d6577d954ef80a70a0683.zip
Fixed automagic and jpeg2k support, bug #391797
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/grib_api')
-rw-r--r--sci-libs/grib_api/ChangeLog5
-rw-r--r--sci-libs/grib_api/grib_api-1.9.9.ebuild22
2 files changed, 20 insertions, 7 deletions
diff --git a/sci-libs/grib_api/ChangeLog b/sci-libs/grib_api/ChangeLog
index 765060e23aa1..613622a1859c 100644
--- a/sci-libs/grib_api/ChangeLog
+++ b/sci-libs/grib_api/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/grib_api
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/grib_api/ChangeLog,v 1.6 2011/11/20 20:34:45 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/grib_api/ChangeLog,v 1.7 2011/12/20 23:16:07 bicatali Exp $
+
+ 20 Dec 2011; Sébastien Fabbro <bicatali@gentoo.org> grib_api-1.9.9.ebuild:
+ Fixed automagic and jpeg2k support, bug #391797
*grib_api-1.9.9 (20 Nov 2011)
diff --git a/sci-libs/grib_api/grib_api-1.9.9.ebuild b/sci-libs/grib_api/grib_api-1.9.9.ebuild
index beccc2016d98..c39ad59c10dd 100644
--- a/sci-libs/grib_api/grib_api-1.9.9.ebuild
+++ b/sci-libs/grib_api/grib_api-1.9.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/grib_api/grib_api-1.9.9.ebuild,v 1.1 2011/11/20 20:34:45 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/grib_api/grib_api-1.9.9.ebuild,v 1.2 2011/12/20 23:16:07 bicatali Exp $
EAPI=3
inherit eutils autotools
@@ -33,19 +33,29 @@ src_prepare() {
}
src_configure() {
+ local myconf
+ if use jpeg2k; then
+ myconf="--enable-jpeg"
+ if hasv media-libs/jasper; then
+ myconf="${myconf} --with-jasper=system --without-openjpeg"
+ elif hasv media-libs/openjpeg; then
+ myconf="${myconf} --without-jasper --with-openjpeg=system"
+ fi
+ else
+ myconf="--disable-jpeg --without-jasper --without-openjpeg"
+ fi
econf \
--enable-install-system-perl \
- --with-perl-options=INSTALLDIRS=vendor \
+ --with-perl-options="INSTALLDIRS=vendor" \
$(use_enable fortran) \
- $(use_enable jpeg2k jpeg) \
$(use_enable openmp omp-packing) \
$(use_enable python) \
$(use_enable python numpy) \
$(use_enable static-libs static) \
- $(use_with netcdf netcdf "${EPRFIX}"/usr) \
+ $(use_with netcdf netcdf "${EPREFIX}"/usr) \
$(use_with perl) \
- $(use_with png png-support)
-
+ $(use_with png png-support) \
+ ${myconf}
}
src_install() {