summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-21 14:00:06 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-21 14:00:06 +0000
commit071313e5ef9520a14edf639f381f319392c2f2cc (patch)
tree41d313d0c98c93eba2cdd38117dd926903069624 /sci-libs/gerris
parentx86 stable wrt bug #319265 (diff)
downloadgentoo-2-071313e5ef9520a14edf639f381f319392c2f2cc.tar.gz
gentoo-2-071313e5ef9520a14edf639f381f319392c2f2cc.tar.bz2
gentoo-2-071313e5ef9520a14edf639f381f319392c2f2cc.zip
Version Bump, remove python which is only needed for the restricted test
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gerris')
-rw-r--r--sci-libs/gerris/ChangeLog8
-rw-r--r--sci-libs/gerris/files/gerris-20100519-autotools.patch47
-rw-r--r--sci-libs/gerris/gerris-20100114.ebuild3
-rw-r--r--sci-libs/gerris/gerris-20100519.ebuild50
4 files changed, 105 insertions, 3 deletions
diff --git a/sci-libs/gerris/ChangeLog b/sci-libs/gerris/ChangeLog
index 8912addee3f3..bb9caa45cf90 100644
--- a/sci-libs/gerris/ChangeLog
+++ b/sci-libs/gerris/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/gerris
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/ChangeLog,v 1.9 2010/01/15 18:19:13 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/ChangeLog,v 1.10 2010/05/21 14:00:06 jlec Exp $
+
+*gerris-20100519 (21 May 2010)
+
+ 21 May 2010; Justin Lecher <jlec@gentoo.org> gerris-20100114.ebuild,
+ +gerris-20100519.ebuild, +files/gerris-20100519-autotools.patch:
+ Version Bump, remove python which is only needed for the restricted test
*gerris-20100114 (15 Jan 2010)
diff --git a/sci-libs/gerris/files/gerris-20100519-autotools.patch b/sci-libs/gerris/files/gerris-20100519-autotools.patch
new file mode 100644
index 000000000000..2bab3f3a2d07
--- /dev/null
+++ b/sci-libs/gerris/files/gerris-20100519-autotools.patch
@@ -0,0 +1,47 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 8b07f68..678ebbd 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -2,9 +2,7 @@
+
+ AUTOMAKE_OPTIONS = 1.6
+
+-AM_CPPFLAGS = -DGFS_MODULES_DIR=\"$(libdir)/gerris\"
+-
+-INCLUDES = -I$(top_srcdir) -I$(includedir) \
++AM_CPPFLAGS = -DGFS_MODULES_DIR=\"$(libdir)/gerris\" \
+ -DG_LOG_DOMAIN=\"Gfs\" $(GTS_CFLAGS)
+
+ bin_SCRIPTS = gfs-config
+@@ -114,12 +112,14 @@ libgfs3D_la_LDFLAGS = $(NO_UNDEFINED)\
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)\
+ -release $(LT_RELEASE) -export-dynamic
+ libgfs3D_la_SOURCES = $(SRC)
++libgfs3D_la_LIBADD = $(GTS_LIBS)
+
+ libgfs2D_la_LDFLAGS = $(NO_UNDEFINED)\
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)\
+ -release $(LT_RELEASE) -export-dynamic
+ libgfs2D_la_SOURCES = $(SRC)
+-libgfs2D_la_CFLAGS = $(AM_CFLAGS) -DFTT_2D=1
++libgfs2D_la_CPPFLAGS = $(AM_CPPFLAGS) -DFTT_2D=1
++libgfs2D_la_LIBADD = $(GTS_LIBS)
+
+ CLEANFILES = $(BUILT_SOURCES)
+
+@@ -131,12 +131,12 @@ EXTRA_DIST = \
+ bin_PROGRAMS = gerris2D gerris3D
+
+ gerris2D_SOURCES = gerris.c
+-gerris2D_CFLAGS = $(AM_CFLAGS) -DFTT_2D=1
+-gerris2D_LDADD = $(GFS2D_LIBS)
++gerris2D_CPPFLAGS = $(AM_CPPFLAGS) -DFTT_2D=1
++gerris2D_LDADD = libgfs2D.la
+ gerris2D_DEPENDENCIES = libgfs2D.la
+
+ gerris3D_SOURCES = gerris.c
+-gerris3D_LDADD = $(GFS3D_LIBS)
++gerris3D_LDADD = libgfs3D.la
+ gerris3D_DEPENDENCIES = libgfs3D.la
+
+ if DARCS_CONTROLLED
diff --git a/sci-libs/gerris/gerris-20100114.ebuild b/sci-libs/gerris/gerris-20100114.ebuild
index 0a15b6ab93ed..fd7013cc89f7 100644
--- a/sci-libs/gerris/gerris-20100114.ebuild
+++ b/sci-libs/gerris/gerris-20100114.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/gerris-20100114.ebuild,v 1.1 2010/01/15 18:19:13 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/gerris-20100114.ebuild,v 1.2 2010/05/21 14:00:06 jlec Exp $
EAPI=2
inherit autotools eutils
@@ -19,7 +19,6 @@ RDEPEND=">=dev-libs/glib-2.4.0
sci-libs/gsl
sci-libs/gts
sci-libs/proj
- dev-lang/python
mpi? ( virtual/mpi )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
diff --git a/sci-libs/gerris/gerris-20100519.ebuild b/sci-libs/gerris/gerris-20100519.ebuild
new file mode 100644
index 000000000000..c8d8001bc29f
--- /dev/null
+++ b/sci-libs/gerris/gerris-20100519.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/gerris-20100519.ebuild,v 1.1 2010/05/21 14:00:06 jlec Exp $
+
+EAPI=2
+
+inherit autotools eutils
+
+DESCRIPTION="The Gerris Flow Solver"
+LICENSE="GPL-2"
+HOMEPAGE="http://gfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gfs/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples mpi"
+
+RDEPEND=">=dev-libs/glib-2.4.0
+ sci-libs/netcdf
+ sci-libs/gsl
+ sci-libs/gts
+ sci-libs/proj
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# test assume it is installed
+RESTRICT="test"
+
+S="${WORKDIR}"/${PN}-snapshot-100519
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable mpi)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake nstall failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ rm -f doc/examples/*.pyc || die "Failed to remove python object"
+ doins -r doc/examples/* || die
+ fi
+}