summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-07-16 17:45:46 +0000
committerJustin Lecher <jlec@gentoo.org>2011-07-16 17:45:46 +0000
commitcc86fe65f123849b29cdc80beb1bb3a68ef4e53c (patch)
tree7dcc38c9044691e04a15efc1bc609c7bf56b773f /sci-libs/gdal
parentalpha/arm/ia64/sparc/x86 stable wrt #375137 (diff)
downloadgentoo-2-cc86fe65f123849b29cdc80beb1bb3a68ef4e53c.tar.gz
gentoo-2-cc86fe65f123849b29cdc80beb1bb3a68ef4e53c.tar.bz2
gentoo-2-cc86fe65f123849b29cdc80beb1bb3a68ef4e53c.zip
Rearrange the ebuild, no external changes
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/ChangeLog6
-rw-r--r--sci-libs/gdal/gdal-1.6.3-r1.ebuild138
-rw-r--r--sci-libs/gdal/gdal-1.8.0-r1.ebuild8
-rw-r--r--sci-libs/gdal/metadata.xml32
4 files changed, 96 insertions, 88 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index 34b59b80ab59..7469f1ef4985 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.113 2011/07/08 10:19:55 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.114 2011/07/16 17:45:46 jlec Exp $
+
+ 16 Jul 2011; Justin Lecher <jlec@gentoo.org> gdal-1.6.3-r1.ebuild,
+ gdal-1.8.0-r1.ebuild, metadata.xml:
+ Rearrange the ebuild, no external changes
08 Jul 2011; Samuli Suominen <ssuominen@gentoo.org> gdal-1.6.3-r1.ebuild:
Convert from "useq" to "use".
diff --git a/sci-libs/gdal/gdal-1.6.3-r1.ebuild b/sci-libs/gdal/gdal-1.6.3-r1.ebuild
index ab3c20f20320..4d494b3ead42 100644
--- a/sci-libs/gdal/gdal-1.6.3-r1.ebuild
+++ b/sci-libs/gdal/gdal-1.6.3-r1.ebuild
@@ -1,16 +1,19 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.3-r1.ebuild,v 1.19 2011/07/08 10:19:55 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.3-r1.ebuild,v 1.20 2011/07/16 17:45:46 jlec Exp $
+
+EAPI=3
-EAPI="3"
WANT_AUTOCONF="2.5"
+
RUBY_OPTIONAL="yes"
USE_RUBY="ruby18"
-PYTHON_DEPEND="2"
+
+PYTHON_DEPEND="python? 2"
inherit autotools eutils perl-module python ruby toolchain-funcs
-DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
+DESCRIPTION="Translator library for raster geospatial data formats (includes OGR support)"
HOMEPAGE="http://www.gdal.org/"
SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
@@ -20,20 +23,19 @@ KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
# need to get these arches updated on several libs first
#KEYWORDS="~alpha ~hppa"
-IUSE="curl debug doc ecwj2k fits geos gif gml hdf hdf5 jpeg jpeg2k mysql \
-netcdf odbc png ogdi perl postgres python ruby sqlite threads"
+IUSE="curl debug doc ecwj2k fits geos gif gml hdf hdf5 jpeg jpeg2k mysql netcdf odbc png ogdi perl postgres python ruby sqlite threads"
-RDEPEND=">=sys-libs/zlib-1.1.4
- >=media-libs/tiff-3.9.1
- sci-libs/libgeotiff
+RDEPEND="
dev-libs/expat
+ media-libs/tiff
+ sci-libs/libgeotiff
+ sys-libs/zlib
curl? ( net-misc/curl )
jpeg? ( virtual/jpeg )
gif? ( media-libs/giflib )
png? ( media-libs/libpng )
perl? ( dev-lang/perl )
- python? ( dev-lang/python
- dev-python/numpy )
+ python? ( dev-python/numpy )
ruby? ( >=dev-lang/ruby-1.8.4.20060226 )
fits? ( sci-libs/cfitsio )
ogdi? ( sci-libs/ogdi )
@@ -41,16 +43,16 @@ RDEPEND=">=sys-libs/zlib-1.1.4
hdf5? ( >=sci-libs/hdf5-1.6.4 )
postgres? ( dev-db/postgresql-base )
|| (
- netcdf? ( sci-libs/netcdf )
- hdf? ( sci-libs/hdf )
+ netcdf? ( sci-libs/netcdf )
+ hdf? ( sci-libs/hdf )
)
|| (
- jpeg2k? ( media-libs/jasper )
- ecwj2k? ( sci-libs/libecwj2 )
+ jpeg2k? ( media-libs/jasper )
+ ecwj2k? ( sci-libs/libecwj2 )
)
mysql? ( virtual/mysql )
- odbc? ( dev-db/unixODBC )
- geos? ( >=sci-libs/geos-2.2.1 )
+ odbc? ( dev-db/unixODBC )
+ geos? ( >=sci-libs/geos-2.2.1 )
sqlite? ( >=dev-db/sqlite-3 )"
DEPEND="${RDEPEND}
@@ -63,10 +65,10 @@ AT_M4DIR="${S}/m4"
pkg_setup() {
if [ -n "${GDAL_CONFIGURE_OPTS}" ]; then
- elog "User-specified configure options are ${GDAL_CONFIGURE_OPTS}."
+ elog "User-specified configure options are ${GDAL_CONFIGURE_OPTS}."
else
- elog "User-specified configure options are not set."
- elog "If needed, set GDAL_CONFIGURE_OPTS to enable grass support."
+ elog "User-specified configure options are not set."
+ elog "If needed, set GDAL_CONFIGURE_OPTS to enable grass support."
fi
python_set_active_version 2
}
@@ -75,10 +77,11 @@ src_prepare() {
eaclocal
eautoconf
- epatch "${FILESDIR}"/${PN}-1.4.2-datadir.patch \
- "${FILESDIR}"/${PN}-1.5.1-python-install.patch \
- "${FILESDIR}"/${PN}-1.6.0-swig-fix.patch \
- "${FILESDIR}"/${PN}-1.6.1-ruby-make.patch
+ epatch \
+ "${FILESDIR}"/${PN}-1.4.2-datadir.patch \
+ "${FILESDIR}"/${PN}-1.5.1-python-install.patch \
+ "${FILESDIR}"/${PN}-1.6.0-swig-fix.patch \
+ "${FILESDIR}"/${PN}-1.6.1-ruby-make.patch
[[ ${CHOST} == *-darwin* ]] \
&& epatch "${FILESDIR}"/${PN}-1.5.0-install_name.patch \
@@ -86,7 +89,6 @@ src_prepare() {
}
src_configure() {
-
local pkg_conf="${GDAL_CONFIGURE_OPTS}"
local use_conf=""
@@ -105,43 +107,44 @@ src_configure() {
fi
use_conf="$(use_with jpeg) $(use_with png) $(use_with mysql) \
- $(use_with gml xerces) $(use_with hdf5) $(use_with curl) \
- $(use_with postgres pg) $(use_with python) $(use_with ruby) \
- $(use_with threads) $(use_with fits cfitsio) $(use_with perl) \
- $(use_with sqlite sqlite3 ="${EPREFIX}"/usr) $(use_with geos) \
- $(use_with jpeg2k jasper) $(use_with odbc) $(use_enable debug)"
+ $(use_with gml xerces) $(use_with hdf5) $(use_with curl) \
+ $(use_with postgres pg) $(use_with python) $(use_with ruby) \
+ $(use_with threads) $(use_with fits cfitsio) $(use_with perl) \
+ $(use_with sqlite sqlite3 ="${EPREFIX}"/usr) $(use_with geos) \
+ $(use_with jpeg2k jasper) $(use_with odbc) $(use_enable debug)"
# It can't find this
if use ogdi ; then
- use_conf="--with-ogdi=${EPREFIX}/usr ${use_conf}"
+ use_conf="--with-ogdi=${EPREFIX}/usr ${use_conf}"
fi
if use mysql ; then
- use_conf="--with-mysql=${EPREFIX}/usr/bin/mysql_config ${use_conf}"
+ use_conf="--with-mysql=${EPREFIX}/usr/bin/mysql_config ${use_conf}"
fi
if use gif ; then
- use_conf="--with-gif=internal ${use_conf}"
+ use_conf="--with-gif=internal ${use_conf}"
else
- use_conf="--with-gif=no ${use_conf}"
+ use_conf="--with-gif=no ${use_conf}"
fi
if use python ; then
- use_conf="--with-pymoddir=${EPREFIX}/$(python_get_sitedir) \
+ use_conf="--with-pymoddir=${EPREFIX}/$(python_get_sitedir) \
${use_conf}"
fi
# Fix doc path just in case
- sed -i -e "s:@exec_prefix@/doc:@exec_prefix@/share/doc/${PF}/html:g" \
- GDALmake.opt.in || die "sed gdalmake.opt failed"
+ sed \
+ -e "s:@exec_prefix@/doc:@exec_prefix@/share/doc/${PF}/html:g" \
+ -i GDALmake.opt.in || die "sed gdalmake.opt failed"
econf ${pkg_conf} ${use_conf} || die "econf failed"
# mysql-config puts this in (and boy is it a PITA to get it out)
sed \
- -i -r -e '/^LDFLAGS/ s/(-(Wl|O1),|,-(Wl|O1))//g' \
- -i -e '/^MYSQL_LIB/ s:-Wl,-O1 -rdynamic::' \
- GDALmake.opt || die "sed LIBS failed"
+ -i -r -e '/^LDFLAGS/ s/(-(Wl|O1),|,-(Wl|O1))//g' \
+ -i -e '/^MYSQL_LIB/ s:-Wl,-O1 -rdynamic::' \
+ GDALmake.opt || die "sed LIBS failed"
}
src_compile() {
@@ -159,75 +162,74 @@ src_compile() {
emake -j1 || die "emake failed"
if use python; then
- sed -i -e "s#library_dirs = #library_dirs = ${EPREFIX}/usr/$(get_libdir):#g" \
+ sed -i -e "s#library_dirs = #library_dirs = ${EPREFIX}/usr/$(get_libdir):#g" \
swig/python/setup.cfg || die "sed python setup.cfg failed"
- sed -i -e "s:\$(DESTDIR)\$(prefix):\$(DESTDIR)\$(INST_PREFIX):g" \
+ sed -i -e "s:\$(DESTDIR)\$(prefix):\$(DESTDIR)\$(INST_PREFIX):g" \
swig/python/GNUmakefile || die "sed python makefile failed"
fi
if use perl ; then
- cd "${S}"/swig/perl
- perl-module_src_prep
- perl-module_src_compile
- cd "${S}"
+ cd "${S}"/swig/perl
+ perl-module_src_prep
+ perl-module_src_compile
+ cd "${S}"
fi
if use doc ; then
- make docs || die "make docs failed"
+ make docs || die "make docs failed"
fi
}
src_install() {
-
if use perl ; then
- cd "${S}"/swig/perl
- perl-module_src_install
- sed -i -e "s:BINDINGS = python ruby perl:BINDINGS = python ruby:g" \
+ cd "${S}"/swig/perl
+ perl-module_src_install
+ sed -i -e "s:BINDINGS = python ruby perl:BINDINGS = python ruby:g" \
GDALmake.opt
- cd "${S}"
+ cd "${S}"
fi
# einstall causes sandbox violations on /usr/lib/libgdal.so
emake DESTDIR="${D}" install \
- || die "make install failed"
+ || die "make install failed"
dodoc Doxyfile HOWTO-RELEASE NEWS
if use doc ; then
- dohtml html/* || die "install html failed"
- docinto ogr
- dohtml ogr/html/* || die "install ogr html failed"
+ dohtml html/* || die "install html failed"
+ docinto ogr
+ dohtml ogr/html/* || die "install ogr html failed"
fi
if use python; then
- newdoc swig/python/README.txt README-python.txt
- dodir /usr/share/${PN}/samples
- insinto /usr/share/${PN}/samples
- doins swig/python/samples/*
+ newdoc swig/python/README.txt README-python.txt
+ dodir /usr/share/${PN}/samples
+ insinto /usr/share/${PN}/samples
+ doins swig/python/samples/*
fi
use perl && fixlocalpod
}
pkg_postinst() {
- elog
+ echo
elog "If you need libgrass support, then you must rebuild gdal, after"
elog "installing the latest Grass, and set the following option:"
- elog
+ echo
elog "GDAL_CONFIGURE_OPTS=--with-grass=\$GRASS_HOME emerge gdal"
- elog
+ echo
elog "GDAL is most useful with full graphics support enabled via various"
elog "USE flags: png, jpeg, gif, jpeg2k, etc. Also python, fits, ogdi,"
elog "geos, and support for either netcdf or HDF4 is available, as well as"
elog "grass, and mysql, sqlite, or postgres (grass support requires grass 6"
- elog "and rebuilding gdal). HDF5 support is now included."
- elog
+ elog "and rebuilding gdal). HDF5 support is now included."
+ echo
elog "Note: tiff and geotiff are now hard depends, so no USE flags."
elog "Also, this package will check for netcdf before hdf, so if you"
elog "prefer hdf, please emerge hdf with USE=szip prior to emerging"
- elog "gdal. Detailed API docs require doxygen (man pages are free)."
- elog
+ elog "gdal. Detailed API docs require doxygen (man pages are free)."
+ echo
elog "Check available image and data formats after building with"
elog "gdalinfo and ogrinfo (using the --formats switch)."
- elog
+ echo
}
diff --git a/sci-libs/gdal/gdal-1.8.0-r1.ebuild b/sci-libs/gdal/gdal-1.8.0-r1.ebuild
index 0b2f8779f89d..6a08dd8157b3 100644
--- a/sci-libs/gdal/gdal-1.8.0-r1.ebuild
+++ b/sci-libs/gdal/gdal-1.8.0-r1.ebuild
@@ -1,17 +1,19 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.8.0-r1.ebuild,v 1.4 2011/07/05 01:00:30 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.8.0-r1.ebuild,v 1.5 2011/07/16 17:45:45 jlec Exp $
-EAPI="2"
+EAPI=2
WANT_AUTOCONF="2.5"
+
RUBY_OPTIONAL="yes"
USE_RUBY="ruby18"
+
PYTHON_DEPEND="python? 2:2.6"
inherit autotools eutils libtool perl-module python ruby-ng toolchain-funcs
-DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
+DESCRIPTION="Translator library for raster geospatial data formats (includes OGR support)"
HOMEPAGE="http://www.gdal.org/"
SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
diff --git a/sci-libs/gdal/metadata.xml b/sci-libs/gdal/metadata.xml
index 1216ac0a05c0..b89ac1d58457 100644
--- a/sci-libs/gdal/metadata.xml
+++ b/sci-libs/gdal/metadata.xml
@@ -1,26 +1,26 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-geosciences</herd>
-<maintainer>
- <email>nerdboy@gentoo.org</email>
- <name>Steve Arnold</name>
- <description>Primary Maintainer</description>
-</maintainer>
-<longdescription>GDAL is the Geospatial Data Abstraction Library, a set of tools for
+ <herd>sci-geosciences</herd>
+ <maintainer>
+ <email>nerdboy@gentoo.org</email>
+ <name>Steve Arnold</name>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <longdescription>GDAL is the Geospatial Data Abstraction Library, a set of tools for
converting between geospatial raster data formats (includes OGR for vector data).</longdescription>
-<use>
- <flag name='aux_xml'>Enable Portable Auxilliary Metadata generation</flag>
- <flag name='ecwj2k'>Enable support for alternate jpeg2k library
+ <use>
+ <flag name="aux_xml">Enable Portable Auxilliary Metadata generation</flag>
+ <flag name="ecwj2k">Enable support for alternate jpeg2k library
<pkg>sci-libs/libecwj2</pkg></flag>
- <flag name='fits'>Enable support for NASA's <pkg>sci-libs/cfitsio</pkg>
+ <flag name="fits">Enable support for NASA's <pkg>sci-libs/cfitsio</pkg>
library</flag>
- <flag name='geos'>Add support for geometry engine (<pkg>sci-libs/geos</pkg>
+ <flag name="geos">Add support for geometry engine (<pkg>sci-libs/geos</pkg>
</flag>
- <flag name='gml'>Enable support for <pkg>dev-libs/xerces-c</pkg> C++ API</flag>
- <flag name='hdf'>Add support for the Hierarchical Data Format v. 4
+ <flag name="gml">Enable support for <pkg>dev-libs/xerces-c</pkg> C++ API</flag>
+ <flag name="hdf">Add support for the Hierarchical Data Format v. 4
(<pkg>sci-libs/hdf</pkg>)</flag>
- <flag name='ogdi'>Enable support for the open geographic datastore interface
+ <flag name="ogdi">Enable support for the open geographic datastore interface
(<pkg>sci-libs/ogdi</pkg>)</flag>
-</use>
+ </use>
</pkgmetadata>