summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-01 14:30:16 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-01 14:30:16 +0000
commit8193315393d38b3e1474905b764b8d9102f82b6f (patch)
treedde545fd3f6da344adc6bf7df34d9b0bbf90f239 /sci-libs/gamer/gamer-1.4.ebuild
parentVersion bump (diff)
downloadgentoo-2-8193315393d38b3e1474905b764b8d9102f82b6f.tar.gz
gentoo-2-8193315393d38b3e1474905b764b8d9102f82b6f.tar.bz2
gentoo-2-8193315393d38b3e1474905b764b8d9102f82b6f.zip
New addition
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gamer/gamer-1.4.ebuild')
-rw-r--r--sci-libs/gamer/gamer-1.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-libs/gamer/gamer-1.4.ebuild b/sci-libs/gamer/gamer-1.4.ebuild
new file mode 100644
index 000000000000..ea3b6f633c5f
--- /dev/null
+++ b/sci-libs/gamer/gamer-1.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gamer/gamer-1.4.ebuild,v 1.1 2010/11/01 14:30:16 jlec Exp $
+
+EAPI="3"
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Geometry-preserving Adaptive MeshER"
+HOMEPAGE="http://fetk.org/codes/gamer/index.html"
+SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="dev-libs/maloc"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-multilib.patch
+ eautoreconf
+}
+
+src_configure() {
+ local fetk_include
+ local fetk_lib
+
+ fetk_include="${EPREFIX}"/usr/include
+ fetk_lib="${EPREFIX}"/usr/$(get_libdir)
+ export FETK_INCLUDE="${fetk_include}"
+ export FETK_LIBRARY="${fetk_lib}"
+
+ econf \
+ --disable-triplet \
+ --enable-shared
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}