summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-02-03 17:57:56 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-02-03 17:57:56 +0000
commitd68f8cbed18eb2cc0443232a3182525f21fa7a1f (patch)
treeb4a6ab21975ff6adada2a7d1bd1ed7382db0630f /sci-libs/cholmod
parentVersion bump and fixed bug #499694 (diff)
downloadgentoo-2-d68f8cbed18eb2cc0443232a3182525f21fa7a1f.tar.gz
gentoo-2-d68f8cbed18eb2cc0443232a3182525f21fa7a1f.tar.bz2
gentoo-2-d68f8cbed18eb2cc0443232a3182525f21fa7a1f.zip
Removed old
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/cholmod')
-rw-r--r--sci-libs/cholmod/ChangeLog8
-rw-r--r--sci-libs/cholmod/cholmod-1.7.4.ebuild105
-rw-r--r--sci-libs/cholmod/cholmod-2.0.1.ebuild62
-rw-r--r--sci-libs/cholmod/files/cholmod-1.7.4-debug.patch17
4 files changed, 6 insertions, 186 deletions
diff --git a/sci-libs/cholmod/ChangeLog b/sci-libs/cholmod/ChangeLog
index 7ecbd51f032d..c5f3fd2b58a5 100644
--- a/sci-libs/cholmod/ChangeLog
+++ b/sci-libs/cholmod/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/cholmod
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/ChangeLog,v 1.40 2013/07/18 13:39:01 chithanh Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/ChangeLog,v 1.41 2014/02/03 17:57:56 bicatali Exp $
+
+ 03 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org> -cholmod-1.7.4.ebuild,
+ -cholmod-2.0.1.ebuild, -files/cholmod-1.7.4-debug.patch:
+ Removed old
18 Jul 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
cholmod-2.1.2.ebuild:
diff --git a/sci-libs/cholmod/cholmod-1.7.4.ebuild b/sci-libs/cholmod/cholmod-1.7.4.ebuild
deleted file mode 100644
index a88d996c5dce..000000000000
--- a/sci-libs/cholmod/cholmod-1.7.4.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/cholmod-1.7.4.ebuild,v 1.8 2013/02/21 21:56:07 jlec Exp $
-
-EAPI=4
-
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils eutils toolchain-funcs
-
-MY_PN=CHOLMOD
-PPV=1.7.0
-
-DESCRIPTION="Sparse Cholesky factorization and update/downdate library"
-HOMEPAGE="http://www.cise.ufl.edu/research/sparse/cholmod/"
-SRC_URI="
- http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz
- mirror://gentoo/${PN}-${PPV}-autotools.patch.bz2"
-
-LICENSE="LGPL-2.1 GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="debug doc metis minimal static-libs +supernodal"
-
-RDEPEND="
- sci-libs/amd
- sci-libs/colamd
- metis? (
- sci-libs/camd
- sci-libs/ccolamd
- || ( sci-libs/metis sci-libs/parmetis ) )
- supernodal? ( virtual/lapack )"
-
-DEPEND="${RDEPEND}
- supernodal? ( virtual/pkgconfig )
- metis? ( virtual/pkgconfig )"
-
-DOCS=( README.txt Doc/ChangeLog )
-
-S="${WORKDIR}/${MY_PN}"
-
-src_prepare() {
- cd "${WORKDIR}"
- epatch "${WORKDIR}"/${PN}-${PPV}-autotools.patch
- cd "${S}"
- use debug && epatch "${FILESDIR}"/${P}-debug.patch
- # bug #399483 does not build with parmetis-3.2
- has_version "=sci-libs/parmetis-3.2*" && \
- epatch "${FILESDIR}"/${P}-parmetis32.patch
-
- # We need to take care of cholmod.h here as well depending on
- # the USE flags, otherwise the installed file will reference
- # headers that we may not have included.
- if use minimal; then
- sed -i '/^#define CHOLMOD_/{N;
- s:\(#define\) \(CHOLMOD_CONFIG_H\)\n:\1 \2\n\1 NMODIFY 1\n\1 NMATRIXOPS 1\n:}' \
- Include/cholmod_config.h
- fi
-
- if ! use supernodal; then
- sed -i '/^#define CHOLMOD_/{N;
- s:\(#define\) \(CHOLMOD_CONFIG_H\)\n:\1 \2\n\1 NSUPERNODAL 1\n:}' \
- Include/cholmod_config.h
- fi
-
- if ! use metis; then
- sed -i '/^#define CHOLMOD_/{N;
- s:\(#define\) \(CHOLMOD_CONFIG_H\)\n:\1 \2\n\1 NPARTITION 1\n:}' \
- Include/cholmod_config.h
- fi
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local lapack_libs=no
- local blas_libs=no
- if use supernodal; then
- blas_libs=$($(tc-getPKG_CONFIG) --libs blas)
- lapack_libs=$($(tc-getPKG_CONFIG) --libs lapack)
- fi
- local myeconfargs+=(
- --with-blas="${blas_libs}"
- --with-lapack="${lapack_libs}"
- $(use_enable supernodal mod-supernodal)
- $(use_enable !minimal mod-modify)
- $(use_enable !minimal mod-matrixops)
- $(use_enable metis mod-partition)
- )
- autotools-utils_src_configure
-}
-
-src_test() {
- if ! use supernodal || ! use metis || use minimal; then
- ewarn "According to your useflags, some modules were not built on"
- ewarn "purpose. This can cause the tests included with Cholmod"
- ewarn "to fail. Rebuild with USE=\"supernodal metis -minimal\""
- ewarn "if you care."
- fi
- autotools-utils_src_test -C Demo test
-}
-
-src_install() {
- autotools-utils_src_install
- use doc && dodoc Doc/UserGuide.pdf
-}
diff --git a/sci-libs/cholmod/cholmod-2.0.1.ebuild b/sci-libs/cholmod/cholmod-2.0.1.ebuild
deleted file mode 100644
index f1ff6dd7389f..000000000000
--- a/sci-libs/cholmod/cholmod-2.0.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/cholmod-2.0.1.ebuild,v 1.5 2013/04/10 06:06:12 jlec Exp $
-
-EAPI=4
-
-inherit autotools-utils multilib toolchain-funcs
-
-DESCRIPTION="Sparse Cholesky factorization and update/downdate library"
-HOMEPAGE="http://www.cise.ufl.edu/research/sparse/cholmod/"
-SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.gz"
-
-LICENSE="minimal? ( LGPL-2.1 ) !minimal? ( GPL-2 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-fbsd ~x86-linux ~x86-macos"
-IUSE="cuda doc lapack metis minimal static-libs"
-
-RDEPEND="
- >=sci-libs/amd-2.3
- >=sci-libs/colamd-2.8
- cuda? ( x11-drivers/nvidia-drivers dev-util/nvidia-cuda-toolkit )
- lapack? ( virtual/lapack )
- metis? (
- >=sci-libs/camd-2.3
- >=sci-libs/ccolamd-2.8
- || ( sci-libs/metis sci-libs/parmetis ) )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( virtual/latex-base )"
-
-src_prepare() {
- # bug #399483 does not build with parmetis-3.2
- has_version "=sci-libs/parmetis-3.2*" && \
- epatch "${FILESDIR}"/${PN}-1.7.4-parmetis32.patch
-}
-
-src_configure() {
- local lapack_libs=no
- local blas_libs=no
- if use lapack; then
- blas_libs=$($(tc-getPKG_CONFIG) --libs blas)
- lapack_libs=$($(tc-getPKG_CONFIG) --libs lapack)
- fi
- local myeconfargs=(
- --with-blas="${blas_libs}"
- --with-lapack="${lapack_libs}"
- $(use_with doc)
- $(use_with !minimal modify)
- $(use_with !minimal matrixops)
- $(use_with metis partition)
- $(use_with lapack supernodal)
- )
- if use cuda; then
- myeconfargs+=(
- --with-cuda
- --with-cublas-libs="-L${EPREFIX}/opt/cuda/$(get_libdir) -lcublas"
- --with-cublas-cflags="-I${EPREFIX}/opt/cuda/include"
- )
- fi
- autotools-utils_src_configure
-}
diff --git a/sci-libs/cholmod/files/cholmod-1.7.4-debug.patch b/sci-libs/cholmod/files/cholmod-1.7.4-debug.patch
deleted file mode 100644
index bf434e24f267..000000000000
--- a/sci-libs/cholmod/files/cholmod-1.7.4-debug.patch
+++ /dev/null
@@ -1,17 +0,0 @@
- Include/cholmod_internal.h | 2 --
- 1 files changed, 0 insertions(+), 2 deletions(-)
-
-diff --git a/Include/cholmod_internal.h b/Include/cholmod_internal.h
-index 36f20a2..2cd6dd2 100644
---- a/Include/cholmod_internal.h
-+++ b/Include/cholmod_internal.h
-@@ -53,9 +53,7 @@
- #define NDEBUG
- #endif
-
--/* Uncomment this line to enable debugging. CHOLMOD will be very slow.
- #undef NDEBUG
-- */
-
- #ifdef MATLAB_MEX_FILE
- #include "mex.h"