summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-19 10:36:38 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-19 10:36:38 +0000
commita99724c0474d96040602c55627470b91689e342c (patch)
treedfe5a893c0052f3508bae806e1f38c055459e1c6 /sci-libs/cctbx
parentfix bug 248162, thanks to Michael Weber (xmw@gentoo.org) for providing a patch (diff)
downloadgentoo-2-a99724c0474d96040602c55627470b91689e342c.tar.gz
gentoo-2-a99724c0474d96040602c55627470b91689e342c.tar.bz2
gentoo-2-a99724c0474d96040602c55627470b91689e342c.zip
sci-libs/cctbx: Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the updated fortran-2.eclass
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-libs/cctbx')
-rw-r--r--sci-libs/cctbx/ChangeLog6
-rw-r--r--sci-libs/cctbx/cctbx-2010.03.29.2334-r6.ebuild6
2 files changed, 9 insertions, 3 deletions
diff --git a/sci-libs/cctbx/ChangeLog b/sci-libs/cctbx/ChangeLog
index 3c0237c57c6d..fcf59b86e86f 100644
--- a/sci-libs/cctbx/ChangeLog
+++ b/sci-libs/cctbx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/cctbx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/ChangeLog,v 1.29 2012/10/18 21:38:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/ChangeLog,v 1.30 2012/10/19 10:36:38 jlec Exp $
+
+ 19 Oct 2012; Justin Lecher <jlec@gentoo.org> cctbx-2010.03.29.2334-r6.ebuild:
+ Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the
+ updated fortran-2.eclass
18 Oct 2012; Justin Lecher <jlec@gentoo.org> cctbx-2010.03.29.2334-r6.ebuild:
Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the
diff --git a/sci-libs/cctbx/cctbx-2010.03.29.2334-r6.ebuild b/sci-libs/cctbx/cctbx-2010.03.29.2334-r6.ebuild
index 2407fb1837d9..a1e26ea54b96 100644
--- a/sci-libs/cctbx/cctbx-2010.03.29.2334-r6.ebuild
+++ b/sci-libs/cctbx/cctbx-2010.03.29.2334-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/cctbx-2010.03.29.2334-r6.ebuild,v 1.7 2012/10/18 21:38:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/cctbx-2010.03.29.2334-r6.ebuild,v 1.8 2012/10/19 10:36:38 jlec Exp $
EAPI="3"
@@ -35,13 +35,15 @@ MY_B="${WORKDIR}"/cctbx_build
pkg_setup() {
use openmp && FORTRAN_NEED_OPENMP="1"
- fortran-2_pkg_setup
if use openmp && ! tc-has-openmp; then
ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 and icc"
ewarn "If you want to build ${PN} with OpenMP, abort now,"
ewarn "and switch CC to an OpenMP capable compiler"
+ FORTRAN_NEED_OPENMP=1
fi
+ fortran-2_pkg_setup
python_set_active_version 2
+ python_pkg_setup
}
src_prepare() {