summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-07-20 21:51:23 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-07-20 21:51:23 +0000
commit7dcdc0587c1b46fde378eeb1e6c70fe2b593a86b (patch)
tree442dda4ff11565bd66d5d00aa8d1fc8d0c4f3191 /sci-libs/armadillo
parentPAX marking for plugin loader, see bug 419513 (diff)
downloadgentoo-2-7dcdc0587c1b46fde378eeb1e6c70fe2b593a86b.tar.gz
gentoo-2-7dcdc0587c1b46fde378eeb1e6c70fe2b593a86b.tar.bz2
gentoo-2-7dcdc0587c1b46fde378eeb1e6c70fe2b593a86b.zip
Version bump. Added examples flag, keyworded amd64-linux, x86-linux
(Portage version: 2.2.01.20757-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/armadillo')
-rw-r--r--sci-libs/armadillo/ChangeLog7
-rw-r--r--sci-libs/armadillo/armadillo-3.2.4.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/sci-libs/armadillo/ChangeLog b/sci-libs/armadillo/ChangeLog
index 9178aaecc5ac..2511cf5faae4 100644
--- a/sci-libs/armadillo/ChangeLog
+++ b/sci-libs/armadillo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/armadillo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.15 2012/06/07 18:44:46 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.16 2012/07/20 21:51:23 bicatali Exp $
+
+*armadillo-3.2.4 (20 Jul 2012)
+
+ 20 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> +armadillo-3.2.4.ebuild:
+ Version bump. Added examples flag, keyworded amd64-linux, x86-linux
*armadillo-3.2.2 (07 Jun 2012)
diff --git a/sci-libs/armadillo/armadillo-3.2.4.ebuild b/sci-libs/armadillo/armadillo-3.2.4.ebuild
new file mode 100644
index 000000000000..30c9c7337c3d
--- /dev/null
+++ b/sci-libs/armadillo/armadillo-3.2.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-3.2.4.ebuild,v 1.1 2012/07/20 21:51:23 bicatali Exp $
+
+EAPI=4
+
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake-utils
+
+DESCRIPTION="Streamlined C++ linear algebra library"
+HOMEPAGE="http://arma.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="atlas blas doc examples lapack"
+
+RDEPEND=">=dev-libs/boost-1.34
+ atlas? ( sci-libs/lapack-atlas )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )"
+
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # avoid the automagic cmake macros
+ sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=()
+ if use blas; then
+ mycmakeargs+=(
+ -DBLAS_FOUND=ON
+ -DBLAS_LIBRARIES="$(pkg-config --libs blas)"
+ )
+ fi
+ if use lapack; then
+ mycmakeargs+=(
+ -DLAPACK_FOUND=ON
+ -DLAPACK_LIBRARIES="$(pkg-config --libs lapack)"
+ )
+ fi
+ if use atlas; then
+ mycmakeargs=(
+ -DARMA_USE_ATLAS=ON
+ -DCBLAS_FOUND=ON
+ -DCLAPACK_FOUND=ON
+ -DATLAS_INCLUDE_DIR="${EPREFIX}/usr/include/atlas/"
+ -DCBLAS_LIBRARIES="$(pkg-config --libs cblas)"
+ -DCLAPACK_LIBRARIES="-L${EPREFIX}/usr/lib64/lapack/atlas -llapack"
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README.txt
+ use doc && dodoc docs/*pdf
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}