summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-29 16:31:23 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-29 16:31:23 +0000
commit624a70f9408208ce3f8f9270ff6987a9bc6e52fd (patch)
tree46d86348a860c04851e330d343e99e7f64bc7553 /sci-geosciences
parentsci-libs/ccp4-libs: Fix usage of new python r1 eclasses (missing PYTHON_REQUI... (diff)
downloadgentoo-2-624a70f9408208ce3f8f9270ff6987a9bc6e52fd.tar.gz
gentoo-2-624a70f9408208ce3f8f9270ff6987a9bc6e52fd.tar.bz2
gentoo-2-624a70f9408208ce3f8f9270ff6987a9bc6e52fd.zip
sci-geosciences/qgis: Fix usage of new python r1 eclasses (missing PYTHON_REQUIRED_USE, PYTHON_DEPS)
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/qgis/ChangeLog6
-rw-r--r--sci-geosciences/qgis/metadata.xml14
-rw-r--r--sci-geosciences/qgis/qgis-1.8.0.ebuild9
3 files changed, 19 insertions, 10 deletions
diff --git a/sci-geosciences/qgis/ChangeLog b/sci-geosciences/qgis/ChangeLog
index f5e549afe38f..e06991023338 100644
--- a/sci-geosciences/qgis/ChangeLog
+++ b/sci-geosciences/qgis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/qgis
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/ChangeLog,v 1.29 2013/03/02 23:21:57 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/ChangeLog,v 1.30 2013/05/29 16:31:23 jlec Exp $
+
+ 29 May 2013; Justin Lecher <jlec@gentoo.org> qgis-1.8.0.ebuild, metadata.xml:
+ Fix usage of new python r1 eclasses (missing PYTHON_REQUIRED_USE,
+ PYTHON_DEPS)
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> qgis-1.7.0.ebuild,
qgis-1.8.0.ebuild:
diff --git a/sci-geosciences/qgis/metadata.xml b/sci-geosciences/qgis/metadata.xml
index 68abd3f85b73..be2c23b6863f 100644
--- a/sci-geosciences/qgis/metadata.xml
+++ b/sci-geosciences/qgis/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-geosciences</herd>
- <longdescription lang="en">
+ <herd>sci-geosciences</herd>
+ <longdescription lang="en">
Quantum GIS (QGIS) is a user friendly Open Source Geographic
Information System (GIS). QGIS supports vector, raster, and database
formats. QGIS lets you browse and create map data on your
@@ -10,9 +10,9 @@
ShapeFile, geotiff). QGIS supports plugins to do things like display
tracks from your GPS.
</longdescription>
- <use>
- <flag name="bundled-libs">Use internal copy of <pkg>x11-libs/qwtpolar</pkg></flag>
- <flag name="grass">Add support for <pkg>sci-geosciences/grass</pkg></flag>
- <flag name="spatialite">Enable Spatial DBMS over sqlite <pkg>dev-db/spatialite</pkg></flag>
- </use>
+ <use>
+ <flag name="bundled-libs">Use internal copy of <pkg>x11-libs/qwtpolar</pkg></flag>
+ <flag name="grass">Add support for <pkg>sci-geosciences/grass</pkg></flag>
+ <flag name="spatialite">Enable Spatial DBMS over sqlite <pkg>dev-db/spatialite</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/sci-geosciences/qgis/qgis-1.8.0.ebuild b/sci-geosciences/qgis/qgis-1.8.0.ebuild
index a7e9dea3fac1..9986f23caa82 100644
--- a/sci-geosciences/qgis/qgis-1.8.0.ebuild
+++ b/sci-geosciences/qgis/qgis-1.8.0.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/qgis-1.8.0.ebuild,v 1.2 2013/03/02 23:21:56 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/qgis-1.8.0.ebuild,v 1.3 2013/05/29 16:31:23 jlec Exp $
EAPI=5
PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
PYTHON_REQ_USE="sqlite"
+
inherit eutils multilib gnome2-utils cmake-utils python-single-r1
DESCRIPTION="User friendly Geographic Information System"
HOMEPAGE="http://www.qgis.org/"
-SRC_URI="http://qgis.org/downloads/qgis-${PV}.tar.bz2
+SRC_URI="
+ http://qgis.org/downloads/qgis-${PV}.tar.bz2
examples? ( http://download.osgeo.org/qgis/data/qgis_sample_data.tar.gz )"
LICENSE="GPL-2"
@@ -18,7 +20,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bundled-libs examples gps grass gsl postgres python spatialite test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
RDEPEND="
+ ${PYTHON_DEPS}
dev-libs/expat
sci-geosciences/gpsbabel
>=sci-libs/gdal-1.6.1[geos,python?]