summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-11-09 19:21:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-11-09 19:21:59 +0000
commite92ff7acd43398dffa69ddd761be1feaa586ce0d (patch)
tree1a93c8cedbbe5509af106b33baa49afa8b1ccd39 /sci-geosciences/tilecache
parentFix typo. (diff)
downloadgentoo-2-e92ff7acd43398dffa69ddd761be1feaa586ce0d.tar.gz
gentoo-2-e92ff7acd43398dffa69ddd761be1feaa586ce0d.tar.bz2
gentoo-2-e92ff7acd43398dffa69ddd761be1feaa586ce0d.zip
Bug #471550: Fix PIL usage. Also migrate from dev-python/imaging to virtual/python-imaging and to distutils-r1 & EAPI5.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-geosciences/tilecache')
-rw-r--r--sci-geosciences/tilecache/ChangeLog12
-rw-r--r--sci-geosciences/tilecache/files/tilecache-2.11-pil.patch21
-rw-r--r--sci-geosciences/tilecache/tilecache-2.11-r1.ebuild33
3 files changed, 63 insertions, 3 deletions
diff --git a/sci-geosciences/tilecache/ChangeLog b/sci-geosciences/tilecache/ChangeLog
index f182464b6133..ec2cf480710d 100644
--- a/sci-geosciences/tilecache/ChangeLog
+++ b/sci-geosciences/tilecache/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-geosciences/tilecache
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/tilecache/ChangeLog,v 1.5 2011/06/01 09:53:25 scarabeus Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/tilecache/ChangeLog,v 1.6 2013/11/09 19:21:59 robbat2 Exp $
+
+*tilecache-2.11-r1 (09 Nov 2013)
+
+ 09 Nov 2013; Robin H. Johnson <robbat2@gentoo.org>
+ +files/tilecache-2.11-pil.patch, +tilecache-2.11-r1.ebuild:
+ Bug #471550: Fix PIL usage. Also migrate from dev-python/imaging to virtual
+ /python-imaging and to distutils-r1 & EAPI5.
*tilecache-2.11 (01 Jun 2011)
@@ -26,4 +33,3 @@
09 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+tilecache-2.10.ebuild, +metadata.xml:
Initial commit.
-
diff --git a/sci-geosciences/tilecache/files/tilecache-2.11-pil.patch b/sci-geosciences/tilecache/files/tilecache-2.11-pil.patch
new file mode 100644
index 000000000000..b596ae449ff7
--- /dev/null
+++ b/sci-geosciences/tilecache/files/tilecache-2.11-pil.patch
@@ -0,0 +1,21 @@
+diff -Nuar tilecache-2.11.orig/TileCache/Layer.py tilecache-2.11/TileCache/Layer.py
+--- tilecache-2.11.orig/TileCache/Layer.py 2010-10-15 04:00:18.000000000 -0700
++++ tilecache-2.11/TileCache/Layer.py 2013-11-09 11:05:17.620475332 -0800
+@@ -391,7 +391,7 @@
+ return MetaTile(self, x, y, tile.z)
+
+ def renderMetaTile (self, metatile, tile):
+- import StringIO, Image
++ import StringIO, PIL.Image as Image
+
+ data = self.renderTile(metatile)
+ image = Image.open( StringIO.StringIO(data) )
+@@ -444,7 +444,7 @@
+ return self.renderTile(tile)
+
+ def watermark (self, img):
+- import StringIO, Image, ImageEnhance
++ import StringIO, PIL.Image as Image, PIL.ImageEnhance as ImageEnhance
+ tileImage = Image.open( StringIO.StringIO(img) )
+ wmark = Image.open(self.watermarkimage)
+ assert self.watermarkopacity >= 0 and self.watermarkopacity <= 1
diff --git a/sci-geosciences/tilecache/tilecache-2.11-r1.ebuild b/sci-geosciences/tilecache/tilecache-2.11-r1.ebuild
new file mode 100644
index 000000000000..34d96eee3dc6
--- /dev/null
+++ b/sci-geosciences/tilecache/tilecache-2.11-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/tilecache/tilecache-2.11-r1.ebuild,v 1.1 2013/11/09 19:21:59 robbat2 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Web map tile caching system"
+HOMEPAGE="http://tilecache.org/"
+SRC_URI="http://${PN}.org/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/python-imaging
+ dev-python/paste"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+"
+
+PATCHES=( "${FILESDIR}/tilecache-2.11-pil.patch" )
+
+src_install() {
+ distutils-r1_src_install "--debian"
+}
+
+python_test() {
+ python setup.py test || die "Failed tests"
+}