summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-04-26 22:50:43 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-04-26 22:50:43 +0000
commit84aa9c90d56b569e90c764fd8a76689d15c18f4e (patch)
tree87b93a7c571bc8b48a75110da316883b83156a65 /sci-geosciences/qgis
parentVersion bump. Remove older. (diff)
downloadgentoo-2-84aa9c90d56b569e90c764fd8a76689d15c18f4e.tar.gz
gentoo-2-84aa9c90d56b569e90c764fd8a76689d15c18f4e.tar.bz2
gentoo-2-84aa9c90d56b569e90c764fd8a76689d15c18f4e.zip
Update to use python correctly. Drop old. Per bug #316215.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/qgis')
-rw-r--r--sci-geosciences/qgis/ChangeLog6
-rw-r--r--sci-geosciences/qgis/files/qgis-1.3.0-sip.patch103
-rw-r--r--sci-geosciences/qgis/qgis-1.3.0.ebuild90
-rw-r--r--sci-geosciences/qgis/qgis-1.4.0.ebuild27
4 files changed, 25 insertions, 201 deletions
diff --git a/sci-geosciences/qgis/ChangeLog b/sci-geosciences/qgis/ChangeLog
index 8ce2f9833fbd..7cd5de4ba13b 100644
--- a/sci-geosciences/qgis/ChangeLog
+++ b/sci-geosciences/qgis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/qgis
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/ChangeLog,v 1.5 2010/03/09 12:09:12 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/ChangeLog,v 1.6 2010/04/26 22:50:43 scarabeus Exp $
+
+ 26 Apr 2010; Tomáš Chvátal <scarabeus@gentoo.org> -qgis-1.3.0.ebuild,
+ -files/qgis-1.3.0-sip.patch, qgis-1.4.0.ebuild:
+ Update to use python correctly. Drop old. Per bug #316215.
09 Mar 2010; Jonathan Callen <abcd@gentoo.org> qgis-1.3.0.ebuild,
qgis-1.4.0.ebuild:
diff --git a/sci-geosciences/qgis/files/qgis-1.3.0-sip.patch b/sci-geosciences/qgis/files/qgis-1.3.0-sip.patch
deleted file mode 100644
index 620b0d0e2c60..000000000000
--- a/sci-geosciences/qgis/files/qgis-1.3.0-sip.patch
+++ /dev/null
@@ -1,103 +0,0 @@
---- python/core/conversions.sip.orig 2009-11-21 19:58:32.000000000 +0000
-+++ python/core/conversions.sip 2009-11-21 20:08:49.000000000 +0000
-@@ -28,6 +28,10 @@
- {
- %TypeHeaderCode
- #include <QVector>
-+#if (SIP_VERSION >= 0x040900)
-+#define sipClass_QString ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QString))
-+#define sipClass_QVariant ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QVariant))
-+#endif
- %End
-
- %ConvertFromTypeCode
-@@ -104,6 +108,10 @@
- {
- %TypeHeaderCode
- #include <QVector>
-+#if (SIP_VERSION >= 0x040900)
-+#define sipClass_QString ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QString))
-+#define sipClass_QVariant ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QVariant))
-+#endif
- %End
-
- %ConvertFromTypeCode
-@@ -179,6 +187,10 @@
- {
- %TypeHeaderCode
- #include <QSet>
-+#if (SIP_VERSION >= 0x040900)
-+#define sipClass_QString ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QString))
-+#define sipClass_QVariant ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QVariant))
-+#endif
- %End
-
- %ConvertFromTypeCode
-@@ -229,6 +241,10 @@
- {
- %TypeHeaderCode
- #include <QSet>
-+#if (SIP_VERSION >= 0x040900)
-+#define sipClass_QString ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QString))
-+#define sipClass_QVariant ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QVariant))
-+#endif
- %End
-
- %ConvertFromTypeCode
-@@ -301,6 +317,10 @@
- {
- %TypeHeaderCode
- #include <QMap>
-+#if (SIP_VERSION >= 0x040900)
-+#define sipClass_QString ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QString))
-+#define sipClass_QVariant ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QVariant))
-+#endif
- %End
-
- %ConvertFromTypeCode
-@@ -418,6 +438,10 @@
- {
- %TypeHeaderCode
- #include <QMap>
-+#if (SIP_VERSION >= 0x040900)
-+#define sipClass_QString ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QString))
-+#define sipClass_QVariant ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QVariant))
-+#endif
- %End
-
- %ConvertFromTypeCode
-@@ -518,7 +542,11 @@
- %MappedType QMap<TYPE1, TYPE2*>
- {
- %TypeHeaderCode
--#include <qmap.h>
-+#include <QMap>
-+#if (SIP_VERSION >= 0x040900)
-+#define sipClass_QString ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QString))
-+#define sipClass_QVariant ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QVariant))
-+#endif
- %End
-
- %ConvertFromTypeCode
-@@ -626,6 +654,10 @@
- {
- %TypeHeaderCode
- #include <QMultiMap>
-+#if (SIP_VERSION >= 0x040900)
-+#define sipClass_QString ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QString))
-+#define sipClass_QVariant ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QVariant))
-+#endif
- %End
-
- %ConvertFromTypeCode
-@@ -744,6 +776,10 @@
- {
- %TypeHeaderCode
- #include <QMap>
-+#if (SIP_VERSION >= 0x040900)
-+#define sipClass_QString ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QString))
-+#define sipClass_QVariant ((sipWrapperType *) sipTypeAsPyTypeObject (sipType_QVariant))
-+#endif
- %End
-
- %ConvertFromTypeCode
diff --git a/sci-geosciences/qgis/qgis-1.3.0.ebuild b/sci-geosciences/qgis/qgis-1.3.0.ebuild
deleted file mode 100644
index 46a66c6367e6..000000000000
--- a/sci-geosciences/qgis/qgis-1.3.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/qgis-1.3.0.ebuild,v 1.4 2010/03/09 12:09:12 abcd Exp $
-
-EAPI="2"
-
-inherit cmake-utils eutils
-
-DESCRIPTION="User friendly Geographic Information System"
-HOMEPAGE="http://www.qgis.org/"
-SRC_URI="http://download.osgeo.org/${PN}/src/${PN}_${PV}.tar.gz
- examples? ( http://download.osgeo.org/${PN}/data/${PN}_sample_data.tar.gz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples gps grass gsl postgres python sqlite"
-
-RDEPEND=">=sci-libs/gdal-1.6.1
- x11-libs/qt-core:4[qt3support]
- x11-libs/qt-gui:4
- x11-libs/qt-svg:4
- x11-libs/qt-sql:4
- sci-libs/geos
- sci-libs/proj
- gps? ( dev-libs/expat sci-geosciences/gpsbabel )
- grass? ( >=sci-geosciences/grass-6 sci-geosciences/gdal-grass )
- gsl? ( sci-libs/gsl )
- postgres? ( >=virtual/postgresql-base-8 )
- python? ( dev-python/PyQt4[sql,svg] )
- sqlite? ( dev-db/sqlite:3 )"
-
-DEPEND="${RDEPEND}
- sys-devel/bison
- sys-devel/flex"
-
-src_prepare() {
- # patch to wor with all versions of sip, taken from upstream trunk
- epatch "${FILESDIR}"/${P}-sip.patch
-}
-
-src_configure() {
- local mycmakeargs
- mycmakeargs+=(
- "-DBUILD_SHARED_LIBS:BOOL=ON"
- "-DBINDINGS_GLOBAL_INSTALL:BOOL=ON"
- "-DQGIS_LIB_SUBDIR=$(get_libdir)"
- "-DQGIS_PLUGIN_SUBDIR=$(get_libdir)/qgis"
- $(cmake-utils_use_with postgres POSTGRESQL)
- $(cmake-utils_use_with grass GRASS)
- $(cmake-utils_use_with gps EXPAT)
- $(cmake-utils_use_with gsl GSL)
- $(cmake-utils_use_with python BINDINGS)
- $(cmake-utils_use_with sqlite SPATIALITE)
- )
-
- if use grass; then
- GRASS_ENVD="/etc/env.d/99grass /etc/env.d/99grass-6 /etc/env.d/99grass-cvs";
- for file in ${GRASS_ENVD}; do
- if test -r ${file}; then
- GRASSPATH=$(sed -n 's/LDPATH="\(.*\)\/lib"$/\1/p' ${file});
- fi
- done
- mycmakeargs+=(
- "-DGRASS_PREFIX=${GRASSPATH}"
- )
- fi
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc AUTHORS BUGS ChangeLog README SPONSORS CONTRIBUTORS
-
- newicon images/icons/qgis-icon.png qgis.png
- make_desktop_entry qgis "Quantum GIS " qgis
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins "${WORKDIR}"/qgis_sample_data/* || die "Unable to install examples"
- fi
-}
-
-pkg_postinst() {
- if use postgres; then
- elog "If you don't intend to use external PostGIS server"
- elog "you should install:"
- elog " dev-db/postgis"
- fi
-}
diff --git a/sci-geosciences/qgis/qgis-1.4.0.ebuild b/sci-geosciences/qgis/qgis-1.4.0.ebuild
index 617879621f85..3c9f002e8a71 100644
--- a/sci-geosciences/qgis/qgis-1.4.0.ebuild
+++ b/sci-geosciences/qgis/qgis-1.4.0.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/qgis-1.4.0.ebuild,v 1.2 2010/03/09 12:09:12 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/qgis-1.4.0.ebuild,v 1.3 2010/04/26 22:50:43 scarabeus Exp $
EAPI="2"
-inherit cmake-utils eutils
+PYTHON_USE_WITH="sqlite"
+PYTHON_DEPEND="python? 2"
+inherit python cmake-utils eutils
DESCRIPTION="User friendly Geographic Information System"
HOMEPAGE="http://www.qgis.org/"
@@ -24,17 +26,28 @@ RDEPEND=">=sci-libs/gdal-1.6.1
x11-libs/qt-sql:4
sci-libs/geos
sci-libs/proj
- gps? ( dev-libs/expat sci-geosciences/gpsbabel )
- grass? ( >=sci-geosciences/grass-6 sci-geosciences/gdal-grass )
+ gps? (
+ dev-libs/expat
+ sci-geosciences/gpsbabel
+ )
+ grass? (
+ >=sci-geosciences/grass-6
+ sci-geosciences/gdal-grass
+ )
gsl? ( sci-libs/gsl )
postgres? ( >=virtual/postgresql-base-8 )
- python? ( dev-lang/python[sqlite] dev-python/PyQt4[sql,svg] )
+ python? ( dev-python/PyQt4[sql,svg] )
sqlite? ( dev-db/sqlite:3 )"
DEPEND="${RDEPEND}
sys-devel/bison
sys-devel/flex"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_configure() {
local mycmakeargs
mycmakeargs+=(
@@ -66,9 +79,9 @@ src_configure() {
src_install() {
cmake-utils_src_install
- dodoc AUTHORS BUGS ChangeLog README SPONSORS CONTRIBUTORS
+ dodoc AUTHORS BUGS ChangeLog README SPONSORS CONTRIBUTORS || die
- newicon images/icons/qgis-icon.png qgis.png
+ newicon images/icons/qgis-icon.png qgis.png || die
make_desktop_entry qgis "Quantum GIS " qgis
if use examples; then