summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-09-25 05:56:22 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-09-25 05:56:22 +0000
commit7593525016274dd5d8540e47f1b11b0f5ac6ea4e (patch)
tree11c670010a93a3fa1259996428ba778fc9981f04 /sci-geosciences/mapnik
parentMore fun for older LDAP setups, where organizationalUnit was used instead of ... (diff)
downloadgentoo-2-7593525016274dd5d8540e47f1b11b0f5ac6ea4e.tar.gz
gentoo-2-7593525016274dd5d8540e47f1b11b0f5ac6ea4e.tar.bz2
gentoo-2-7593525016274dd5d8540e47f1b11b0f5ac6ea4e.zip
removed proj and gdal use flags in favor of hard depends
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.5 x86_64)
Diffstat (limited to 'sci-geosciences/mapnik')
-rw-r--r--sci-geosciences/mapnik/ChangeLog7
-rw-r--r--sci-geosciences/mapnik/mapnik-0.5.1.ebuild21
-rw-r--r--sci-geosciences/mapnik/metadata.xml6
3 files changed, 17 insertions, 17 deletions
diff --git a/sci-geosciences/mapnik/ChangeLog b/sci-geosciences/mapnik/ChangeLog
index 9c7fe67aebe0..c483ed8f3e2f 100644
--- a/sci-geosciences/mapnik/ChangeLog
+++ b/sci-geosciences/mapnik/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/mapnik
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/ChangeLog,v 1.1 2008/09/25 05:42:05 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/ChangeLog,v 1.2 2008/09/25 05:56:22 nerdboy Exp $
+
+ 25 Sep 2008; Steve Arnold <nerdboy@gentoo.org> metadata.xml,
+ mapnik-0.5.1.ebuild:
+ Removed proj and gdal use flags in favor of hard depends (mostly to
+ make it cleaner for people using gpsdrive).
*mapnik-0.5.1 (25 Sep 2008)
diff --git a/sci-geosciences/mapnik/mapnik-0.5.1.ebuild b/sci-geosciences/mapnik/mapnik-0.5.1.ebuild
index d69695db2fc7..c5c81d8b7797 100644
--- a/sci-geosciences/mapnik/mapnik-0.5.1.ebuild
+++ b/sci-geosciences/mapnik/mapnik-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/mapnik-0.5.1.ebuild,v 1.1 2008/09/25 05:42:05 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/mapnik-0.5.1.ebuild,v 1.2 2008/09/25 05:56:22 nerdboy Exp $
inherit eutils autotools
@@ -10,7 +10,7 @@ SRC_URI="mirror://berlios/mapnik/mapnik_src-${PV}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="postgres proj debug doc gdal python bidi"
+IUSE="debug doc postgres python bidi"
RDEPEND=">=dev-libs/boost-1.33.0
>=media-libs/libpng-1.2.12
@@ -18,9 +18,10 @@ RDEPEND=">=dev-libs/boost-1.33.0
>=media-libs/tiff-3.8.2
>=sys-libs/zlib-1.2.3
>=media-libs/freetype-2.1.10
+ >=sci-libs/proj-4.4.9
+ dev-libs/libxml2
+ sci-libs/gdal
postgres? ( >=dev-db/postgis-1.1.2 )
- proj? ( >=sci-libs/proj-4.4.9 )
- gdal? ( sci-libs/gdal )
python? ( >=dev-lang/python-2.4 )
bidi? ( dev-libs/fribidi )"
@@ -37,10 +38,14 @@ src_unpack() {
}
src_compile() {
+ MAKEOPTS="${MAKEOPTS} INPUT_PLUGINS=shape,raster,postgis"
+ MAKEOPTS="${MAKEOPTS} PROJ_INCLUDES=/usr/include"
+ MAKEOPTS="${MAKEOPTS} PROJ_LIBS=/usr/$(get_libdir)"
+ MAKEOPTS="${MAKEOPTS} XMLPARSER=libxml2"
+
if ! use python ; then
MAKEOPTS="${MAKEOPTS} BINDINGS=none"
fi
- MAKEOPTS="${MAKEOPTS} INPUT_PLUGINS=shape,raster,postgis"
if use debug ; then
MAKEOPTS="${MAKEOPTS} DEBUG=1"
fi
@@ -50,11 +55,7 @@ src_compile() {
if use postgres ; then
MAKEOPTS="${MAKEOPTS} PGSQL_INCLUDES=/usr/include/postgresql"
fi
- if use proj ; then
- MAKEOPTS="${MAKEOPTS} PROJ_INCLUDES=/usr/include"
- MAKEOPTS="${MAKEOPTS} PROJ_LIBS=/usr/$(get_libdir)"
- fi
- MAKEOPTS="${MAKEOPTS} XMLPARSER=libxml2"
+
scons ${MAKEOPTS} || die
}
diff --git a/sci-geosciences/mapnik/metadata.xml b/sci-geosciences/mapnik/metadata.xml
index 2a58472c65b5..5d28222ffe04 100644
--- a/sci-geosciences/mapnik/metadata.xml
+++ b/sci-geosciences/mapnik/metadata.xml
@@ -10,10 +10,4 @@
mapping applications. The core libraries are written in C++, with
optional Python bindings.
</longdescription>
-<use>
- <flag name='gdal'>Enable <pkg>sci-libs/gdal</pkg> geoformat conversion
- support</flag>
- <flag name='proj'> Enable <pkg>sci-libs/proj</pkg> library support for
- specific map projections</flag>
-</use>
</pkgmetadata>