summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-02-23 20:03:59 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-02-23 20:03:59 +0000
commit526cb746c344f0db28fc5debe877057fdcf62f91 (patch)
treef3fd9163d614e3e6acbb3c4a30e4758a5226cffe /sci-geosciences/gpsd/gpsd-2.32.ebuild
parentApply the patch for bug #208631 also in 3.5.9. (diff)
downloadgentoo-2-526cb746c344f0db28fc5debe877057fdcf62f91.tar.gz
gentoo-2-526cb746c344f0db28fc5debe877057fdcf62f91.tar.bz2
gentoo-2-526cb746c344f0db28fc5debe877057fdcf62f91.zip
updated to latest version and new udev rules (closes bug #210079)
(Portage version: 2.1.4.1)
Diffstat (limited to 'sci-geosciences/gpsd/gpsd-2.32.ebuild')
-rw-r--r--sci-geosciences/gpsd/gpsd-2.32.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sci-geosciences/gpsd/gpsd-2.32.ebuild b/sci-geosciences/gpsd/gpsd-2.32.ebuild
index 052a06a8741c..4963d948e335 100644
--- a/sci-geosciences/gpsd/gpsd-2.32.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.32.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.32.ebuild,v 1.4 2007/08/25 14:28:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.32.ebuild,v 1.5 2008/02/23 20:03:58 nerdboy Exp $
inherit eutils libtool distutils
@@ -41,7 +41,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
elibtoolize
}
@@ -55,8 +55,8 @@ src_compile() {
}
src_install() {
- cd ${S}
- make DESTDIR=${D} install
+
+ make DESTDIR="${D}" install
if use usb ; then
sed -i -e "s/gpsd.hotplug/gpsd/g" gpsd.hotplug gpsd.usermap
@@ -65,8 +65,8 @@ src_install() {
exeinto /etc/hotplug/usb
newexe gpsd.hotplug gpsd
else
- newconfd ${FILESDIR}/gpsd.conf gpsd
- newinitd ${FILESDIR}/gpsd.init gpsd
+ newconfd "${FILESDIR}"/gpsd.conf gpsd
+ newinitd "${FILESDIR}"/gpsd.init gpsd
fi
if use X ; then
insinto /etc/X11/app-defaults
@@ -77,7 +77,7 @@ src_install() {
diropts "-m0644"
exeinto /usr/$(get_libdir)/python${PYVER}/site-packages
doexe gps.py gpsfake.py
- dodoc AUTHORS HACKING INSTALL README TODO ${FILESDIR}/40-usb-serial.rules
+ dodoc AUTHORS HACKING INSTALL README TODO "${FILESDIR}"/40-usb-serial.rules
}
pkg_postinst() {