summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-01-10 10:45:08 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-01-10 10:45:08 +0000
commitf81731b2d82dd148c85f8b2a7e0bbe27f62dc8d0 (patch)
tree54946e5ad159a30e59e77d7ced26ca0e1fd9f308 /sci-electronics/gerbv
parentAdded hppa to KEYWORDS. (diff)
downloadgentoo-2-f81731b2d82dd148c85f8b2a7e0bbe27f62dc8d0.tar.gz
gentoo-2-f81731b2d82dd148c85f8b2a7e0bbe27f62dc8d0.tar.bz2
gentoo-2-f81731b2d82dd148c85f8b2a7e0bbe27f62dc8d0.zip
Fixed bug #204792.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'sci-electronics/gerbv')
-rw-r--r--sci-electronics/gerbv/ChangeLog8
-rw-r--r--sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild16
-rw-r--r--sci-electronics/gerbv/gerbv-1.0.2.ebuild14
-rw-r--r--sci-electronics/gerbv/gerbv-1.0.3.ebuild8
4 files changed, 28 insertions, 18 deletions
diff --git a/sci-electronics/gerbv/ChangeLog b/sci-electronics/gerbv/ChangeLog
index 9e27548c00e6..df1854d46da8 100644
--- a/sci-electronics/gerbv/ChangeLog
+++ b/sci-electronics/gerbv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/gerbv
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/ChangeLog,v 1.22 2007/12/03 10:03:28 calchan Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/ChangeLog,v 1.23 2008/01/10 10:45:08 calchan Exp $
+
+ 10 Jan 2008; Denis Dupeyron <calchan@gentoo.org> gerbv-1.0.1-r1.ebuild,
+ gerbv-1.0.2.ebuild, gerbv-1.0.3.ebuild:
+ Fixed bug #204792.
*gerbv-1.0.3 (03 Dec 2007)
diff --git a/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild b/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild
index d4e474ea8f57..4cea0788ad6a 100644
--- a/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild
+++ b/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild,v 1.10 2006/10/29 21:11:56 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild,v 1.11 2008/01/10 10:45:08 calchan Exp $
inherit eutils
@@ -13,24 +13,26 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ppc sparc x86"
-DEPEND="=x11-libs/gtk+-2*
+RDEPEND="=x11-libs/gtk+-2*
png? ( media-libs/libpng )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
src_compile() {
local confOptions
confOptions='--enable-gtk2'
- use xinerama && epatch ${FILESDIR}/${PN}-1.0.0-Xinerama.patch
+ use xinerama && epatch "${FILESDIR}/${PN}-1.0.0-Xinerama.patch"
use png || confOptions="$confOptions --disable-exportpng"
- epatch ${FILESDIR}/${PN}-1.0.0-gcc-4.10.patch
+ epatch "${FILESDIR}/${PN}-1.0.0-gcc-4.10.patch"
econf $confOptions || die
emake || die
}
src_install () {
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
if use doc; then
cd doc
dodoc sources.txt
diff --git a/sci-electronics/gerbv/gerbv-1.0.2.ebuild b/sci-electronics/gerbv/gerbv-1.0.2.ebuild
index f6b728b3088a..b8695575a38a 100644
--- a/sci-electronics/gerbv/gerbv-1.0.2.ebuild
+++ b/sci-electronics/gerbv/gerbv-1.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-1.0.2.ebuild,v 1.3 2006/10/29 21:11:56 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-1.0.2.ebuild,v 1.4 2008/01/10 10:45:08 calchan Exp $
inherit eutils
@@ -13,14 +13,16 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-DEPEND="=x11-libs/gtk+-2*
+RDEPEND="=x11-libs/gtk+-2*
png? ( media-libs/libpng )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
src_compile() {
local confOptions
confOptions='--enable-gtk2'
- use xinerama && epatch ${FILESDIR}/${PN}-1.0.0-Xinerama.patch
+ use xinerama && epatch "${FILESDIR}/${PN}-1.0.0-Xinerama.patch"
use png || confOptions="$confOptions --disable-exportpng"
econf $confOptions || die
@@ -28,8 +30,8 @@ src_compile() {
}
src_install () {
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
if use doc; then
cd doc
dodoc sources.txt
diff --git a/sci-electronics/gerbv/gerbv-1.0.3.ebuild b/sci-electronics/gerbv/gerbv-1.0.3.ebuild
index 0b27796c7d92..64d263a3164d 100644
--- a/sci-electronics/gerbv/gerbv-1.0.3.ebuild
+++ b/sci-electronics/gerbv/gerbv-1.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-1.0.3.ebuild,v 1.1 2007/12/03 10:03:28 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-1.0.3.ebuild,v 1.2 2008/01/10 10:45:08 calchan Exp $
DESCRIPTION="A free Gerber viewer"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -11,8 +11,10 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-DEPEND="=x11-libs/gtk+-2*
+RDEPEND="=x11-libs/gtk+-2*
png? ( media-libs/libpng )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
src_compile() {
econf \