summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-15 09:15:32 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-15 09:15:32 +0000
commitf6ea11340d86fe7b5342059c0e84dd4b88aac643 (patch)
treef5e30933d813f254eed06ae08746cdc9a19d8b1f /sci-chemistry
parentMask media-video/mplayer2 and media-video/smplayer2 for removal in 30 days (b... (diff)
downloadgentoo-2-f6ea11340d86fe7b5342059c0e84dd4b88aac643.tar.gz
gentoo-2-f6ea11340d86fe7b5342059c0e84dd4b88aac643.tar.bz2
gentoo-2-f6ea11340d86fe7b5342059c0e84dd4b88aac643.zip
Version BUmp
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/relax/ChangeLog8
-rw-r--r--sci-chemistry/relax/relax-3.3.6.ebuild10
-rw-r--r--sci-chemistry/relax/relax-3.3.7.ebuild73
3 files changed, 87 insertions, 4 deletions
diff --git a/sci-chemistry/relax/ChangeLog b/sci-chemistry/relax/ChangeLog
index da4693fbc94d..26cc8188f833 100644
--- a/sci-chemistry/relax/ChangeLog
+++ b/sci-chemistry/relax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/relax
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/ChangeLog,v 1.34 2015/02/07 07:58:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/ChangeLog,v 1.35 2015/03/15 09:15:32 jlec Exp $
+
+*relax-3.3.7 (15 Mar 2015)
+
+ 15 Mar 2015; Justin Lecher <jlec@gentoo.org> +relax-3.3.7.ebuild,
+ relax-3.3.6.ebuild:
+ Version BUmp
07 Feb 2015; Justin Lecher <jlec@gentoo.org> -files/relax-2.1.0-gentoo.patch,
-files/relax-2.2.1-gentoo.patch, -files/relax-3.0.1-gentoo.patch,
diff --git a/sci-chemistry/relax/relax-3.3.6.ebuild b/sci-chemistry/relax/relax-3.3.6.ebuild
index 726d0d2a1a00..ffc93ae9c65f 100644
--- a/sci-chemistry/relax/relax-3.3.6.ebuild
+++ b/sci-chemistry/relax/relax-3.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/relax-3.3.6.ebuild,v 1.1 2015/02/07 07:56:16 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/relax-3.3.6.ebuild,v 1.2 2015/03/15 09:15:32 jlec Exp $
EAPI=5
@@ -17,7 +17,7 @@ SRC_URI="http://download.gna.org/relax/${P}.src.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
+IUSE="test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -37,7 +37,11 @@ RDEPEND="
sci-visualization/opendx
x11-libs/wxGTK:${WX_GTK_VER}[X]"
DEPEND="${RDEPEND}
- media-gfx/pngcrush"
+ media-gfx/pngcrush
+ test? (
+ ${RDEPEND}
+ )
+ "
pkg_setup() {
python-single-r1_pkg_setup
diff --git a/sci-chemistry/relax/relax-3.3.7.ebuild b/sci-chemistry/relax/relax-3.3.7.ebuild
new file mode 100644
index 000000000000..ba28f11f4584
--- /dev/null
+++ b/sci-chemistry/relax/relax-3.3.7.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/relax-3.3.7.ebuild,v 1.1 2015/03/15 09:15:32 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+WX_GTK_VER="2.9"
+
+inherit eutils multiprocessing python-single-r1 scons-utils toolchain-funcs wxwidgets virtualx
+
+DESCRIPTION="Molecular dynamics by NMR data analysis"
+HOMEPAGE="http://www.nmr-relax.com/"
+SRC_URI="http://download.gna.org/relax/${P}.src.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/Numdifftools[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/wxpython:${WX_GTK_VER}[${PYTHON_USEDEP}]
+ sci-chemistry/molmol
+ sci-chemistry/pymol[${PYTHON_USEDEP}]
+ sci-chemistry/vmd
+ >=sci-libs/bmrblib-1.0.3[${PYTHON_USEDEP}]
+ >=sci-libs/minfx-1.0.11[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-visualization/grace
+ sci-visualization/opendx
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${RDEPEND}
+ media-gfx/pngcrush
+ test? (
+ ${RDEPEND}
+ )
+ "
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -rf minfx bmrblib extern/numdifftools || die
+ tc-export CC
+}
+
+src_compile() {
+ escons
+}
+
+src_test() {
+ VIRTUALX_COMMAND="${EPYTHON} ./${PN}.py -x --traceback"
+ virtualmake
+}
+
+src_install() {
+ dodoc README docs/{CHANGES,COMMITTERS,JOBS,relax.pdf}
+
+ python_moduleinto ${PN}
+ python_domodule *
+
+ rm ${PN} README || die
+
+ make_wrapper ${PN}-nmr "${EPYTHON} $(python_get_sitedir)/${PN}/${PN}.py $@"
+}