summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-05-23 21:20:35 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-05-23 21:20:35 +0000
commit577f1eae697efc5936176bd0521225a415d09d67 (patch)
tree8fe5e505a7c6661d3faf7f99f7dd3954eebe99af /sci-chemistry
parentStable on x86 wrt bug #133989. (diff)
downloadgentoo-2-577f1eae697efc5936176bd0521225a415d09d67.tar.gz
gentoo-2-577f1eae697efc5936176bd0521225a415d09d67.tar.bz2
gentoo-2-577f1eae697efc5936176bd0521225a415d09d67.zip
Added patch to enable compilation with gcc-4.1.
(Portage version: 2.1_rc2)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/apbs/ChangeLog6
-rw-r--r--sci-chemistry/apbs/apbs-0.4.0.ebuild9
-rw-r--r--sci-chemistry/apbs/files/apbs-gcc4-gentoo.patch20
3 files changed, 31 insertions, 4 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index 53d4d5717acb..9ab2573a2f48 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.4 2006/04/27 22:26:41 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.5 2006/05/23 21:20:35 markusle Exp $
+
+ 23 May 2006; Markus Dittrich <markusle@gentoo.org>
+ +files/apbs-gcc4-gentoo.patch, apbs-0.4.0.ebuild:
+ Added patch to enable compilation with gcc-4.1.
27 Apr 2006; Alec Warner <antarus@gentoo.org> files/digest-apbs-0.3.2,
Manifest:
diff --git a/sci-chemistry/apbs/apbs-0.4.0.ebuild b/sci-chemistry/apbs/apbs-0.4.0.ebuild
index e61251406059..ad26ce177695 100644
--- a/sci-chemistry/apbs/apbs-0.4.0.ebuild
+++ b/sci-chemistry/apbs/apbs-0.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-0.4.0.ebuild,v 1.1 2006/03/09 11:48:28 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-0.4.0.ebuild,v 1.2 2006/05/23 21:20:35 markusle Exp $
inherit eutils fortran
@@ -18,8 +18,10 @@ DEPEND="blas? ( virtual/blas )
dev-libs/maloc
mpi? ( virtual/mpi )"
+FORTRAN="g77 gfortran"
+
pkg_setup() {
- need_fortran g77
+ fortran_pkg_setup
# the configure script has a weird MPI related behaviour:
# if maloc was compiled with mpi, apbs requires mpi as
@@ -39,7 +41,8 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- epatch "${FILESDIR}"/apbs-examples-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-examples-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-gcc4-gentoo.patch
}
src_compile() {
diff --git a/sci-chemistry/apbs/files/apbs-gcc4-gentoo.patch b/sci-chemistry/apbs/files/apbs-gcc4-gentoo.patch
new file mode 100644
index 000000000000..434a7fc0a05c
--- /dev/null
+++ b/sci-chemistry/apbs/files/apbs-gcc4-gentoo.patch
@@ -0,0 +1,20 @@
+--- apbs-0.4.0/configure 2005-12-14 14:11:17.000000000 -0500
++++ apbs-0.4.0-new/configure 2006-05-23 17:01:07.000000000 -0400
+@@ -3513,7 +3513,7 @@
+ ac_link='$F77 -o conftest$ac_exeext $FFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
+ ac_compiler_gnu=$ac_cv_f77_compiler_gnu
+ if test -n "$ac_tool_prefix"; then
+- for ac_prog in g77 f77 xlf frt pgf77 fl32 af77 fort77 f90 xlf90 pgf90 epcf90 f95 fort xlf95 lf95 g95
++ for ac_prog in g77 gfortran f77 xlf frt pgf77 fl32 af77 fort77 f90 xlf90 pgf90 epcf90 f95 fort xlf95 lf95 g95
+ do
+ # Extract the first word of "$ac_tool_prefix$ac_prog", so it can be a program name with args.
+ set dummy $ac_tool_prefix$ac_prog; ac_word=$2
+@@ -3555,7 +3555,7 @@
+ fi
+ if test -z "$F77"; then
+ ac_ct_F77=$F77
+- for ac_prog in g77 f77 xlf frt pgf77 fl32 af77 fort77 f90 xlf90 pgf90 epcf90 f95 fort xlf95 lf95 g95
++ for ac_prog in g77 gfortran f77 xlf frt pgf77 fl32 af77 fort77 f90 xlf90 pgf90 epcf90 f95 fort xlf95 lf95 g95
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+ set dummy $ac_prog; ac_word=$2