summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-06-06 08:10:14 +0000
committerJustin Lecher <jlec@gentoo.org>2014-06-06 08:10:14 +0000
commit4873414d1650f81add5c777b9c1cec56f4c31466 (patch)
tree1ad084343083b9b909aebb9aa84dd07e16465762 /sci-chemistry
parentStable on amd64 and x86, wrt bug #509828 (diff)
downloadgentoo-2-4873414d1650f81add5c777b9c1cec56f4c31466.tar.gz
gentoo-2-4873414d1650f81add5c777b9c1cec56f4c31466.tar.bz2
gentoo-2-4873414d1650f81add5c777b9c1cec56f4c31466.zip
sci-chemistry/relax: Version Bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/relax/ChangeLog8
-rw-r--r--sci-chemistry/relax/files/relax-3.2.2-gentoo.patch28
-rw-r--r--sci-chemistry/relax/relax-3.2.2.ebuild71
3 files changed, 106 insertions, 1 deletions
diff --git a/sci-chemistry/relax/ChangeLog b/sci-chemistry/relax/ChangeLog
index 035e48b9b6ec..a7667b9b113a 100644
--- a/sci-chemistry/relax/ChangeLog
+++ b/sci-chemistry/relax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/relax
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/ChangeLog,v 1.24 2014/05/26 07:40:57 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/ChangeLog,v 1.25 2014/06/06 08:10:14 jlec Exp $
+
+*relax-3.2.2 (06 Jun 2014)
+
+ 06 Jun 2014; Justin Lecher <jlec@gentoo.org> +relax-3.2.2.ebuild,
+ +files/relax-3.2.2-gentoo.patch:
+ Version Bump
*relax-3.2.1 (26 May 2014)
diff --git a/sci-chemistry/relax/files/relax-3.2.2-gentoo.patch b/sci-chemistry/relax/files/relax-3.2.2-gentoo.patch
new file mode 100644
index 000000000000..bfe7a26be096
--- /dev/null
+++ b/sci-chemistry/relax/files/relax-3.2.2-gentoo.patch
@@ -0,0 +1,28 @@
+ sconstruct | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/sconstruct b/sconstruct
+index 511a6dd..fc2d6de 100644
+--- a/sconstruct
++++ b/sconstruct
+@@ -25,7 +25,7 @@
+
+
+ # Import statements.
+-from os import F_OK, access, getcwd, path, remove, rmdir, sep, walk
++from os import F_OK, access, getcwd, path, remove, rmdir, sep, walk, environ
+ import platform
+ from re import search
+ from shutil import rmtree
+@@ -630,6 +630,11 @@ class Main:
+ for file in files:
+ nodes.append(env.SharedObject(dir + path.sep + file, CCFLAGS=cflags))
+
++ env.Append(LINKFLAGS = environ['LDFLAGS'])
++ env.Append(CFLAGS = environ['CFLAGS'])
++ env.Replace(CC = environ['CC'])
++
++
+ # Build the relaxation curve fitting module.
+ self.relax_fit_object = env.SharedLibrary(target=dir + path.sep + 'relax_fit', source=nodes, SHLIBPREFIX=prefix, SHLIBSUFFIX=suffix)
+
diff --git a/sci-chemistry/relax/relax-3.2.2.ebuild b/sci-chemistry/relax/relax-3.2.2.ebuild
new file mode 100644
index 000000000000..6eab382a73e3
--- /dev/null
+++ b/sci-chemistry/relax/relax-3.2.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/relax-3.2.2.ebuild,v 1.1 2014/06/06 08:10:14 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+WX_GTK_VER="2.9"
+
+inherit eutils multiprocessing python-single-r1 scons-utils toolchain-funcs wxwidgets virtualx
+
+DESCRIPTION="Molecular dynamics by NMR data analysis"
+HOMEPAGE="http://www.nmr-relax.com/"
+SRC_URI="http://download.gna.org/relax/${P}.src.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/wxpython:${WX_GTK_VER}[${PYTHON_USEDEP}]
+ sci-chemistry/molmol
+ sci-chemistry/pymol[${PYTHON_USEDEP}]
+ sci-chemistry/vmd
+ >=sci-libs/bmrblib-1.0.3[${PYTHON_USEDEP}]
+ >=sci-libs/minfx-1.0.5[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-visualization/grace
+ sci-visualization/opendx
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${RDEPEND}
+ media-gfx/pngcrush"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ local png
+ rm -rf minfx bmrblib || die
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch
+ tc-export CC
+}
+
+src_compile() {
+ escons
+}
+
+src_test() {
+ VIRTUALX_COMMAND="${EPYTHON} ./${PN}.py -x --traceback"
+ virtualmake
+}
+
+src_install() {
+ dodoc README docs/{CHANGES,COMMITTERS,JOBS,relax.pdf,prompt_screenshot.txt}
+
+ python_moduleinto ${PN}
+ python_domodule *
+
+ rm ${PN} README || die
+
+ make_wrapper ${PN}-nmr "${EPYTHON} $(python_get_sitedir)/${PN}/${PN}.py $@"
+}