summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-17 15:25:21 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-17 15:25:21 +0000
commit7cbf9fbc4590bee433897c0a63bc8e68a4d026b1 (patch)
treef56a4de3438891995b71bf2f95724f90d36b9005 /sci-chemistry/xdsi
parentCleanup old (diff)
downloadgentoo-2-7cbf9fbc4590bee433897c0a63bc8e68a4d026b1.tar.gz
gentoo-2-7cbf9fbc4590bee433897c0a63bc8e68a4d026b1.tar.bz2
gentoo-2-7cbf9fbc4590bee433897c0a63bc8e68a4d026b1.zip
Version Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/xdsi')
-rw-r--r--sci-chemistry/xdsi/ChangeLog8
-rw-r--r--sci-chemistry/xdsi/files/0.92-gentoo.patch24
-rw-r--r--sci-chemistry/xdsi/xdsi-0.92.ebuild49
3 files changed, 80 insertions, 1 deletions
diff --git a/sci-chemistry/xdsi/ChangeLog b/sci-chemistry/xdsi/ChangeLog
index 924359093a0f..8d8933774e4d 100644
--- a/sci-chemistry/xdsi/ChangeLog
+++ b/sci-chemistry/xdsi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/xdsi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xdsi/ChangeLog,v 1.2 2010/04/25 11:31:42 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xdsi/ChangeLog,v 1.3 2010/05/17 15:25:21 jlec Exp $
+
+*xdsi-0.92 (17 May 2010)
+
+ 17 May 2010; Justin Lecher <jlec@gentoo.org> +files/0.92-gentoo.patch,
+ +xdsi-0.92.ebuild:
+ Version Bump
*xdsi-0.91 (17 Feb 2010)
diff --git a/sci-chemistry/xdsi/files/0.92-gentoo.patch b/sci-chemistry/xdsi/files/0.92-gentoo.patch
new file mode 100644
index 000000000000..a7ba308371ec
--- /dev/null
+++ b/sci-chemistry/xdsi/files/0.92-gentoo.patch
@@ -0,0 +1,24 @@
+diff --git a/xdsi b/xdsi
+index cbedee8..e11abc5 100755
+--- a/xdsi
++++ b/xdsi
+@@ -20,8 +20,8 @@
+ ####################################################################
+ # These are the only two things you should change#
+
+-set Templates "/mydir/templates"
+-set initial "/mydir/SLS-2009"
++set Templates "GENTOOTEMPLATE"
++set initial "./"
+
+
+ ####################################################################
+@@ -121,7 +121,7 @@ your system administrator."
+ }
+
+
+-CheckExecutables "kpdf gnuplot xds_par xdsstat xds-viewer-0.6 convert pointless ipmosflm VIEW"
++CheckExecutables "xpdf gnuplot xds_par xds-viewer convert pointless ipmosflm"
+
+ #wm resizable . 0 0
+
diff --git a/sci-chemistry/xdsi/xdsi-0.92.ebuild b/sci-chemistry/xdsi/xdsi-0.92.ebuild
new file mode 100644
index 000000000000..173f95b918b5
--- /dev/null
+++ b/sci-chemistry/xdsi/xdsi-0.92.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xdsi/xdsi-0.92.ebuild,v 1.1 2010/05/17 15:25:21 jlec Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="A crude interface for running the XDS"
+HOMEPAGE="http://strucbio.biologie.uni-konstanz.de/xdswiki/index.php/Xdsi"
+SRC_URI="ftp://turn5.biologie.uni-konstanz.de/pub/${PN}_${PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ sci-chemistry/mosflm
+ sci-chemistry/xds-bin[smp]
+ sci-chemistry/pointless
+ sci-visualization/xds-viewer
+ sci-visualization/gnuplot
+ media-gfx/imagemagick
+ app-text/xpdf
+ dev-lang/tk"
+# Need to clarified for licensing
+# sci-chemistry/xdsstat-bin
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ sed "s:GENTOOTEMPLATE:${EPREFIX}/usr/share/${PN}/templates:g" -i ${PN} \
+ || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ insinto /usr/share/${PN}/templates
+ doins templates/{*.INP,bohr*,fortran,pauli,info.png,*.pck,tablesf_xdsi} || die
+ dodoc templates/*.pdf || die
+}
+
+pkg_postinst() {
+ elog "Documentation can be found here:"
+ elog "ftp://turn14.biologie.uni-konstanz.de/pub/xdsi/xdsi_doc_print.pdf"
+}