summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-04-09 09:57:35 +0000
committerJustin Lecher <jlec@gentoo.org>2013-04-09 09:57:35 +0000
commit5b7390b061bbd45dcac063559880e325f1f4f20b (patch)
treef78983fab08ae5924698154bebdcc0f36eb038aa /sci-chemistry/theseus
parentold (diff)
downloadgentoo-2-5b7390b061bbd45dcac063559880e325f1f4f20b.tar.gz
gentoo-2-5b7390b061bbd45dcac063559880e325f1f4f20b.tar.bz2
gentoo-2-5b7390b061bbd45dcac063559880e325f1f4f20b.zip
sci-chemistry/theseus: Version Bump
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-chemistry/theseus')
-rw-r--r--sci-chemistry/theseus/ChangeLog10
-rw-r--r--sci-chemistry/theseus/metadata.xml8
-rw-r--r--sci-chemistry/theseus/theseus-2.0.1.ebuild64
3 files changed, 76 insertions, 6 deletions
diff --git a/sci-chemistry/theseus/ChangeLog b/sci-chemistry/theseus/ChangeLog
index bce30627e4d5..a23eb9b25152 100644
--- a/sci-chemistry/theseus/ChangeLog
+++ b/sci-chemistry/theseus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/theseus
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/theseus/ChangeLog,v 1.4 2012/05/04 07:02:35 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/theseus/ChangeLog,v 1.5 2013/04/09 09:57:35 jlec Exp $
+
+*theseus-2.0.1 (09 Apr 2013)
+
+ 09 Apr 2013; Justin Lecher <jlec@gentoo.org> +theseus-2.0.1.ebuild,
+ metadata.xml:
+ Version Bump
04 May 2012; Jeff Horelick <jdhore@gentoo.org> theseus-1.6.2-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/sci-chemistry/theseus/metadata.xml b/sci-chemistry/theseus/metadata.xml
index dde7ca88a50f..ae9ec7c5f6a4 100644
--- a/sci-chemistry/theseus/metadata.xml
+++ b/sci-chemistry/theseus/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/sci-chemistry/theseus/theseus-2.0.1.ebuild b/sci-chemistry/theseus/theseus-2.0.1.ebuild
new file mode 100644
index 000000000000..7c84e3da67b6
--- /dev/null
+++ b/sci-chemistry/theseus/theseus-2.0.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/theseus/theseus-2.0.1.ebuild,v 1.1 2013/04/09 09:57:35 jlec Exp $
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="maximum likelihood superpositioning and analysis of macromolecular structures"
+HOMEPAGE="http://www.theseus3d.org/"
+SRC_URI="http://www.theseus3d.org/src/${PN}_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ sci-libs/gsl
+ || (
+ sci-biology/probcons
+ sci-biology/mafft
+ sci-biology/t-coffee
+ sci-biology/kalign
+ sci-biology/clustalw
+ sci-biology/muscle
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${PN}_src/
+
+src_prepare() {
+ cat >> make.inc <<- EOF
+ ARCH = $(tc-getAR)
+ ARCHFLAGS = -rvs
+ RANLIB = $(tc-getRANLIB)
+ LOCALLIBDIR = "${EPREFIX}/usr/$(get_libdir)
+ SYSLIBS = $(pkg-config --libs gsl) -lpthread
+ LIBS = -ldistfit -lmsa -ldssplite -ldltmath -lDLTutils -ltheseus
+ LIBDIR = -L./lib
+ INSTALLDIR = "${ED}"/usr/bin
+ OPT =
+ WARN =
+ CFLAGS = ${CFLAGS} \$(WARN)
+ CC = $(tc-getCC)
+ EOF
+
+ sed \
+ -e 's|theseus:|theseus: libs|g' \
+ -e '/-o theseus/s:$(CC):$(CC) ${LDFLAGS}:g' \
+ -i Makefile || die
+
+ sed \
+ -e 's:/usr/local/bin/::g' \
+ -e 's:/usr/bin/::g' \
+ -i theseus_align || die
+}
+
+src_install() {
+ dobin theseus theseus_align
+ dodoc theseus_man.pdf README AUTHORS
+ use examples && insinto /usr/share/${PN} && doins -r examples
+}