summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-05 23:41:04 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-05 23:41:04 +0000
commit61af318a6ae8a6a5c4aa0d890d11639328db16a5 (patch)
treebd9433d4732781cc9f8d5948d1fc880e523a45f4 /sci-chemistry/reduce
parentVersion Bump (diff)
downloadgentoo-2-61af318a6ae8a6a5c4aa0d890d11639328db16a5.tar.gz
gentoo-2-61af318a6ae8a6a5c4aa0d890d11639328db16a5.tar.bz2
gentoo-2-61af318a6ae8a6a5c4aa0d890d11639328db16a5.zip
Clean old versions, fix for bug 280857 & bug 280858
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/reduce')
-rw-r--r--sci-chemistry/reduce/ChangeLog11
-rw-r--r--sci-chemistry/reduce/files/3.13.080428-LDFLAGS.patch11
-rw-r--r--sci-chemistry/reduce/reduce-2.21.030604.ebuild61
-rw-r--r--sci-chemistry/reduce/reduce-3.02.060709.ebuild50
-rw-r--r--sci-chemistry/reduce/reduce-3.13.080428-r1.ebuild56
5 files changed, 76 insertions, 113 deletions
diff --git a/sci-chemistry/reduce/ChangeLog b/sci-chemistry/reduce/ChangeLog
index f357c8aaee35..ccdf4e1c5d70 100644
--- a/sci-chemistry/reduce/ChangeLog
+++ b/sci-chemistry/reduce/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/reduce
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/reduce/ChangeLog,v 1.12 2009/05/29 00:43:56 dberkholz Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/reduce/ChangeLog,v 1.13 2010/02/05 23:41:04 jlec Exp $
+
+*reduce-3.13.080428-r1 (05 Feb 2010)
+
+ 05 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/3.13.080428-LDFLAGS.patch, -reduce-2.21.030604.ebuild,
+ -reduce-3.02.060709.ebuild, +reduce-3.13.080428-r1.ebuild:
+ Clean old versions, fix for 280857 & 280858
29 May 2009; Donnie Berkholz <dberkholz@gentoo.org>;
reduce-3.13.080428.ebuild:
diff --git a/sci-chemistry/reduce/files/3.13.080428-LDFLAGS.patch b/sci-chemistry/reduce/files/3.13.080428-LDFLAGS.patch
new file mode 100644
index 000000000000..bcee1a9fe8f3
--- /dev/null
+++ b/sci-chemistry/reduce/files/3.13.080428-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- reduce_src/Makefile 2009-08-09 10:11:29.000000000 +0200
++++ reduce_src/Makefile.new 2009-08-09 10:13:31.000000000 +0200
+@@ -34,7 +34,7 @@
+ all: reduce
+
+ reduce: $(OBJLIST)
+- $(CXX) -o $@ $(OBJLIST) $(LFLAGS)
++ $(CXX) $(LDFLAGS) -o $@ $(OBJLIST) $(LFLAGS)
+
+ clean:
+ @rm -rf *.o *.ckp ii_files
diff --git a/sci-chemistry/reduce/reduce-2.21.030604.ebuild b/sci-chemistry/reduce/reduce-2.21.030604.ebuild
deleted file mode 100644
index d101a977f163..000000000000
--- a/sci-chemistry/reduce/reduce-2.21.030604.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/reduce/reduce-2.21.030604.ebuild,v 1.4 2006/10/23 03:55:16 dberkholz Exp $
-
-# If you want to fix the warnings about friend declaration 'foo' declared as
-# a non-template function, see http://gcc.gnu.org/faq.html#friend.
-
-inherit eutils toolchain-funcs
-
-MY_P="${PN}.${PV}"
-DESCRIPTION="Adds hydrogens to a Protein Data Bank (PDB) molecule structure file"
-HOMEPAGE="http://kinemage.biochem.duke.edu/software/reduce.php"
-SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/reduce/${MY_P}.src.tgz
- http://kinemage.biochem.duke.edu/downloads/software/reduce/reduce_het_dict.txt.zip"
-LICENSE="richardson"
-SLOT="0"
-KEYWORDS="ppc x86"
-IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
- app-arch/unzip"
-S="${WORKDIR}/${MY_P}.source"
-
-src_unpack() {
- DICT_DIR="/usr/$(get_libdir)/reduce"
- DICT_FILE="reduce_het_dict.txt"
- DICT_LOC="${DICT_DIR}/${DICT_FILE}"
-
- unpack ${A}
- epatch ${FILESDIR}/${PV}-gcc4.patch
-
- # Get Makefiles that are at least somewhere close to right
- einfo "Updating Makefiles"
- for dir in libpdb reduce_src toolclasses; do
- pushd "${S}"/${dir} > /dev/null
- mv Makefile Makefile.old
- mv Makefile.g++ Makefile
- popd > /dev/null
- done
-
- # Do after replacing Makefiles
- einfo "Fixing CFLAGS and locations"
- sed -i \
- -e "s:^\(DICT_HOME\).*:\1 = ${DICT_LOC}:g" \
- -e "s:-DBRACKETOPERPARMS::g" \
- "${S}"/*/Makefile
-}
-
-src_compile() {
- emake \
- CXX="$(tc-getCXX)" \
- OPT="${CXXFLAGS}" \
- || die "make failed"
-}
-
-src_install() {
- dobin ${S}/reduce_src/reduce
- dodoc ${S}/README*
- insinto ${DICT_DIR}
- doins ${WORKDIR}/${DICT_FILE}
-}
diff --git a/sci-chemistry/reduce/reduce-3.02.060709.ebuild b/sci-chemistry/reduce/reduce-3.02.060709.ebuild
deleted file mode 100644
index 6499a9ba82f2..000000000000
--- a/sci-chemistry/reduce/reduce-3.02.060709.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/reduce/reduce-3.02.060709.ebuild,v 1.3 2006/10/23 03:55:16 dberkholz Exp $
-
-# If you want to fix the warnings about friend declaration 'foo' declared as
-# a non-template function, see http://gcc.gnu.org/faq.html#friend.
-
-inherit eutils toolchain-funcs
-
-MY_P="${PN}.${PV}.source"
-DESCRIPTION="Adds hydrogens to a Protein Data Bank (PDB) molecule structure file"
-HOMEPAGE="http://kinemage.biochem.duke.edu/software/reduce.php"
-SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/reduce/${MY_P}.tgz
- http://kinemage.biochem.duke.edu/downloads/software/reduce/reduce_het_dict.txt.zip"
-LICENSE="richardson"
-SLOT="0"
-KEYWORDS="~ppc ~x86"
-IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
- app-arch/unzip"
-S="${WORKDIR}/${PN}src"
-
-src_unpack() {
- DICT_DIR="/usr/share/reduce"
- DICT_FILE="reduce_het_dict.txt"
- DICT_LOC="${DICT_DIR}/${DICT_FILE}"
-
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PV}-remove-extra-qualification.patch
-
- einfo "Fixing location of dictionary"
- sed -i \
- -e "s:^\(DICT_HOME.*=\).*:\1 ${DICT_LOC}:g" \
- "${S}"/*/Makefile
-}
-
-src_compile() {
- emake \
- CXX="$(tc-getCXX)" \
- OPT="${CXXFLAGS}" \
- || die "make failed"
-}
-
-src_install() {
- dobin ${S}/reduce_src/reduce
- insinto ${DICT_DIR}
- doins ${WORKDIR}/${DICT_FILE}
-}
diff --git a/sci-chemistry/reduce/reduce-3.13.080428-r1.ebuild b/sci-chemistry/reduce/reduce-3.13.080428-r1.ebuild
new file mode 100644
index 000000000000..a4c7ea549cb7
--- /dev/null
+++ b/sci-chemistry/reduce/reduce-3.13.080428-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/reduce/reduce-3.13.080428-r1.ebuild,v 1.1 2010/02/05 23:41:04 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}.${PV}.src"
+
+DESCRIPTION="Adds hydrogens to a Protein Data Bank (PDB) molecule structure file"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/reduce.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/reduce31/${MY_P}.tgz"
+
+LICENSE="richardson"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-LDFLAGS.patch
+}
+
+src_compile() {
+ DICT_DIR="/usr/share/reduce"
+ DICT_FILE="reduce_het_dict.txt"
+
+ emake \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ OPT="${CXXFLAGS}" \
+ DICT_HOME="${EPREFIX}/${DICT_DIR}/${DICT_FILE}" \
+ || die "make failed"
+}
+
+src_install() {
+ dobin "${S}"/reduce_src/reduce || die
+ insinto ${DICT_DIR}
+ doins "${S}"/${DICT_FILE} "${S}"/reduce_wwPDB_het_dict.txt || die
+ dodoc README.usingReduce.txt || die
+}
+
+pkg_info() {
+ elog "To use the PDBv3 dictionary instead of PDBv2, set the environment"
+ elog "variable REDUCE_HET_DICT to /usr/share/reduce/reduce_wwPDB_het_dict.txt"
+}
+
+pkg_postinst() {
+ pkg_info
+}