summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-06-23 15:06:19 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-06-23 15:06:19 +0000
commit9b3a18d8078ce8894a63ee05959998aea7f047fc (patch)
tree0f54840490757f9714c7f30863834d8222fc0875 /sci-chemistry/gamess
parentreadding ~amd64 per bug 119877 (diff)
downloadgentoo-2-9b3a18d8078ce8894a63ee05959998aea7f047fc.tar.gz
gentoo-2-9b3a18d8078ce8894a63ee05959998aea7f047fc.tar.bz2
gentoo-2-9b3a18d8078ce8894a63ee05959998aea7f047fc.zip
Disable linking against external blas when compiling with ifc and print out a warning.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'sci-chemistry/gamess')
-rw-r--r--sci-chemistry/gamess/ChangeLog7
-rw-r--r--sci-chemistry/gamess/gamess-20060222.2.ebuild9
2 files changed, 12 insertions, 4 deletions
diff --git a/sci-chemistry/gamess/ChangeLog b/sci-chemistry/gamess/ChangeLog
index 8e9053bc5c29..78b4d1c23b49 100644
--- a/sci-chemistry/gamess/ChangeLog
+++ b/sci-chemistry/gamess/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/gamess
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/ChangeLog,v 1.13 2006/05/23 13:29:17 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/ChangeLog,v 1.14 2006/06/23 15:06:19 markusle Exp $
+
+ 23 Jun 2006; Markus Dittrich <markusle@gentoo.org>
+ gamess-20060222.2.ebuild:
+ Disable linking against external blas when compiling with ifc and
+ print out a warning.
23 May 2006; Markus Dittrich <markusle@gentoo.org>
gamess-20060222.2.ebuild:
diff --git a/sci-chemistry/gamess/gamess-20060222.2.ebuild b/sci-chemistry/gamess/gamess-20060222.2.ebuild
index 40e9eb2f7832..24703ffd0841 100644
--- a/sci-chemistry/gamess/gamess-20060222.2.ebuild
+++ b/sci-chemistry/gamess/gamess-20060222.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-20060222.2.ebuild,v 1.5 2006/05/23 13:29:17 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-20060222.2.ebuild,v 1.6 2006/06/23 15:06:19 markusle Exp $
inherit eutils toolchain-funcs fortran flag-o-matic
@@ -43,7 +43,10 @@ pkg_setup() {
# blas and ifc don't go together
if use blas && [[ "${FORTRANC}" = "ifc" ]]; then
- die "${PN} can not be compiled with USE=blas and ifc"
+ echo
+ ewarn "${PN} can not be compiled with USE=blas and ifc."
+ ewarn "Linking against GAMESS' internal blas instead."
+ echo
fi
}
@@ -112,7 +115,7 @@ src_unpack() {
fi
# use proper blas
- if ! use blas; then
+ if ! use blas || [[ "${FORTRANC}" = "ifc" ]]; then
sed -e "s|/usr/lib/libblas.a|/usr/lib/dontuselibblas.a|" \
-i lked || die "Failed to adjust blas in lked"
fi