summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 08:55:54 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 08:55:54 +0000
commitc8f20f470b8420f2b367367139df5e43958cc8a9 (patch)
tree397ec4174242ec26e9d0101f1a7e55915cfabd4f /sci-chemistry/apbs
parentx86 stable wrt bug #348636 (diff)
downloadgentoo-2-c8f20f470b8420f2b367367139df5e43958cc8a9.tar.gz
gentoo-2-c8f20f470b8420f2b367367139df5e43958cc8a9.tar.bz2
gentoo-2-c8f20f470b8420f2b367367139df5e43958cc8a9.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/apbs')
-rw-r--r--sci-chemistry/apbs/ChangeLog6
-rw-r--r--sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild12
-rw-r--r--sci-chemistry/apbs/apbs-1.3-r1.ebuild6
-rw-r--r--sci-chemistry/apbs/apbs-1.3.ebuild6
4 files changed, 15 insertions, 15 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index dc2b15fb7380..8b312e63ecb5 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.44 2010/11/04 09:40:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.45 2010/12/16 08:55:54 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> apbs-1.2.1b-r4.ebuild,
+ apbs-1.3.ebuild, apbs-1.3-r1.ebuild:
+ Removal of fortran.eclass, #348851
*apbs-1.3-r1 (04 Nov 2010)
diff --git a/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild b/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
index 151b2b833424..1e8a5af64d69 100644
--- a/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
+++ b/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild,v 1.8 2010/10/27 17:19:45 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild,v 1.9 2010/12/16 08:55:54 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-FORTRAN="g77 gfortran ifc"
-inherit autotools eutils flag-o-matic fortran python versionator
+inherit autotools eutils flag-o-matic python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -21,7 +20,8 @@ LICENSE="BSD"
IUSE="arpack doc mpi openmp python tools"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-DEPEND="dev-libs/maloc[mpi=]
+DEPEND="
+ dev-libs/maloc[mpi=]
virtual/blas
sys-libs/readline
arpack? ( sci-libs/arpack )
@@ -32,11 +32,11 @@ S="${WORKDIR}"/"${MY_P}-source"
pkg_setup() {
use python && python_set_active_version 2
- fortran_pkg_setup
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-openmp.patch \
+ epatch \
+ "${FILESDIR}"/${P}-openmp.patch \
"${FILESDIR}"/${P}-install-fix.patch \
"${FILESDIR}"/${PN}-1.2.0-contrib.patch \
"${FILESDIR}"/${PN}-1.2.0-link.patch \
diff --git a/sci-chemistry/apbs/apbs-1.3-r1.ebuild b/sci-chemistry/apbs/apbs-1.3-r1.ebuild
index f47d8c077b56..8d870d36382c 100644
--- a/sci-chemistry/apbs/apbs-1.3-r1.ebuild
+++ b/sci-chemistry/apbs/apbs-1.3-r1.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r1.ebuild,v 1.1 2010/11/04 09:40:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r1.ebuild,v 1.2 2010/12/16 08:55:54 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-FORTRAN="g77 gfortran ifc"
-inherit autotools eutils flag-o-matic fortran python versionator
+inherit autotools eutils flag-o-matic python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -41,7 +40,6 @@ S="${WORKDIR}"/"${MY_P}-source"
pkg_setup() {
use python && python_set_active_version 2
- fortran_pkg_setup
if use mpi && use python; then
einfo "mpi and python support are incompatible"
einfo "Disabling USE=python"
diff --git a/sci-chemistry/apbs/apbs-1.3.ebuild b/sci-chemistry/apbs/apbs-1.3.ebuild
index 803d60cdc66f..27e6df772c5e 100644
--- a/sci-chemistry/apbs/apbs-1.3.ebuild
+++ b/sci-chemistry/apbs/apbs-1.3.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3.ebuild,v 1.3 2010/11/01 17:25:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3.ebuild,v 1.4 2010/12/16 08:55:54 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-FORTRAN="g77 gfortran ifc"
-inherit autotools eutils flag-o-matic fortran python versionator
+inherit autotools eutils flag-o-matic python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -41,7 +40,6 @@ S="${WORKDIR}"/"${MY_P}-source"
pkg_setup() {
use python && python_set_active_version 2
- fortran_pkg_setup
if use mpi && use python; then
einfo "mpi and python support are incompatible"
einfo "Disabling USE=python"