summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-07-02 08:56:56 +0000
committerJustin Lecher <jlec@gentoo.org>2011-07-02 08:56:56 +0000
commitd62ef6a65c30e0584e0d2cdd456cbdb19da0d69b (patch)
tree7b231679c6a7c5b88091715269e501d417774b59 /sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
parentUse pkg-config to detect mmdb and lapack libs (diff)
downloadgentoo-2-d62ef6a65c30e0584e0d2cdd456cbdb19da0d69b.tar.gz
gentoo-2-d62ef6a65c30e0584e0d2cdd456cbdb19da0d69b.tar.bz2
gentoo-2-d62ef6a65c30e0584e0d2cdd456cbdb19da0d69b.zip
Use pkg-config to detect mmdb and lapack libs
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild')
-rw-r--r--sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild b/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
index 57f1b2f70d94..00f87514ed85 100644
--- a/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
+++ b/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild,v 1.11 2011/06/21 16:07:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild,v 1.12 2011/07/02 08:56:56 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
+inherit autotools eutils flag-o-matic fortran-2 python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -80,7 +80,7 @@ src_configure() {
econf \
--disable-maloc-rebuild \
--enable-shared \
- --with-blas=-lblas \
+ --with-blas="$(pkg-config --libs blas)" \
$(use_enable openmp) \
$(use_enable python) \
$(use_enable tools) \