summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-22 13:40:00 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-22 13:40:00 +0000
commit683a82710c07ca0ea0c0b2f6d62e92ec3f068580 (patch)
tree4e95ea0d5b5ffbf634d04478ee529f0bb29ab93c /sci-calculators
parentMask sys-apps/mkinitrd for removal wrt #324741. (diff)
downloadgentoo-2-683a82710c07ca0ea0c0b2f6d62e92ec3f068580.tar.gz
gentoo-2-683a82710c07ca0ea0c0b2f6d62e92ec3f068580.tar.bz2
gentoo-2-683a82710c07ca0ea0c0b2f6d62e92ec3f068580.zip
Including
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/hexcalc/ChangeLog11
-rw-r--r--sci-calculators/hexcalc/files/hexcalc-keypad.diff116
-rw-r--r--sci-calculators/hexcalc/hexcalc-1.11-r2.ebuild (renamed from sci-calculators/hexcalc/hexcalc-1.11-r1.ebuild)27
3 files changed, 140 insertions, 14 deletions
diff --git a/sci-calculators/hexcalc/ChangeLog b/sci-calculators/hexcalc/ChangeLog
index 1519fb6d3634..a6f5b04e67e6 100644
--- a/sci-calculators/hexcalc/ChangeLog
+++ b/sci-calculators/hexcalc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-calculators/hexcalc
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/hexcalc/ChangeLog,v 1.9 2008/11/17 22:05:07 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/hexcalc/ChangeLog,v 1.10 2010/06/22 13:40:00 jlec Exp $
+
+*hexcalc-1.11-r2 (22 Jun 2010)
+
+ 22 Jun 2010; Justin Lecher <jlec@gentoo.org> -hexcalc-1.11-r1.ebuild,
+ +hexcalc-1.11-r2.ebuild, +files/hexcalc-keypad.diff:
+ Including patch for Keypad, #156390; respecting users choices of CC and
+ FLAGS
17 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
files/hexcalc-order.diff:
diff --git a/sci-calculators/hexcalc/files/hexcalc-keypad.diff b/sci-calculators/hexcalc/files/hexcalc-keypad.diff
new file mode 100644
index 000000000000..1becd895c1c3
--- /dev/null
+++ b/sci-calculators/hexcalc/files/hexcalc-keypad.diff
@@ -0,0 +1,116 @@
+--- hexcalc.c 1989-11-22 22:29:06.000000000 +0100
++++ hexcalc.c.new 2006-11-27 11:38:07.000000000 +0100
+@@ -208,46 +208,73 @@
+ };
+
+ static String defaultTranslations =
+- ":<Key>(: DoKey(\"(\")\n\
+- :<Key>&: DoKey(&)\n\
+- :<Key>^: DoKey(^)\n\
+- :<Key>): DoKey(\")\")\n\
+- Ctrl<Key>c: DoKey(off)\n\
+- :<Key>H: DoKey(hex)\n\
+- :<Key>O: DoKey(oct)\n\
+- :<Key>D: DoKey(dec)\n\
+- :<Key>B: DoKey(bin)\n\
+- :<Key>R: DoKey(Rcl)\n\
+- :<Key>S: DoKey(Sto)\n\
+- :<Key>s: DoKey(16)\n\
+- :<Key>l: DoKey(32)\n\
+- :<Key>+: DoKey(+)\n\
+- :<Key>-: DoKey(-)\n\
+- :<Key>*: DoKey(*)\n\
+- :<Key>/: DoKey(/)\n\
+- :<Key>%: DoKey(%)\n\
+- :<Key>>: DoKey(>>)\n\
+- :<Key><: DoKey(<<)\n\
+- :<Key>0: DoKey(0)\n\
+- :<Key>1: DoKey(1)\n\
+- :<Key>2: DoKey(2)\n\
+- :<Key>3: DoKey(3)\n\
+- :<Key>4: DoKey(4)\n\
+- :<Key>5: DoKey(5)\n\
+- :<Key>6: DoKey(6)\n\
+- :<Key>7: DoKey(7)\n\
+- :<Key>8: DoKey(8)\n\
+- :<Key>9: DoKey(9)\n\
+- :<Key>a: DoKey(a)\n\
+- :<Key>b: DoKey(b)\n\
+- :<Key>c: DoKey(c)\n\
+- :<Key>d: DoKey(d)\n\
+- :<Key>e: DoKey(e)\n\
+- :<Key>f: DoKey(f)\n\
+- Ctrl<Key>h: Delete()\n\
+- <Key>Delete: Delete()\n\
+- :<Key>=: DoKey(=)\n\
+- :<Key>Return: DoKey(=)"
++ ":<Key>(: DoKey(\"(\")\n\
++ :<Key>&: DoKey(&)\n\
++ :<Key>^: DoKey(^)\n\
++ :<Key>): DoKey(\")\")\n\
++ Ctrl<Key>c: DoKey(off)\n\
++ :<Key>H: DoKey(hex)\n\
++ :<Key>O: DoKey(oct)\n\
++ :<Key>D: DoKey(dec)\n\
++ :<Key>B: DoKey(bin)\n\
++ :<Key>R: DoKey(Rcl)\n\
++ :<Key>S: DoKey(Sto)\n\
++ :<Key>s: DoKey(16)\n\
++ :<Key>l: DoKey(32)\n\
++ :<Key>+: DoKey(+)\n\
++ :<Key>KP_Add: DoKey(+)\n\
++ :<Key>-: DoKey(-)\n\
++ :<Key>KP_Subtract: DoKey(-)\n\
++ :<Key>*: DoKey(*)\n\
++ :<Key>KP_Multiply: DoKey(*)\n\
++ :<Key>/: DoKey(/)\n\
++ :<Key>KP_Divide: DoKey(/)\n\
++ :<Key>%: DoKey(%)\n\
++ :<Key>>: DoKey(>>)\n\
++ :<Key><: DoKey(<<)\n\
++ :<Key>0: DoKey(0)\n\
++ :<Key>KP_0: DoKey(0)\n\
++ :<Key>KP_Insert: DoKey(0)\n\
++ :<Key>1: DoKey(1)\n\
++ :<Key>KP_1: DoKey(1)\n\
++ :<Key>KP_End: DoKey(1)\n\
++ :<Key>2: DoKey(2)\n\
++ :<Key>KP_2: DoKey(2)\n\
++ :<Key>KP_Down: DoKey(2)\n\
++ :<Key>3: DoKey(3)\n\
++ :<Key>KP_3: DoKey(3)\n\
++ :<Key>KP_Next: DoKey(3)\n\
++ :<Key>4: DoKey(4)\n\
++ :<Key>KP_4: DoKey(4)\n\
++ :<Key>KP_Left: DoKey(4)\n\
++ :<Key>5: DoKey(5)\n\
++ :<Key>KP_5: DoKey(5)\n\
++ :<Key>KP_Begin: DoKey(5)\n\
++ :<Key>6: DoKey(6)\n\
++ :<Key>KP_6: DoKey(6)\n\
++ :<Key>KP_Right: DoKey(6)\n\
++ :<Key>7: DoKey(7)\n\
++ :<Key>KP_7: DoKey(7)\n\
++ :<Key>KP_Home: DoKey(7)\n\
++ :<Key>8: DoKey(8)\n\
++ :<Key>KP_8: DoKey(8)\n\
++ :<Key>KP_Up: DoKey(8)\n\
++ :<Key>9: DoKey(9)\n\
++ :<Key>KP_9: DoKey(9)\n\
++ :<Key>KP_Prior: DoKey(9)\n\
++ :<Key>a: DoKey(a)\n\
++ :<Key>b: DoKey(b)\n\
++ :<Key>c: DoKey(c)\n\
++ :<Key>d: DoKey(d)\n\
++ :<Key>e: DoKey(e)\n\
++ :<Key>f: DoKey(f)\n\
++ Ctrl<Key>h: Delete()\n\
++ <Key>Delete: Delete()\n\
++ <Key>KP_Delete: Delete()\n\
++ <Key>KP_Decimal: Delete()\n\
++ :<Key>=: DoKey(=)\n\
++ :<Key>KP_Enter: DoKey(=)\n\
++ :<Key>Return: DoKey(=)"
+ ;
+
+
diff --git a/sci-calculators/hexcalc/hexcalc-1.11-r1.ebuild b/sci-calculators/hexcalc/hexcalc-1.11-r2.ebuild
index 06e3581b9a03..aa39bedb520a 100644
--- a/sci-calculators/hexcalc/hexcalc-1.11-r1.ebuild
+++ b/sci-calculators/hexcalc/hexcalc-1.11-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/hexcalc/hexcalc-1.11-r1.ebuild,v 1.2 2007/07/22 07:29:44 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/hexcalc/hexcalc-1.11-r2.ebuild,v 1.1 2010/06/22 13:40:00 jlec Exp $
-inherit eutils
+EAPI="3"
+
+inherit eutils toolchain-funcs
DESCRIPTION="A simple hex calculator for X"
HOMEPAGE="ftp://ftp.x.org/R5contrib/"
@@ -19,21 +21,22 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- epatch ${FILESDIR}/${PN}-order.diff
+src_prepare() {
+ epatch ${FILESDIR}/${PN}-* || die
}
src_compile() {
xmkmf || die
- make || die
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ CCLINK="$(tc-getCC)" \
+ LDOPTIONS="${LDFLAGS}" \
+ || die
}
src_install() {
-
- dobin hexcalc
+ dobin hexcalc || die
mv hexcalc.man hexcalc.1
- doman hexcalc.1
+ doman hexcalc.1 || die
}