summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-03-15 21:23:34 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-03-15 21:23:34 +0000
commitc4cd693db35d42d797b0389c2bd2a9c0a51fde61 (patch)
tree17b54ca03fd96f78cead89fd492c2adecb03e8a8 /sci-calculators/tilp2
parentppc stable wrt #359059 (diff)
downloadgentoo-2-c4cd693db35d42d797b0389c2bd2a9c0a51fde61.tar.gz
gentoo-2-c4cd693db35d42d797b0389c2bd2a9c0a51fde61.tar.bz2
gentoo-2-c4cd693db35d42d797b0389c2bd2a9c0a51fde61.zip
Version bump
(Portage version: 2.1.9.43/cvs/Linux x86_64)
Diffstat (limited to 'sci-calculators/tilp2')
-rw-r--r--sci-calculators/tilp2/ChangeLog7
-rw-r--r--sci-calculators/tilp2/tilp2-1.14.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/sci-calculators/tilp2/ChangeLog b/sci-calculators/tilp2/ChangeLog
index 398fefa86d50..f17b20718b87 100644
--- a/sci-calculators/tilp2/ChangeLog
+++ b/sci-calculators/tilp2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-calculators/tilp2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tilp2/ChangeLog,v 1.5 2011/03/02 13:32:26 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tilp2/ChangeLog,v 1.6 2011/03/15 21:23:34 bicatali Exp $
+
+*tilp2-1.14 (15 Mar 2011)
+
+ 15 Mar 2011; Sébastien Fabbro <bicatali@gentoo.org> +tilp2-1.14.ebuild:
+ Version bump
02 Mar 2011; Justin Lecher <jlec@gentoo.org> tilp2-1.12.ebuild:
Correct Slots for gtk 3 introduction to tree
diff --git a/sci-calculators/tilp2/tilp2-1.14.ebuild b/sci-calculators/tilp2/tilp2-1.14.ebuild
new file mode 100644
index 000000000000..0a135388f173
--- /dev/null
+++ b/sci-calculators/tilp2/tilp2-1.14.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tilp2/tilp2-1.14.ebuild,v 1.1 2011/03/15 21:23:34 bicatali Exp $
+
+EAPI="3"
+inherit eutils
+
+DESCRIPTION="Communication program for Texas Instruments calculators "
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp"
+SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls threads xinerama"
+
+RDEPEND="dev-libs/glib:2
+ gnome-base/libglade:2.0
+ x11-libs/gtk+:2
+ >=sci-libs/libticalcs2-1.1.5
+ >=sci-libs/libticables2-1.3.1
+ >=sci-libs/libtifiles2-1.1.3
+ >=sci-libs/libticonv-1.1.1
+ nls? ( virtual/libintl )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_configure() {
+ # kde seems to be kde3 only
+ econf \
+ --disable-rpath \
+ --without-kde \
+ $(use_enable nls) \
+ $(use_enable threads threading) \
+ $(use_with xinerama)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ rm -f "${ED}"usr/share/${PN}/{Manpage.txt,COPYING,RELEASE,AUTHORS,LICENSES}
+ dodoc README AUTHORS ChangeLog RELEASE TODO
+ make_desktop_entry tilp "TiLP TI Linker" \
+ "${EPREFIX}"/usr/share/${PN}/pixmaps/icon.xpm
+}