summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-03 20:07:39 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-03 20:07:39 +0000
commit5f132c7c1ac58f04d00d183a8a7d08ff477377c1 (patch)
treecbbddd5e08b0fb87ee564d69a50fb55227cf2bcc /sci-biology
parentUnmask mplayer2 again... (diff)
downloadgentoo-2-5f132c7c1ac58f04d00d183a8a7d08ff477377c1.tar.gz
gentoo-2-5f132c7c1ac58f04d00d183a8a7d08ff477377c1.tar.bz2
gentoo-2-5f132c7c1ac58f04d00d183a8a7d08ff477377c1.zip
Version bump.
(Portage version: 2.2.0_alpha29_p8/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/biopython/ChangeLog8
-rw-r--r--sci-biology/biopython/biopython-1.57.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index 645fd6cdd31d..21e26ada8e3c 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/biopython
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.59 2011/01/30 19:07:34 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.60 2011/04/03 20:07:39 arfrever Exp $
+
+*biopython-1.57 (03 Apr 2011)
+
+ 03 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +biopython-1.57.ebuild:
+ Version bump.
30 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-biopython-1.55.ebuild:
diff --git a/sci-biology/biopython/biopython-1.57.ebuild b/sci-biology/biopython/biopython-1.57.ebuild
new file mode 100644
index 000000000000..27fe75d23b0d
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.57.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.57.ebuild,v 1.1 2011/04/03 20:07:39 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="Biopython - Python modules for computational molecular biology"
+HOMEPAGE="http://www.biopython.org http://pypi.python.org/pypi/biopython"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql postgres"
+
+RDEPEND="dev-python/numpy
+ >=dev-python/reportlab-2.0
+ mysql? ( dev-python/mysql-python )
+ postgres? ( dev-python/psycopg )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS="CONTRIB DEPRECATED NEWS README"
+PYTHON_MODNAME="Bio BioSQL"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${PN}-1.51-flex.patch"
+}
+
+src_test() {
+ testing() {
+ cd Tests
+ PYTHONPATH="$(ls -d ../build/lib.*)" "$(PYTHON)" run_tests.py
+ }
+ python_execute_function --nonfatal -s testing
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r Doc/* || die "Installation of documentation failed"
+ insinto /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}usr/share/${PN}" || die "Installation of shared files failed"
+}