summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-13 10:49:23 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-13 10:49:23 +0000
commit464d4f814505d8f7dd9d94acfc22c51d1369c4a6 (patch)
treea078fc89420032c344151820ba197f65f15df3bc /sci-biology
parentVersion bump (diff)
downloadgentoo-2-464d4f814505d8f7dd9d94acfc22c51d1369c4a6.tar.gz
gentoo-2-464d4f814505d8f7dd9d94acfc22c51d1369c4a6.tar.bz2
gentoo-2-464d4f814505d8f7dd9d94acfc22c51d1369c4a6.zip
sci-biology/ncbi-tools: Change Version numbers from x to 0.x in order to be able to follow upstream new versioning scheme; Drop old unstable
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/ncbi-tools/ChangeLog10
-rw-r--r--sci-biology/ncbi-tools/ncbi-tools-0.20080302.ebuild223
-rw-r--r--sci-biology/ncbi-tools/ncbi-tools-0.20090809.ebuild (renamed from sci-biology/ncbi-tools/ncbi-tools-20100808.ebuild)55
3 files changed, 251 insertions, 37 deletions
diff --git a/sci-biology/ncbi-tools/ChangeLog b/sci-biology/ncbi-tools/ChangeLog
index e274e46a652b..5d5fe315b1f4 100644
--- a/sci-biology/ncbi-tools/ChangeLog
+++ b/sci-biology/ncbi-tools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-biology/ncbi-tools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/ncbi-tools/ChangeLog,v 1.84 2012/05/22 18:32:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/ncbi-tools/ChangeLog,v 1.85 2012/06/13 10:49:23 jlec Exp $
+
+*ncbi-tools-0.20090809 (13 Jun 2012)
+*ncbi-tools-0.20080302 (13 Jun 2012)
+
+ 13 Jun 2012; Justin Lecher <jlec@gentoo.org> +ncbi-tools-0.20080302.ebuild,
+ +ncbi-tools-0.20090809.ebuild, -ncbi-tools-20100808.ebuild:
+ Change Version numbers from x to 0.x in order to be able to follow upstream
+ new versioning scheme; Drop old unstable
*ncbi-tools-2.2.26 (22 May 2012)
diff --git a/sci-biology/ncbi-tools/ncbi-tools-0.20080302.ebuild b/sci-biology/ncbi-tools/ncbi-tools-0.20080302.ebuild
new file mode 100644
index 000000000000..14a02acf2bd9
--- /dev/null
+++ b/sci-biology/ncbi-tools/ncbi-tools-0.20080302.ebuild
@@ -0,0 +1,223 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/ncbi-tools/ncbi-tools-0.20080302.ebuild,v 1.1 2012/06/13 10:49:23 jlec Exp $
+
+EAPI=1
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="Development toolkit and applications for computational biology"
+HOMEPAGE="http://www.ncbi.nlm.nih.gov/"
+SRC_URI="
+ mirror://gentoo/${PN}-${PV/0./}.tar.gz
+ doc? ( mirror://gentoo/${PN}-sdk-doc.tar.bz2 )"
+
+# mpi? ( mirror://gentoo/mpiblast-20070826.tar.gz )
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ppc64 ~sparc x86"
+
+# IUSE="doc mpi X"
+# mpiblast 1.5.0beta1 doesn't compile as advertised with this ncbi release.
+# Currently seeking a fix.
+
+IUSE="doc X"
+
+RDEPEND="app-shells/tcsh
+ dev-lang/perl
+ media-libs/libpng
+ X? ( >=x11-libs/openmotif-2.3:0 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/pmake"
+
+# mpi? ( virtual/mpi )
+
+S="${WORKDIR}/ncbi"
+
+EXTRA_VIB="asn2all asn2asn"
+
+pkg_setup() {
+ echo
+ ewarn 'Please note that the NCBI toolkit (and especially the X'
+ ewarn 'applications) are known to have compilation and run-time'
+ ewarn 'problems when compiled with agressive compilation flags. The'
+ ewarn '"-O3" flag is filtered by the ebuild on the x86 architecture if'
+ ewarn 'X support is enabled.'
+ echo
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-extra_vib.patch
+
+ if use ppc64; then
+ epatch "${FILESDIR}"/${PN}-lop.patch
+ fi
+
+# if use mpi; then
+# cd "${WORKDIR}"
+# epatch "${WORKDIR}"/mpiblast/ncbi_Mar2007_evalue.patch
+# fi
+
+ if ! use X; then
+ cd "${S}"/make
+ sed -e "s:\#set HAVE_OGL=0:set HAVE_OGL=0:" \
+ -e "s:\#set HAVE_MOTIF=0:set HAVE_MOTIF=0:" \
+ -i makedis.csh || die
+ else
+ if use x86; then
+ # X applications segfault on startup on x86 with -O3.
+ replace-flags '-O3' '-O2'
+ fi
+ fi
+
+ # Apply user C flags...
+ cd "${S}"/platform
+ # ... on x86...
+ sed -e "s/NCBI_CFLAGS1 = -c/NCBI_CFLAGS1 = -c ${CFLAGS}/" \
+ -e "s/NCBI_LDFLAGS1 = -O3 -mcpu=pentium4/NCBI_LDFLAGS1 = ${CFLAGS}/" \
+ -e "s/NCBI_OPTFLAG = -O3 -mcpu=pentium4/NCBI_OPTFLAG = ${CFLAGS}/" \
+ -i linux-x86.ncbi.mk || die
+ # ... on alpha...
+ sed -e "s/NCBI_CFLAGS1 = -c/NCBI_CFLAGS1 = -c ${CFLAGS}/" \
+ -e "s/NCBI_LDFLAGS1 = -O3 -mieee/NCBI_LDFLAGS1 = -mieee ${CFLAGS}/" \
+ -e "s/NCBI_OPTFLAG = -O3 -mieee/NCBI_OPTFLAG = -mieee ${CFLAGS}/" \
+ -i linux-alpha.ncbi.mk || die
+ # ... on hppa...
+ sed -e "s/NCBI_CFLAGS1 = -c/NCBI_CFLAGS1 = -c ${CFLAGS}/" \
+ -e "s/NCBI_LDFLAGS1 = -O2/NCBI_LDFLAGS1 = ${CFLAGS}/" \
+ -e "s/NCBI_OPTFLAG = -O2/NCBI_OPTFLAG = ${CFLAGS}/" \
+ -i hppalinux.ncbi.mk || die
+ # ... on ppc...
+ sed -e "s/NCBI_CFLAGS1 = -c/NCBI_CFLAGS1 = -c ${CFLAGS}/" \
+ -e "s/NCBI_LDFLAGS1 = -O2/NCBI_LDFLAGS1 = ${CFLAGS}/" \
+ -e "s/NCBI_OPTFLAG = -O2/NCBI_OPTFLAG = ${CFLAGS}/" \
+ -i ppclinux.ncbi.mk || die
+ # ... on generic 64-bit Linux...
+ sed -e "s/NCBI_CFLAGS1 = -c/NCBI_CFLAGS1 = -c ${CFLAGS}/" \
+ -e "s/NCBI_LDFLAGS1 = -O3/NCBI_LDFLAGS1 = ${CFLAGS}/" \
+ -e "s/NCBI_OPTFLAG = -O3/NCBI_OPTFLAG = ${CFLAGS}/" \
+ -i linux64.ncbi.mk || die
+ # ... on generic Linux.
+ sed -e "s/NCBI_CFLAGS1 = -c/NCBI_CFLAGS1 = -c ${CFLAGS}/" \
+ -e "s/NCBI_LDFLAGS1 = -O3/NCBI_LDFLAGS1 = ${CFLAGS}/" \
+ -e "s/NCBI_OPTFLAG = -O3/NCBI_OPTFLAG = ${CFLAGS}/" \
+ -i linux.ncbi.mk || die
+
+ # Put in our MAKEOPTS (doesn't work).
+ # sed -e "s:make \$MFLG:make ${MAKEOPTS}:" -i ncbi/make/makedis.csh
+
+ # Set C compiler...
+ # ... on x86...
+ sed -i -e "s/NCBI_CC = gcc/NCBI_CC = $(tc-getCC)/" linux-x86.ncbi.mk || die
+ # ... on alpha...
+ sed -i -e "s/NCBI_CC = gcc/NCBI_CC = $(tc-getCC)/" linux-alpha.ncbi.mk || die
+ # ... on hppa...
+ sed -i -e "s/NCBI_CC = gcc/NCBI_CC = $(tc-getCC)/" hppalinux.ncbi.mk || die
+ # ... on ppc...
+ sed -i -e "s/NCBI_CC = gcc/NCBI_CC = $(tc-getCC)/" ppclinux.ncbi.mk || die
+ # ... on generic 64-bit Linux...
+ sed -i -e "s/NCBI_CC = gcc/NCBI_CC = $(tc-getCC)/" linux64.ncbi.mk || die
+ # ... on generic Linux.
+ sed -i -e "s/NCBI_CC = gcc/NCBI_CC = $(tc-getCC)/" linux.ncbi.mk || die
+
+ # We use dynamic libraries
+ sed -i -e "s/-Wl,-Bstatic//" *linux*.ncbi.mk || die
+
+ # GNU make 3.81 is confused by those nightmarish Makefiles, so we use pmake
+ # instead. The right solution would be to fix the Makefiles. (Be my guest.)
+ cd "${S}"/make
+ sed -i -e "s%CMD='make%CMD='/usr/bin/pmake%" makedis.csh || die \
+ "Failed to replace make by pmake."
+}
+
+src_compile() {
+ export EXTRA_VIB
+ cd "${WORKDIR}"
+ ncbi/make/makedis.csh || die
+ mkdir "${S}"/cgi
+ mkdir "${S}"/real
+ mv "${S}"/bin/*.cgi "${S}"/cgi || die
+ mv "${S}"/bin/*.REAL "${S}"/real || die
+
+# mpiblast fails to compile... perhaps mpiblast2 contain a fix
+# if use mpi; then
+# cd "${WORKDIR}"/mpiblast
+# AM_OPT="-a"
+# eautoreconf
+# econf --with-ncbi="${WORKDIR}"/ncbi --with-mpi=/usr
+# emake || die
+# fi
+}
+
+src_install() {
+ dobin "${S}"/bin/* || die "Failed to install binaries."
+ for i in ${EXTRA_VIB}; do
+ dobin "${S}"/build/${i} || die "Failed to install binaries."
+ done
+ dolib "${S}"/lib/* || die "Failed to install libraries."
+ mkdir -p "${D}"/usr/include/ncbi
+ cp -RL "${S}"/include/* "${D}"/usr/include/ncbi || \
+ die "Failed to install headers."
+
+# if use mpi; then
+# cd "${WORKDIR}"/mpiblast
+# make install DESTDIR="${D}" || die "Failed to install MPI blast."
+# fi
+
+ # TODO: Web apps
+ #insinto /usr/share/ncbi/lib/cgi
+ #doins ${S}/cgi/*
+ #insinto /usr/share/ncbi/lib/real
+ #doins ${S}/real/*
+ # TODO: Add support for wwwblast.
+
+ # Basic documentation
+ dodoc "${S}"/{README,VERSION,doc/{*.txt,README.asn2xml}} || \
+ die "Failed to install basic documentation."
+ newdoc "${S}"/doc/fa2htgs/README README.fa2htgs || \
+ die "Failed renaming fa2htgs documentation."
+ newdoc "${S}"/config/README README.config || \
+ die "Failed renaming config documentation."
+ newdoc "${S}"/network/encrypt/README README.encrypt || \
+ die "Failed renaming encrypt documentation."
+ newdoc "${S}"/network/nsclilib/readme README.nsclilib || \
+ die "Failed renaming nsclilib documentation."
+ newdoc "${S}"/sequin/README README.sequin || \
+ die "Failed renaming sequin documentation."
+ doman "${S}"/doc/man/* || \
+ die "Failed to install man pages."
+
+ # Hypertext user documentation
+ dohtml "${S}"/{README.htm,doc/{*.html,*.gif}} || \
+ die "Failed to install HTML documentation."
+ insinto /usr/share/doc/${PF}/html/blast
+ doins "${S}"/doc/blast/* || die "Failed to install blast HTML documentation."
+
+ # Developer documentation
+ if use doc; then
+ # Hypertext SDK documentation
+ insinto /usr/share/doc/${PF}/html/sdk
+ doins "${WORKDIR}"/${PN}-sdk-doc/* || die
+
+ # Demo programs
+ mkdir "${D}"/usr/share/ncbi
+ mv "${S}"/demo "${D}"/usr/share/ncbi/demo || die
+ fi
+
+ # Shared data (similarity matrices and such) and database directory.
+ insinto /usr/share/ncbi/data
+ doins "${S}"/data/* || die "Failed to install shared data."
+ dodir /usr/share/ncbi/formatdb || die
+
+ # Default config file to set the path for shared data.
+ insinto /etc/ncbi
+ newins "${FILESDIR}"/ncbirc .ncbirc || die "Failed to install config file."
+
+ # Env file to set the location of the config file and BLAST databases.
+ newenvd "${FILESDIR}"/21ncbi-r1 21ncbi || die "Failed to install env file."
+}
diff --git a/sci-biology/ncbi-tools/ncbi-tools-20100808.ebuild b/sci-biology/ncbi-tools/ncbi-tools-0.20090809.ebuild
index 7bc4cb0cd59a..00cb8f688593 100644
--- a/sci-biology/ncbi-tools/ncbi-tools-20100808.ebuild
+++ b/sci-biology/ncbi-tools/ncbi-tools-0.20090809.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/ncbi-tools/ncbi-tools-20100808.ebuild,v 1.4 2010/11/15 21:07:43 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/ncbi-tools/ncbi-tools-0.20090809.ebuild,v 1.1 2012/06/13 10:49:23 jlec Exp $
-EAPI="3"
+EAPI="2"
inherit flag-o-matic toolchain-funcs eutils
DESCRIPTION="Development toolkit and applications for computational biology, including NCBI BLAST"
-LICENSE="public-domain"
HOMEPAGE="http://www.ncbi.nlm.nih.gov/"
-SRC_URI="ftp://ftp.ncbi.nlm.nih.gov/toolbox/ncbi_tools/old/${PV}/ncbi.tar.gz -> ${P}.tar.gz"
+SRC_URI="ftp://ftp.ncbi.nlm.nih.gov/toolbox/ncbi_tools/old/${PV/0./}/ncbi.tar.gz -> ${P}.tar.gz"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+LICENSE="public-domain"
+KEYWORDS="~alpha amd64 ~ppc64 x86"
# IUSE=mpi deprecated, use sci-biology/mpiblast separately
IUSE="doc X"
@@ -60,32 +60,32 @@ src_prepare() {
cd "${S}"/platform
# ... on x86...
sed -e "s/NCBI_CFLAGS1 = -c/NCBI_CFLAGS1 = -c ${CFLAGS}/" \
- -e "s/NCBI_LDFLAGS1 = -O3 -mcpu=pentium4/NCBI_LDFLAGS1 = ${CFLAGS} ${LDFLAGS}/" \
+ -e "s/NCBI_LDFLAGS1 = -O3 -mcpu=pentium4/NCBI_LDFLAGS1 = ${CFLAGS}/" \
-e "s/NCBI_OPTFLAG = -O3 -mcpu=pentium4/NCBI_OPTFLAG = ${CFLAGS}/" \
-i linux-x86.ncbi.mk || die
# ... on alpha...
sed -e "s/NCBI_CFLAGS1 = -c/NCBI_CFLAGS1 = -c ${CFLAGS}/" \
- -e "s/NCBI_LDFLAGS1 = -O3 -mieee/NCBI_LDFLAGS1 = -mieee ${CFLAGS} ${LDFLAGS}/" \
+ -e "s/NCBI_LDFLAGS1 = -O3 -mieee/NCBI_LDFLAGS1 = -mieee ${CFLAGS}/" \
-e "s/NCBI_OPTFLAG = -O3 -mieee/NCBI_OPTFLAG = -mieee ${CFLAGS}/" \
-i linux-alpha.ncbi.mk || die
# ... on hppa...
sed -e "s/NCBI_CFLAGS1 = -c/NCBI_CFLAGS1 = -c ${CFLAGS}/" \
- -e "s/NCBI_LDFLAGS1 = -O2/NCBI_LDFLAGS1 = ${CFLAGS} ${LDFLAGS}/" \
+ -e "s/NCBI_LDFLAGS1 = -O2/NCBI_LDFLAGS1 = ${CFLAGS}/" \
-e "s/NCBI_OPTFLAG = -O2/NCBI_OPTFLAG = ${CFLAGS}/" \
-i hppalinux.ncbi.mk || die
# ... on ppc...
sed -e "s/NCBI_CFLAGS1 = -c/NCBI_CFLAGS1 = -c ${CFLAGS}/" \
- -e "s/NCBI_LDFLAGS1 = -O2/NCBI_LDFLAGS1 = ${CFLAGS} ${LDFLAGS}/" \
+ -e "s/NCBI_LDFLAGS1 = -O2/NCBI_LDFLAGS1 = ${CFLAGS}/" \
-e "s/NCBI_OPTFLAG = -O2/NCBI_OPTFLAG = ${CFLAGS}/" \
-i ppclinux.ncbi.mk || die
# ... on generic 64-bit Linux...
sed -e "s/NCBI_CFLAGS1 = -c/NCBI_CFLAGS1 = -c ${CFLAGS}/" \
- -e "s/NCBI_LDFLAGS1 = -O3/NCBI_LDFLAGS1 = ${CFLAGS} ${LDFLAGS}/" \
+ -e "s/NCBI_LDFLAGS1 = -O3/NCBI_LDFLAGS1 = ${CFLAGS}/" \
-e "s/NCBI_OPTFLAG = -O3/NCBI_OPTFLAG = ${CFLAGS}/" \
-i linux64.ncbi.mk || die
# ... on generic Linux.
sed -e "s/NCBI_CFLAGS1 = -c/NCBI_CFLAGS1 = -c ${CFLAGS}/" \
- -e "s/NCBI_LDFLAGS1 = -O3/NCBI_LDFLAGS1 = ${CFLAGS} ${LDFLAGS}/" \
+ -e "s/NCBI_LDFLAGS1 = -O3/NCBI_LDFLAGS1 = ${CFLAGS}/" \
-e "s/NCBI_OPTFLAG = -O3/NCBI_OPTFLAG = ${CFLAGS}/" \
-i linux.ncbi.mk || die
@@ -108,39 +108,26 @@ src_prepare() {
# We use dynamic libraries
sed -i -e "s/-Wl,-Bstatic//" *linux*.ncbi.mk || die
-
- sed \
- -re "s:/usr(/bin/.*sh):\1:g" \
- -e "s:(/bin/.*sh):${EPREFIX}\1:g" \
- -i $(find "${S}" -type f) || die
}
src_compile() {
export EXTRA_VIB
cd "${WORKDIR}"
- csh ncbi/make/makedis.csh || die
+ ncbi/make/makedis.csh || die
mkdir "${S}"/cgi
mkdir "${S}"/real
mv "${S}"/bin/*.cgi "${S}"/cgi || die
mv "${S}"/bin/*.REAL "${S}"/real || die
- cd "${S}"/demo
- emake \
- -f ../make/makenet.unx \
- CC="$(tc-getCC) ${CFLAGS} -I../include -L../lib" \
- LDFLAGS="${LDFLAGS}" \
- spidey || die
- cp spidey ../bin/ || die
}
src_install() {
- mv "${S}"/bin/cdscan "${S}"/bin/cdscan-ncbi #sci-geosciences/cdat-lite
dobin "${S}"/bin/* || die "Failed to install binaries."
for i in ${EXTRA_VIB}; do
dobin "${S}"/build/${i} || die "Failed to install binaries."
done
dolib "${S}"/lib/* || die "Failed to install libraries."
- mkdir -p "${ED}"/usr/include/ncbi
- cp -RL "${S}"/include/* "${ED}"/usr/include/ncbi || \
+ mkdir -p "${D}"/usr/include/ncbi
+ cp -RL "${S}"/include/* "${D}"/usr/include/ncbi || \
die "Failed to install headers."
# TODO: wwwblast with webapps
@@ -150,7 +137,7 @@ src_install() {
#doins ${S}/real/*
# Basic documentation
- dodoc "${S}"/{README,VERSION,doc/{*.txt,README.*}} || \
+ dodoc "${S}"/{README,VERSION,doc/{*.txt,README.asn2xml}} || \
die "Failed to install basic documentation."
newdoc "${S}"/doc/fa2htgs/README README.fa2htgs || \
die "Failed renaming fa2htgs documentation."
@@ -166,20 +153,16 @@ src_install() {
die "Failed to install man pages."
# Hypertext user documentation
- dohtml "${S}"/{README.htm,doc/{*.html,*.htm,*.gif}} || \
+ dohtml "${S}"/{README.htm,doc/{*.html,*.gif}} || \
die "Failed to install HTML documentation."
insinto /usr/share/doc/${PF}/html/blast
doins "${S}"/doc/blast/* || die "Failed to install blast HTML documentation."
- insinto /usr/share/doc/${PF}/html/images
- doins "${S}"/doc/images/* || die "Failed to install documentation images."
- insinto /usr/share/doc/${PF}/html/seq_install
- doins "${S}"/doc/seq_install/* || die "Failed to install seq_install documentation."
# Developer documentation
if use doc; then
# Demo programs
- mkdir "${ED}"/usr/share/ncbi
- mv "${S}"/demo "${ED}"/usr/share/ncbi/demo || die
+ mkdir "${D}"/usr/share/ncbi
+ mv "${S}"/demo "${D}"/usr/share/ncbi/demo || die
fi
# Shared data (similarity matrices and such) and database directory.